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UNIT I 

Lights in Maya 

List of Default lights in Maya 

1) Ambient Light 

2) Directional Light 

3) Point Light 

4) Spot Light 

5) Area Light 

6) Volume light 

Where will you get these lights? 

In Menu bar, go to create option and select Lights and click on a light you need in the 
scene. 

Rendering Shelf in Maya 

Purpose of each light in Maya 

1) Ambient Light 

Ambient light shine in two ways :- 

a) It shines evenly in  all direction from the location of light. 

b) It shines evenly in all directions from all directions. 

Ambient light  in Maya is used to simulate the combination of direct and indirect lighting. 

More - Attributes of Ambient light in Maya 

2) Directional light 

Directional light is used to simulate sunlight because it uses parallel rays of light as if 
illuminating the object from far distance. The position of light is not important as the 
direction of the arrow. 

Since this light is normally used to simulate sunlight it does not have a decay. 

More – Attributes of Directional light in Maya 
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3) Point Light 

Point lights in Maya shines evenly in all direction from small point source. Point lights 
can be used to simulate light bulb or a star. 

Point light , when enclosed in a geometry (from three sides) acts like a Spot light. 

More – Attributes of Point light in Maya 

4) Spot light 

Spot light in Maya shines a beam of light in a direction defined by a cone. The size of 
cone determines the size of beam. Cone can be rotated to change the direction of the 
beam. 

Spot light is used to simulate Flash light and car headlights.In some cases it can be 
used to simulate sunlight. 

More - Attributes of Spot light in Maya 

5) Area light 

Area light is physical based 2 dimensional rectangular light source. It does not have a 
decay option. Using it in a scene will increase render time. 

It can be used to simulate indirect lighting. Use it and place it wisely in your scene to 
create contact shadows when you are not allowed to use Occlusion pass. 

More - Attributes of Area light in Maya 

6) Volume light 

You can achieve different effect using volume light. Inward behaves like a point light 
and down Axis like a directional light. 

Introduction 

In the real world, when light shines on a surface, the parts of the surface facing toward 

the light source appear illuminated, and the parts of the surface facing away from the 

light source appear dark. If one object is located between a second object and the light 

source, the first object casts a shadow onto the second object. 

Absorption, reflection, and refraction of light 

  The color of the objects we see in the natural world is a result of the way objects 
interact with light. When a light wave strikes an object, it can be absorbed, reflected, or 
refracted by the object. All objects have a degree of reflection and absorption.  
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Note In the natural world, light can also be transmitted by an object. That is, light can 

pass through an object with no effect (an x-ray, for example). These types of light, 

however, are not represented in Autodesk® Maya® because they have no visual effect.  

Default Light Setups 

By default, Maya scenes do not contain light sources.  

However, Maya‘s default lighting helps you to visualize objects in Shaded display in the Scene 

view (press 5). If you turn default lighting off and have no lights in the scene, the scene appears 

black.  

To turn lights on or off, if for example, you want to see or render incandescent objects (for which 

no lighting is required), see Turn default lighting on or off.  

Default light source at render time  

If you render a scene without a light, Maya creates directional light during the render so that 

your objects can be seen. Without it, your objects would not be illuminated; that is, your render 

would be black.  

This default light is parented to the rendered camera. The entire scene is illuminated no matter 

where the camera is facing. The surface areas directly facing the camera are bright while the 

surface areas hidden from the camera are dark. This provides surface contours that look 

realistic.  

After the render completes, Maya removes the default light from the scene.  

NoteThe IPR default light source that is added to the scene during rendering operates much the 

same way as the Maya default light source at render time.  

 The IPR default light source is removed from the scene as soon as the IPR session is 
terminated (for example, when you click the IPR stop button).  

 The IPR default light source is not saved with the scene, preventing you from 
accidentally adding the IPR default light to their saved scene.  

 

Light Working Methods 

Basic Lighting  

We will be using the Pawn file and the Rendering menu set for this exercise.  

Switch to the camera "render_cam" and do a quick render. You will see that the scene 
renders as though there was already a light source. This is a result of Maya's default 

http://download.autodesk.com/us/maya/2011help/files/BoL_Turn_default_lighting_on_or_off.htm
http://www.cs.washington.edu/education/courses/cse458/12au/content/maya_files/pawn.mb
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light source. If you render a scene without a light, Maya creates a directional light during 
the render so that your objects can be seen. Without it, your objects would not be 
illuminated; that is, your render would be black.  

This default light is parented to the rendered camera. This means that the entire scene 
will be illuminated no matter where the camera is facing. As soon as you add a light to 
your scene, the default light source is automatically disabled so that your scene will only 
be lit by the lights you've added. You can also disable the default light in the Render 
Settings, which is recommended for production lighting and rendering.  

 

You can add lights to the scene through the Create → Lights menu, but you will 
probably find the buttons on the Rendering shelf more convenient. Adding a light will 
add a light object to the scene at the origin, which you can then move, rotate, and scale 
like any other object. There are six basic types of lights. The Ambient Light radiates 
diffuse light in all directions based on its position. In general, this light is not used very 
often since it tends to wash out the objects it illuminates. Also, it doesn't interact with 
bump maps.  
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The Directional Light simulates light that comes from very far away, such as the sun. 
This light has a direction, but its position doesn't matter so much. Every object in the 
scene will be illuminated by this light since the light is theoretically made up of a bunch 
of parallel rays. Because of this, Directional Lights are used for broad stroke lighting in 
outdoor scenes. Also because of this, Directional Lights tend to be very bad at casting 
shadows, since they try to expand their shadow maps to cover everything they 
illuminate. As noted, the default light is a Directional Light.  

A Point Light represents a light source that comes from a single point, similar to the 
Ambient Light. This type of light is good for small, open light sources such as light bulbs, 
candles, or torches. Unlike Ambient Lights, Point Lights can emit specular light, which 
creates the bright, shiny highlights you can see on the pawn below. The image below 
was created with a single point light with a Quadratic Decay Rate. The Decay Rate is an 
attribute of most lights that determines the intensity of a light as it gets farther away from 
the light. By default, light intensity does not decay as it travels through space. Decay 
Rate is useful in localizing the effect of a light and making the scene look more realistic, 
since real light decays in a quadratic manner.  
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The Area Light is a light that emits light from one side of a plane. Its position and 
rotation are used to orient the light, but this light is a bit strange since its scale also 
matters. The larger the surface area of the plane, the brighter the light will be. Because 
of this, Area Lights can be a little tricky to work with, but they can be useful for broad 
light sources such as monitors or florescent lights. Below is the light produced by a very 
wide, but narrow Area Light.  
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Volume Lights only illuminate objects that are within the bounding volume of the light. 
As such, the scale and position of the light is very important. In their normal mode of 
operation, they act similar to Point Lights, but you can change their bounds to be a 
sphere, cube, cylinder, or cone. You can also change whether they emit light inward or 
outward. The image below was created by a spherical Volume Light casting light 
inward. Volume Lights tend to be a little fussy, but if you want to restrict light to a very 
specific area, they are a good choice.  
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Last, but not least, is the Spotlight. The Spotlight casts a cone of light from a single 
point. This makes it good for localizing the direction and placement of light, as well as 
being ideal for casting shadows. These properties make Spotlights the most useful type 
of light when lighting a scene. The light cone that the Spotlight casts can be very sharp 
such as in the left image or soft, such as the right image. This can be adjusted by 
changing the Penumbra Angle attribute of the Spotlight.  
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One common artifact associated with Spotlights is Mach Banding, which is caused by 
the discontinuity introduced by the transition from the center of the light to the 
penumbra. Notice how there seems to be a bright ring in the center of the light on the 
left. That area is not significantly brighter than the surrounding pixels, your brain just 
interprets the sudden change in the intensity gradient as important and highlights it. You 
can avoid this problem by increasing the Dropoff attribute of the Spotlight, the effect of 
which can be seen on the right.  

 

One of the most crucial parts of lighting is actually the absence of light. In the real world, 
when an object obstructs a light source, you expect a shadow to be cast behind it. 
However, it is more correct to say that the light casts light everywhere except the 
shadow. Shadows prevent light from reaching certain areas. In Maya, shadows are not 
enabled by default. To enable them for a specific light, go to the Shadows area of the 
Attribute Editor with the light selected. You will find the Depth Map and Raytrace 
Shadow Attributes here.  

The differences between these two types of shadows are relatively unimportant since 
we will be using Depth Map Shadows for most, if not all, of our lighting. Check the Use 
Depth Map Shadows box to enable shadows on the selected light. The two important 
attributes for Depth Map Shadows are Resolution and Filter Size.  
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Resolution determines the detail of the shadow map. Typically this value is a power of 2 
(512, 1024, 2048) and is set to be as large as is needed. Setting this value too low will 
result in shadow aliasing, which can be seen on the left below. This artifact is extremely 
obvious if the object is animating, resulting in a problem called "shadow chattering" 
where the edges of the shadow seem to flicker. By default, the edges of shadows will be 
sharp, which may not be very realistic, depending on your light source. You can blur the 
edges of your shadows by increasing the Filter Size of the shadow. This can be seen in 
the image below on the right.  

 

Another artifact you may come across when using shadows is called shadow banding. 
Shadow banding appears as a series of dark bands, typically in areas that are 
supposed to be shadowed. The artifact arises from a precision error and can be difficult 
to eliminate. You can reduce how visible it is by increasing the shadow Resolution and 
Filter Size. Adjusting the Bias may also help, but tweaking this value too much will either 
remove your shadows completely or place them where they shouldn't be. The image 
below shows you what shadow banding looks like.  

 

There are a few ways to position your lights. The most basic way is to use the 
manipulation tools to move and rotate the light into position. This is a little clumsy, but is 
useful when direction doesn't matter, such as with Point Lights. If you want a light to 
point towards a specific place, you can hit the t key with the light selected. This will 
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allow you to manipulate the position and target of the light seperately. Finally, if you 
want to "look through" a light, go to Panels → Look Through Selected Camera. This 
will allow you to manipulate the light as if it were a camera. This is especially useful with 
Spotlights, since you can see the Cone and Penumbra Angles in the view. One 
drawback of this method is that you are not able to undo your movements. You can 
correct this by going to View → Camera Settings → Undoable Movement, though you 
must do this for every new temporary light camera. 

  

One of the benefits of working in an artificial environment is that you can ignore certain 
laws of physics. One of the most useful laws to ignore is "A light illuminates everything it 
touches". In Maya you can choose what is and is not illuminated by any given light, a 
process called Light Linking. By default, a light illuminates every object in the scene, as 
indicated by the Illuminates by Default box in the light's attributes. Unchecking this box 
will make it so that it illuminates nothing.  

Obviously we need a middle ground between all and nothing. You can find the Light 
Linking Editor under Lighting/Shading → Light Linking Editor. This editor has two 
modes: Light-Centric and Object-Centric. The difference depends on whether you want 
to link lights to objects or objects to lights. For Light-Centric, select the light you are 
interested in, then select or deselect the objects you want linked or unlinked.  

This editor can be a tedious to use if you want to make small light linking changes. To 
quickly link lights, select a set of lights and objects and go to Lighting/Shading → 
Make Light Links. Break Light Links works in a similar manner. The image on the left 
shows a Spotlight linked to only the floor, where it is linked to only the pawn on the right.  
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You now know the basics of lighting. Continue on to the other exercises to learn more 
about the basics of Maya.  

Lightning Concepts 

Basic Lighting Concepts 

It's no surprise that Maya's lighting resembles actual direct-lighting techniques used in 

photography and filmmaking. Lights of various types are placed around a scene to 

illuminate the subjects as they would for a still life or a portrait. Your scene and what's in 

it dictate, to some degree at least, which lights you put where. The type of lights you use 

depends on the desired effect. At the basic level, you want your lights to illuminate the 

scene. Without lights, your cameras have nothing to capture. Although it seems rather 

easy to throw your lights in, turn them all on, and render a scene, that couldn't be further 

from the truth.Although it's easy to insert and configure lights, it's how you light that will 

make or break your scene. Knowing how to do that really only comes with a good deal 

of experience and experimentation, as well as a good eye and patience. 

Lighting Types  

Six types of light are available in Maya: Ambient, Directional, Point, Spot, Area, and 
Volume. These lights are also used when rendering in mental ray. How you use each 
dictates whether they become key, fill, or rim lights. Each light can fill any of those roles, 
although some are better for certain jobs than others. The most commonly used light 
types for most scenes are Spot, Directional, and Ambient. All of these Maya lights 
render in Maya software as well as mental ray. To create each light, choose Create 
Lights, and click the light type. 

Common Light Attributes 

Lights in Maya are treated like any other object node. They can be transformed, rotated, 
scaled, duplicated, deleted, and so forth and are visible as nodes in the Hypergraph and 
Outliner alongside other objects in the scene. Like any other node, lights have attributes 
that govern how they function. 
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Light Linking 

You can control which lights illuminate which objects by using Maya's light linking. 
Inevitably, a time will come when you want to create a special light for a part of your 
scene but not for all of it. However by default, lights created in your scene illuminate all 
objects in the scene. The easiest way to create an exclusive lighting relationship is first 
to create a light and turn off Illuminates by Default in the light's Attribute Editor. This 
ensures that this light won't cast light on any object unless specifically made to do so 
through light linking. To assign your new light to the object(s) you want to illuminate 
exclusively, choose Window Relationship Editors Light Linking Light-Centric. This 
opens the Relationship Editor and sets it for light linking. Light-Centric means the lights 
are featured in the left side of the panel as shown in 

Advanced Lighting Techniques 

Global Illumination and Final Gather in Mental Ray for Maya 

 

Currently, one of the best ways of achieving photo-realistic imagery is to render using 
Mental Ray for Maya. Mental Ray offers a Global Illumination and Final Gather solution, 
which when combined, simulates the physics of real world lighting effects. Now, for the 
first time in 3d, lighting techniques used by photographers and filmmakers can be 
applied to computer graphics. The following is a guide for setting up Global Illumination 
and Final Gather using Mental Ray for Maya. It is based on notes from the web, Maya‘s 
Help manual and good-old fashion experimentation. 

Setting-up 

The first thing I always like to do is develop some sort of plan. As they say, ‗If you don‘t 
know where you‘re going, you probably won‘t get there.‘ Here is a quick set-up sketch I 
did in Photoshop. I have included lighting placement and some material information. 
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The basic idea from the sketch was modelled and setup. Maya has four basic shaders 
to choose from: Lambert, Blinn, Phong or Anisotropic. Lambert has no specular 
highlights, Blinn has soft specular highlights, Phong has hard specular highlights and 
Anisotropic has irregular highlights. Based on the sketch, the first material will be a 
white, matte background that has no shine. A basic Lambert material was used with 
color set to an off white (very light grey) and diffuse increased above 0.8. Next is the 
sphere, which will be used as a prop to study the effects of illumination. A Phong shader 
was used to give it a highly polished, chrome like appearance, so as to be able to better 
study how the light rays are being traced. The last material is the Negative fill. These 
are being used like large barn doors, stopping the light from spilling. To suck the light 
from the scene, a Lambert material was again used, with both the color and diffuse set 
to black. 

 

This is the final scene set-up. Two spot-lights have been added either side of the 
negative fill and are pointed at the wall. Their light will bounce of the white wall, to 
create a soft large light, illuminating the back of the ball. Any spill from the lights is being 
stopped by the black boards. Later the lights will be converted to Mental Ray area lights 
to create softer shadows. 
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As the sphere subject is not receiving any direct illumination a reflector board has been 
added. It will catch reflected light from the screen and illuminate the sphere from the 
front. The same material used for the background has been applied to the reflector 
board. 

A standard hardware render produces an almost black image as most of the illumination 
is to be achieved from bouncing light. 

Global Illumination  

The first part involves setting up the Global Illumination. 
Once a good photon map has been created, then Final 
Gathering will be added to increase indirect illumination. 
Global Illumination using Mental Ray, requires the 
adjustment of two main sections: the light‘s attributes and 
the Render Globals Settings. 

Both light‘s attributes are first set-up. To get realistic 
lighting behaviour, 

 the decay rate is set to Quadratic and  
 the light intensity is initially set to 120.  
 Raytraced shadows are turn on in the Shadow attributes section.  
 Lastly, in the Mental Ray section, the light is set to emit photons. 

To create the Global Illumination solution, the Mental Ray render is selected in the 
Render Globals Settings, and in the ‗mental ray‘ tab, the Quality Preset is set to Draft 
and Global Illumination is turn on in the Caustics and Global Illumination section. 
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Here the initial render is created. The Negative Fill boards were adjusted to give a more 
even lighting. Both the light's intensity was reduced by half down to 60 - giving a total 
combined intensity of 120. The spot lighting effect was also reduced by increasing the 
Penumbra Angle to 10. 

The next stage is to fine tune the Global Illumination. To adjust the overall brightness of 
the scene, the light's Exponent value and Photon Intensity attributes are adjusted. Here 
is Maya Help manual definition for the Exponent value: 

Exponent  

This is similar to decay -- the intensity increases as the value decreases. To increase 
the chances that indirect light will reach a greater distance, decrease the value.  

Visible noise can occur with values less than 1. The default (2) simulates natural 
(quadratic) decay, but violates the conservation-of-energy law (that happens in the 
natural world), so bright spots from distant light sources could occur in unexpected 
locations.  

Phrased another way, higher Exponent values will decrease brightness. Increments of 
0.1 through to 3.5 will gradually decrease the brightness. 

 

This is the same render with an Exponent value of 3. The image is much duller. 
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Global Illumination and Final Gather in Mental Ray for Maya 

As the lights are set to Quadratic decay, and Final Gather will be used at the end, then 
only a little increase in Exponent value, up to 2.2 was used to darken the effect a little. 

Then comes Photon Intensity adjustments. The Maya manual explains: 

Energy (Photon Intensity) 

The amount of light distributed by the light source. Each photon carries a fraction of the 
light source energy. 
8000 is the default. 0 means no photons are emitted.  

If caustic effects are not bright enough, try increasing these values equally, in small 
increments (to 12000, to start) until you have better results.  

If `hot spots' (blown out) areas occur, try decreasing these values equally to around 
4000 or 5000. 

Basically it controls how bright the white spots are (the photons). 

 

Here the Photon Intensity has been increased to 10,000 - just to slightly brighten things 
up. 

One more light attribute to adjust – Global Illumination Photons. The Maya manual 
explains: 

Global Illum Photons 

The number of photons to be generated by the light source and therefore stored in the 
photon map. The default, 10000, is suitable for quick, low-quality renders. To improve 
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the quality, increase this number, incrementally, to 20000 to start (render time will 
increase as a result). Generally, 100000 produces medium quality and 1000000 
produces highly accurate effects. 

This feature then controls quality. In other words, the more photons you can shoot, the 
better the quality. The aim is to increase this value to as high as possible, before render 
times are affected. 

 

Here, the number of Photons has been increased to 50,000. There are now more visible 
white spots. This will be fine tuned in the Render Globals Settings of the render. 

To reduce the number of white spots (visible effect of photons), the Global Illum 
Accuracy is increased in the Render Globals Settings Mental Ray tab. Here is the Maya 
Help manual definition: 

Global Illum Accuracy  

Change the number of photons used to compute the local intensity of global 
illumination. The default number is 64; larger numbers make the global illumination 
smoother but increase render time. 

 

A Global Illum Accuracy of 1 is shown here to show the individual photons. 
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A Global Illum Accuracy of 100 has been used here. Generally, Accuracy above 100 
only increases render time. 

To improve illumination quality and reduce the spotty effect, the Global Illum Radius is 
increased. The Maya manual explains: 

Global Illum Radius 

Controls the maximum distance at which mental ray for Maya considers photons for 
global illumination. When left at 0 (the default), mental ray for Maya calculates an 
appropriate amount of radius, based on the bounding box size of the scene. If the result 
is too noisy, increasing this value (to 1 to start, then by small increments up to 2) 
decreases noise but gives a more blurry result. To reduce the blur, you must increase 
the number of global illumination photons (Global illumination Accuracy) emitted by the 
light source. 

 

Here, with Global Illum Accuracy set to 100, and Global Illum Radius is set to 0.1. 

 

A Global Illum Radius value of 1 produced the best results. 

Final Gather  

Up to this point an accurate Global Illumination model has been used. To improve 
indirect illumination and to create a Radiosity effect, Final Gather is introduced. In the 
Render Globals Settings, Final Gather is turn on and Final Gather Rays are reduced to 
an initial value of 100. The following is the Maya manual extract: 
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Final Gather Rays  

Controls how many rays are shot in each final gathering step to compute the indirect 
illumination. The default is 1000 per sample point, but this tends to be high for test 
renders (renders can take hours). Test rendering at lower values, usually 100 or 200, is 
sufficient; higher values are required for final renders. Increasing the value reduces 
noise but also increases the rendering time. 

 

Global Illumination and Final Gather in Mental Ray for Maya 

This is the resulting image with Final Gather turned on and Final Gather Rays set to 
100. The image is currently appearing much darker. This is because there are only 
really two surfaces for the light to reflect off. Final Gather also works in response to a 
surface's Diffuse and Incandescence values. 

 

Here a separate material has been applied to the reflector board above the set. The 
Color has been set to pure white and the Diffuse set to 1. Incandescence has been set 
to mid-grey and gradually increased to add light. The backdrop has also been set to 
pure white and a diffuse value of 1. It's Incandescence is a low dark-grey. Adjusting the 
Incandescence value gradually allows Final Gather to introduce more light. 
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With more light, the Final Gather Rays are increased to 300 to improve quality. 

The last Final Gather adjustment to make is the Min/Max Radius. Here is the Maya 
manual explanation: 

Min Radius, Max Radius 

Max Radius and Min Radius control the size of the sampling region within which Final 
Gather rays search for irradiance information from other surfaces. 

With the default values, Maya calculates values that seem appropriate based on scene 
dimensions to speed up the render, but this calculation doesn't allow for complex 
geometry. Generally, enter a value that is 10% of scene's overall dimension for the Max 
Radius, then enter 10% of that for Min Radius. Make further adjustments based on 
scene geometry detail, how the geometry is arranged in the scene, and how the render 
looks. For example, use these settings to achieve better diffuse detailing in nooks and 
crannies in your scene. 

Mental Ray automatically calculates the Min/Max Radius when the value is 0. 
Increasing these values can help reduce render time. 

 

Here the Radii are equal with a Min Radius of 0.1 and a Max Radius of 0.1. It leaves a 
spotty effect. 

 

Here a Min Radius of 0.1 is used and a Max Radius of 1. Render time has been 
reduced notably. 

As a final touch, the Spot lights are converted to Mental Ray area lights. This removes 
the hard shadow from the black boards and adds softness to the image. 
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This is the image with area lights. The type is set to Rectangle and both Sampling 
increased to 6x6. To increase brightness, the light‘s intensity has been increased 
slightly to 80 and the Incandescence of the wall and reflector board material has also 
been increased. 

The Final Render  

 

After some tweaking, this final image was rendered. The camera was moved closer, the 
sphere‘s color material changed, a key light added and render quality increased. 

Lighting Flat Objects 

Light Attributes 

Intensity 

A light's Intensity attribute controls the brightness of the source. You can set it to any 
value, positive or negative. If the intensity is raised, more light is emitted from the 
source . Usually, you set the value between 0 and 1 for a medium-intensity fill light. For 
sunlight effects, you might go as high as 1.5 or so. With Decay Rate added , the light's 
Intensity value might need to be set much higher because the strength can fall off 
rapidly with distance. All Maya's default lights have no decay rate  and illuminate objects 
at full intensity, regardless of distance.You can also use negative values for the Intensity 
attribute. By setting a negative value, the light actually "absorbs" other light. If you have 
an area of the scene that you want to be pitch-black but have light illuminating it, you 
can use a light with a negative Intensity setting to help eliminate the problem. 
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Illuminates by Default 

By default, lights automatically illuminate all objects in the scene. When you disable the 
Illuminates by Default check box, the light is removed from the default Light Set and 
affects only objects it's linked to. Light linking is handled in the Relationship Editor for 
lights (Window > Relationship Editors > Light Linking). In this dialog box, you can select 
a light and then choose which objects it illuminates .  

 

Emit Diffuse and Emit Specular 

The Emit Diffuse and Emit Specular attributes are not available with Ambient lights. 
Emit Diffuse is particularly useful for creating soft fill lights to simulate light reflection; 
you need to disable the Emit Specular attribute so that no highlights are generated. Emit 
Specular can also be useful for lighting metal objects (such as chrome logos) when you 
want to add specular highlights to the metal without brightening other areas.  

Color 

Each light can have its own color assigned, and modifying the color of a light follows the 
same procedure and uses the same Color Chooser dialog box you see when modifying 
color for a material. You can also map textures to a light's color, causing the light to 
project the texture like a slide projector. Or if you animate the texture variables or use a 
movie as the source, the light acts as a movie projector. 

Decay Rate 

Specific to Spot, Area, and Point lights, this attribute determines the rate at which the 
light intensity fades (decreases) at a distance. Several types of decay are available in 
the Attribute Editor's Decay Rate list box. 

No Decay  The light does not diminish with distance; it reaches all objects in the scene. 

Linear The intensity of emitted light decreases at a constant (linear) rate as distance 
from the light source increases. Linear decay is the most frequently used type because 
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it's easier to control; you don't need to raise the light's Intensity attribute to enormously 
high values to compensate. 

Quadratic A physically accurate mode of decay, also known as inverse square. 
Quadratic decay is determined by proportionally decreasing the light intensity along the 
square of the distance. Light intensity generally must be raised substantially with this 
mode. 

Cubic  Decreases the intensity of light faster than the rate seen in reality. Cubic Decay 
is evaluated by a decrease in intensity that's relatively proportional to the cube of the 
distance. The lit area falls off almost instantly with Cubic Decay. This type of decay can 
be used to create a lit area that seems as though it's burning within surrounding 
darkness.  

  

 IPR rendering is a helpful tool for interactively adjusting light decay; it's hard to visualize 
otherwise. 

Shadows 

Shadows in Maya can be turned on or off. The default setting for lights is to have the 
shadow set to off. Surfaces illuminated by the non-shadow–casting light are still shaded 
by it, but won't cast shadows onto other surfaces. That means the part of an object 
that's exposed to light is illuminated, and the object's opposite side fades to a darker 
tone. An object's shadow can identify its size, position, and orientation in space, so by 
adding shadows to your scene, you can more clearly define the spatial relationships 
between objects. Without shadows in a scene, the render looks flat and lacks depth. 
Shadows add depth and realism to the scene, especially indoor scenes. 

Shadows tend to wash each other out as you add more shadow-casting lights that 
illuminate the same area. With Maya, you have a lot of control over the way shadows 
are cast in a scene, which can help you reduce render times, add contrast to your 
renderings, and create a better-looking overall result. There are two types of shadows in 
Maya: depth map and ray traced shadows. 

Depth Map Shadows 

Depth map shadows are produced through an image map. The depth map is calculated 
immediately before the actual render takes place. Using calculations for the distance of 
light to a specific point on an object, depth information is stored in the map and then 
passed on to the rendering engine to produce a "simulated" shadow effect. The depth 
map tells the rendering engine which areas of the scene are illuminated by light 

Depth map shadows usually give good results without having to worry about a huge 
increase in render time. They are usually slightly softer, too, which is more natural than 
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harsh-edged ray traced shadows. If you want, you can achieve almost the same level of 
sharpness as ray traced shadows. Depth map shadows work in a unique way for Point, 
Ambient, and Area lights: Because a square bitmap is required to create the shadow, 
and these light types cast light in all directions, they must create multiple maps to cover 
the area. Maya uses cubic shadow maps for these light types—that is, six depth maps 
are cast for the six sides of a cube. This process requires six times the RAM, which 
could be a concern for large map sizes. 

The main drawback to depth map shadows is that they don't take materials' 
transparency into account. 

Depth Map Attributes 

Shadow Color Applicable to both types of shadows in Maya. Changing the Shadow 
Color attribute changes the shadow's color seen in the render. It's often a good idea to 
bring shadow colors a little brighter than pure black, to add to the simulation of diffuse 
light reflection. You can also map an image file or a texture to the Shadow Color, just as 
you would map an image to a material. 

Dmap Resolution Specifies the resolution (accuracy) of a depth map shadow. The maps 
are square, so if you set this attribute to 1024, the shadow map is produced as a 
1024x1024 pixel image. When setting Dmap Resolutions, try to use values that are 
powers of 4, such as 128, 256, 512, and 1024. These numbers are easier for Maya to 
calculate with and can result in faster render times. At very large sizes (4096+), RAM 
consumption can become a problem. Increasing the resolution also reduces the jagged 
effect, but creates a sharper shadow edge. 

Dmap Filter Size Directly affects the edges of a depth map shadow by making them 
softer. This attribute, combined with the Dmap Resolution, can smoothly and gradually 
soften a shadow's edge. Be aware that increasing this value increases render times. 
Use values between 1 and 3, unless you truly need to go higher. 

Dmap Bias When depth map shadow–casting lights are casting long shadows, they can 
sometimes separate from the objects. This setting allows you to adjust the placement of 
the shadows, and you usually need to adjust it only for very low light angles (such as a 
setting sun). 

Raytraced Shadows 

Raytraced shadows are generally slower to compute, but offer the advantage of lower 
RAM requirements, soft shadows, and properly cast shadows for objects that have 
transparency, such as windows. To make raytraced shadows appear in your renderings, 
you must go to the Render Global Settings window and enable raytracing. Like the Area 
light, the Spot, Directional, Ambient, and Point lights can cast area shadows. In this 
case, the soft shadows are created by having the light cast from a circular source. Non–
Point light sources create soft shadows (known as penumbral shadows) because a 
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variable amount of the non–Point light source is blocked as an object passes in front of 
the light. 

Transparent objects can affect shadows if the shadows are raytraced. However, the 
color values do not affect shadow color. To cast colored raytraced shadows, you must 
set or map the transparency color for the material. 

Raytraced Shadow Attributes 

Light Radius  Sets the imaginary size of the circular Area light effect. 

Shadow Rays Controls the sampling of soft shadows. If you use a low number, the 
shadows look speckled, but render faster. This is similar to the way that Dmap Filter 
Size works with depth map shadows, in that increasing the Shadow Rays setting 
reduces the shadow's graininess. 

Ray Depth Limit This setting enables you to limit the number of times a light bounces 
from reflective and refractive materials. You can raise this value if you want to allow 
raytraced light rays to bounce around the scene before eventually creating a shadow. 

Area Light Shadows 

If you set Area lights to cast raytraced shadows, the shadows are calculated from the 
rectangular Area light icon, based on its size. The results are similar to circular Area 
lights. As with circular Area lights, more Shadow Rays soften the shadow, but result in 
substantially longer render times. 

Lighting in Layers 

Lighting in Maya: Render Layers  

Render Layers  

 

When rendering in Maya, it is unwise to give up control of the image by rendering a 

single pass. 

Using compositing software such as Nuke or Shake (may it rest in peace) it is possible 

to combine many layers that control specific aspects of the image (such as specular 

highlights or occlusion) whilst still retaining full control of the image. 
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1) Go to your Channel Box/Layer Editor. 

 

2) Create a new empty Render Layer (whatever you do, don't use the ridiculous "smart 

select" Layer creator thing...it has SO many bugs that will mess up your day). 

 

3) Double click on the name of the Layer to rename it. 

 

4) Using your Outliner, select the objects you wish to have in this new Render Layer. 

 

5) Right click on your Layer and Add Selected Objects. 

 

Layer Protip: When working within a Render Layer that is not the Main Render Layer 

you must be very careful.  ANY changes you make will affect ALL layers.  In order to 

make changes that will only show up within your chosen layer (for example changing 

the color of a Spotlight or adjust a render setting), right click any attribute and select 

Create Layer Override.  The attribute title should now be orange and the change will 

only exist within the layer you are now working from. 

 
 

Lighting 

Rendering in Passes and Layers,  

An issue which is often overlooked or avoided by individuals new to 3D is the necessity 
of fine-tuning projects in conjunction with a compositing package. Yet the level of 
interactive flexibility available within just about any 2D application can save precious 
time. While it is possible when working on full CG projects to render the final image 
directly from the 3D rendering engine, this methodology is rarely utilized in production 
environments. Furthermore, as most work in broadcast and film utilizes 3D imagery as a 
subservient element to a live-action backplate, compositing is going to occur regardless. 
While many visual effects shots incorporate 3D, all visual effects shots are composited. 
What also must be mentioned is that there are many effects which not only benefit from, 
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but require a compositing application's specialized features: Color correction, film grain, 
effects such as depth of field, fog, glows, motion blur, heat distortion, optical effects... 
while some of these can be achieved in Maya with varying degrees of success, an 
experienced compositor with a strong application can often times take things further. 

My purpose here is to give an overview of how 3D elements are prepped and rendered 
from Maya for use in a compositing pipeline... You will notice, however, that I do not 
mention the Render Layer Manager. Reason is, as you may expect, that it is clunky and 
not really the best way to approach passes/layers. 

Passes 

While it is possible for an image rendered with Maya to achieve the results you need, 
the most common pipeline involves getting things are close as possible in Maya while 
keeping in mind what types of tweaks can be more easily made in a compositing 
package. Any serious lighter should be familiar with at least one application. This 
includes Nothing Real Shake, Adobe After Effects, Discreet Combustion, Silicon Grail 
Rayz and others. 

 

Diffuse/Beauty Pass - rendered by turning off 'emit specular' on all lights.  

Specular /Highlight Pass - rendered by turning off 'emit diffuse' on all lights. 

note: either Diffuse or Specular passes can even be rendered on a light by light basis to 
increase the degree of post-control. This is should not be necessary very often, 
although it is not uncommon in film. 

Reflection Pass - Create a chrome shader (blinn, color=black, diffuse=0, specular = 
white, reflectivity = 1) and assign it to the object(s) being rendered. Reflection 
intensity/opacity/blurring can then be handled at the compositing stage. The objects 
being reflected will need to be matted out by rendering another matte pass. 
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Matte Pass - If an occlusion matte is needed, the occluding object's shader can be 
edited so that it's function in the alpha channel is to block out objects behind. This is 
done by setting the Opacity Control on a Shader to 'Black Hole'. 

Shadow Pass - There are two types of shadows when rendering passes. The shadows 
an object casts onto itself (self-shadows) and the shadows the object casts onto other 
objects (cast-shadows). Usually just the shadows being cast on other objects are 
rendered as a pass, and the self-shadowing is included in the beauty pass. To render a 
shadow pass, turn off 'primary visibility' on the object's shape node, but leave 'casts 
shadows' on. One can also assign the 'Use Background' Shader to objects receiving the 
shadows so that only the shadow is rendered (to the alpha channel). 

The issue of shadow accuracy on a 'hard - soft' scale can be dealt with in two ways. 
One is to use d-map shadows for self-shadowing which easily creates varying softness, 
but then render hard accurate shadows for cast-shadows so that complete control is 
taken at the compositing stage. It is easy to soften a hard shadow via gradient blurs, but 
you cannot harden a soft shadow. The other technique is to try to get Maya to render 
accurate soft shadows but this can slow down rendering. If softening the shadows in 
post is going to be too arduous, then this will be the best route: it is always a question of 
which method is faster. At film houses it is very common to provide hard-edged but 
accurate shadows to the compositor so that all blurring/opacity/color correction can be 
handled in post. 

Effects Pass - Elements such as fur, smoke, rain, etc are usually rendered as separate 
passes. 

Depth Pass - Z-depth can be rendered as a separate pass to allow for a variety of 
results in post. One can use Z-depth to add depth-of-field and fog to an element. It can 
also be used to allow a compositing package to know where one object on a layer is in 
relation to another object on another layer. Therefore if you had a sphere in the middle 
of a torus where some of the sphere is behind and some in front of the torus, you could 
render the objects separately and still composite them successfully. 

Z-depth is a single channel image, being limited to 256 shades of gray in a standard 8-
bit/channel image. It is common to render a depth pass as a 16-bit image to increase 
the value range and accuracy within a z-depth image. 

The gray values within a depth pass represent distance from the camera where white is 
near and black is far. The range in Maya units that this represents is based on the 
rendered camera's clipping planes. Therefore you can increase accuracy by using 
near/far clipping planes which are as close to the objects in your scene as possible 
while not clipping them off. It is very important, however, to use the same clipping plane 
values for each rendered layer. 
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Layers 

While pass rendering allows you to improve the realism of an image, rendering objects 
in layers allows you to tweak objects independently of each other. It also allows you to 
more efficiently manage render time. If a camera is locked down, for example, the 
background could be rendered as a still image with the animated elements composited 
on top.  

 

To render objects separately, there are a couple techniques you can use. Managing the 
'primary visibility' attribute via the Attribute Spread sheet is the most straight forward 
approach. You can also use either scene layers or Maya's render-layer manager, but I 
prefer to rely on scene layers. Just be careful when rendering layers via visibility to 
watch out for how those objects interact with each in regards to shadows and lighting. 

Conclusion 

So at this point it should be clear that once you combine rendering in layers with 
passes, a shot can easily be broken down into many elements. If separate light passes 
are also rendered, then the amount of elements can reach high numbers... so if you 
have heard case studies from films such as Final Fintasy or Titanic, where scenes 
sometimes have dozens to hundreds of composited elements per shot, hopefully this 
overview has given a clearer picture as to why there are so many. 
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Semi-Outdoor Lighting 

Wills Maya Global Illumination Tweaking Guide 1 

Copyright (C) Will Smith , July 2003 

All text and models released under the Gnu Free Documentation License, with no 

invariant sections, and the Public Documentation License. 

Introduction 

Maya 5.0 introduces mental ray renderer built in.  For the first time, global illumination 

and caustics are easily accessible to Maya users. 

 

This guide documents some common mistakes when using GI (I learnt from making 

them myself).  I am by no means an expert on GI, so this is only Guide number 1.  

Hopefully there will be more to come. 

 

Rather than starting off with a scene and tweaking until we have a nice look, I will start 

with a scene that is as good as I can get it, then I will experiment with changing some of 

the settings.  The errors / artifacts introduced will hopefully help you when you see 

them, you'll know what's causing them and know what options to change. 

Credits 

I based the model on the model from Toni Bratincevic, which he kindly made available 

for download (see 

http://www.3dluvr.com/intercepto/maya/tutorials/mray_thegathering/outdoor01.htm) .  

The model has very minor cosmetic modifications compared to Toni's, and the render 

settings are increased for a very slow, high quality render. 

System Specifications 

All my settings are based on a Athlon XP 1800+ on a Nvidia Nforce2 based 

motherboard.  The CPU runs at 11x150MHz = 1650Mhz, and the 1Gb of DDR memory 

runs at memory at 150MHz ( 300Mhz DDR).  Since Maya mainly cares about raw CPU 

speed, my Athlon is therefore equivalent to approximately a 1900+. 

http://www.3dluvr.com/intercepto/
http://www.3dluvr.com/intercepto/maya/tutorials/mray_thegathering/outdoor01.htm
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Full Quality Render (download maya file) 

 
This 480x360 render takes 5:42 = 342 seconds. 

 

There no antialiasing issues (except some strange light blue in the interface between 

the groundand the sky that I haven't debugged yet).  The scene is illuminated partly by 

the blue sky, and partly by an orange/yellow spotlight.  The spotlight has an area light to 

give softer shadows.  The inside of the Acropolis is made slightly lighter by the use of 

global illumination. 

Tweaking Final Gathering Ray Count 

Final gathering is confusingly named, since it seems to occur before any of the rendering you 

can see.  It's perhaps the final stage of all the global illumination.  We  currently have this set to 

1000.  I reduced it to 50 (download maya file).  The setting is in Render Globals ... mental ray 

tab .. Final Gather ... Final Gather Rays. 

 
This 480x360 render takes 2:28 = 148 seconds. 

 

Final gather is very costly in render time.  We've made a big decrease, over 50% faster.  

But now there are ugly blotches in the steps on the lefthand side and inside the 

http://www.willsmith.org/maya_gi_tutorial_1/040_acropolis_01_all_hq.ma
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Acropolis, i.e. in areas where there are compound or complex shadows. 

 

Let's try to find a compromise.  I tried increasing final gather rays back to 200 (download 

maya file) 

 

 

 
This 480x360 render takes 3:14  = 194 seconds. 

 

There is still slight blotchiness.  It's not ugly, but compared to the original image, it's 

clear that it shouldn't be there.  Maybe 500 gather rays is necessary (download maya 

file) 

 

 
This 480x360 render takes 4:33 = 273 seconds, (reduction of 20% compared to benchmark 

original). 

 

There is still a tiny bit of blotchiness, however this is only visible if  we do an image 

comparison in the Maya output window.  We will leave final gather at 500 from now on, 

so our new 'benchmark' time is 273 seconds. 

 

Conclusion : Final Gather Rays count is critical in optimizing rendering time.  Values 

that are too low cause blotchiness in shadows and areas that should be evenly shaded.  

Halving your final gather ray count will take perhaps 10-20% off your render times. 

http://www.willsmith.org/maya_gi_tutorial_1/040_acropolis_03_compromise_final_gather_at_200.ma
http://www.willsmith.org/maya_gi_tutorial_1/040_acropolis_03_compromise_final_gather_at_200.ma
http://www.willsmith.org/maya_gi_tutorial_1/040_acropolis_03_compromise_final_gather_at_200.ma
http://www.willsmith.org/maya_gi_tutorial_1/040_acropolis_04_compromise_final_gather_at_500.ma
http://www.willsmith.org/maya_gi_tutorial_1/040_acropolis_04_compromise_final_gather_at_500.ma
http://www.willsmith.org/maya_gi_tutorial_1/040_acropolis_04_compromise_final_gather_at_500.ma
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Tweaking Sampling Quality 

Sampling quality is something similar to antialiasing.  It is accessible from Render 

Global ... mental ray tab ... Sampling Quality. 

The 'min samples' and 'max samples' are (I think) the key.  Maya recommends that 'max 

samples' is set to 'min samples' + 2.  The manual implies that every time you increase 

the values by 1, the possible number of pixels sampled for antialiasing can double. 

 

Lets reduce our current setting of 'min samples' = 1, 'max samples' = 3 (I  abbreviate to 

1, 3) down to -2, 0 (download maya file).  This big reduction should help us see easily 

see the effect on visual quality and render times. 

 

 
This 480x360 render takes 2:13 = 133 seconds. 

 

There are now ugly antialiasing effects, visible anywhere there is a sharp contrast, 

especially on the darker lefthand columns.  However, we did get a big reduction in 

render time (down by 50%) so it's worth tweaking some more. 

 

Let's try increasing sampling quality up to -1, 1 to see if it is sufficient (download maya 

file). 

 

 
This 480x360 render takes 2:26 = 146 seconds. 

http://www.willsmith.org/maya_gi_tutorial_1/040_acropolis_05_decrease_samples_to_-2_0.ma
http://www.willsmith.org/maya_gi_tutorial_1/040_acropolis_06_compromise_samples_to_-1_1.ma
http://www.willsmith.org/maya_gi_tutorial_1/040_acropolis_06_compromise_samples_to_-1_1.ma
http://www.willsmith.org/maya_gi_tutorial_1/040_acropolis_06_compromise_samples_to_-1_1.ma
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That's excellent.  Only incredibly close comparison reveals a few pixels different on one 

or two columns, and we have almost halved rendering time.  These settings and 146 

seconds becomes our new benchmark. 

 

Conclusion : sampling quality 'min samples' = -1, 'max samples' = 1 is probably 

sufficient unless you notice antialiasing problems.  An increase to 1, 3 could well double 

you render times. 

Tweaking Sampling Filter 

Currently, we are using the 'Gauss' filter, which defaults to 'filter width' = 3, 'filter height' 

= 3 (these are in render global ... mental ray tab .. sampling quality).  Let's try changing 

back to the default, and presumably lower quality, box filter (download maya file). 

 

 
This 480x360 render takes 219 = 139 seconds. 

 

There is no perceptible difference in quality that I can detect, but the time gained is 

about 5%.  Let's try the more complicated filter types, just to see if we can see any 

effect  First, the Lanczos filter (download maya file). 

 

 
This 480x360 render takes 2:29 = 149 seconds. 

 

Interesting.  This gives a much sharper, crisper image.  A read of the Maya manual 

http://www.willsmith.org/maya_gi_tutorial_1/040_acropolis_07_reduce_sampling_quality_filter_type_to_box.ma
http://www.willsmith.org/maya_gi_tutorial_1/040_acropolis_08_increase_sampling_quality_filter_type_to_lanczos.ma
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implies to me that this is similar to the unsharp mask function in Photoshop.  So, use it if 

you want crispness, but don't over-use it!  There is almost no time penalty for using this 

filter. 

 

Now let's try the Mitchell filter type (download maya file). 

 

 

This 480x360 render takes 2:22 = 144 seconds (same render time as previous 

benchmark, slightly sharper image). 

 

Mitchell is a bit softer than Lanczos, but a bit sharper than 'box' or 'gauss'.  Let's leave it 

on, this becomes the new benchmark default.  It's the same speed as our previous 

benchmark, but I like the sharpness. 

 

Conclusion : Sampling filter does not affect render times significantly, but controls the 

sharpness of the final image.   Gauss and Box give a slightly soft, blurred effect, Mitchell 

is a compromise, and Lanczos gives very sharp images.  For the sharper filters, you 

may experience slight problems with antialiasing though, possibly needing a higher 

sampling quality, which will slow your render. 

 

Global Illumination Accuracy 

Currently I have the global illumination accuracy set to 250 (render global ... mental ray 

tab .. caustics and global illumination ... global illum accuracy)..  Maya default to 64.  

Let's take it down to 32 to see what the effects are (download maya file). 

 

http://www.willsmith.org/maya_gi_tutorial_1/040_acropolis_09_increase_sampling_quality_filter_type_to_michell.ma
http://www.willsmith.org/maya_gi_tutorial_1/040_acropolis_10_gi_accuracy_reduce_to_32.ma
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This 480x360 render takes 1:54 = 114 seconds. 

 

The scene does not show any major defects, but the whole lefthand side of the image is 

significantly brigher than it was before, and the righthand steps seem to glow a little.  On 

the plus side, we reduced the rendering time by 20%.  Let's take the quality to a 

compromise 100, and see how things look (download maya file). 

 

 
This 480x360 render takes 2:03 = 123 seconds. 

 

The render times are now within 15% of the original render times, but there is a 

noticable difference in the image (at least, if you compare them in Maya's render 

window).  It is not objectionable, but I hate to accept an image that I know is not as 

'accurate' as it could be. 

 

Let's try it the other way, to see if even the 250 accuracy setting can be improved on, in 

terms of image quality.  Let's increase the GI accuracy right up to 1000 (download maya 

file). 

 

http://www.willsmith.org/maya_gi_tutorial_1/040_acropolis_11_gi_accuracy_compromise_at_100.ma
http://www.willsmith.org/maya_gi_tutorial_1/040_acropolis_12_gi_accuracy_increased_to_1000.ma
http://www.willsmith.org/maya_gi_tutorial_1/040_acropolis_12_gi_accuracy_increased_to_1000.ma
http://www.willsmith.org/maya_gi_tutorial_1/040_acropolis_12_gi_accuracy_increased_to_1000.ma
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This 480x360 render takes 3:28 = 208 seconds. 

 

We are way back up in long render times.  There is a some difference between this (GI 

accuracy = 1000) and the previous benchmark (GI accuracy = 250).  This is slightly 

duller at the righthand side.  Presumably the building is blocking some light from some 

of the sky hitting the righthand steps, and the lower qualities doesn't take that into 

account somehow. 

 

OK, let's return the GI accuracy to 250, where we started.  The benchmark time remains 

at 144 seconds, we can forget all this GI accuracy tweaking. 

 

Conclusion : Low GI accuracy can result in areas with the incorrect brightness.  The 

effects are not ugly.  A GI accuracy of 1000 can add 40% to a render time compared 

with 250, and a GI accuracy of 32 can reduce render time by 20% compared with 250.  

Overall, a fairly high value like 250 will ensure accuracy without excessive render times. 

Area Light Sampling 

Currently we are using a spotlight for the sun, with an 'attached' mental ray area light. 

 

The area light is set to type 'sphere', with sampling '3,3', low level = 0, and low sampling 

= 2,2 (see spotlightshape1 ... mental ray ... area light). 

 

Let's set the sampling down to 1,1. For all the settings (sampling and low sampling both 

set to 1,1) (download maya file). 

 

http://www.willsmith.org/maya_gi_tutorial_1/040_acropolis_13_area_light_sampling_reduced_to_1_1.ma
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This 480x360 render takes 2:20 = 140 seconds.  

 

Ugh, the edges of the shadows are really ugly, and we only saved a few seconds off our 

previous benchmark of 144 seconds.  Let's try the other way - can we get even nicer 

shadows by taking all the area light sampling values right up to 4,4 (download maya 

file)? 

 

 
This 480x360 render takes 2:31 = 151 seconds. 

 

There's a tiny, subtle difference between this and the benchmark.  The render time has 

increased from 144 to 151 seconds, or 5%.  I think it's worth it - it just makes the 

shadows perfect, not a hint of grainyness at the edges.  This becomes our new 

benchmark. 

Mental Ray Raytrace Levels 

Currently we have the mental ray raytrace levels (in render global .. mental ray .. quality 

.. general) set to: 

 max reflection rays = 4 
 max refraction rays = 1 
 max ray depth = 4 

http://www.willsmith.org/maya_gi_tutorial_1/040_acropolis_14_area_light_sampling_increased_to_4_4.ma
http://www.willsmith.org/maya_gi_tutorial_1/040_acropolis_14_area_light_sampling_increased_to_4_4.ma
http://www.willsmith.org/maya_gi_tutorial_1/040_acropolis_14_area_light_sampling_increased_to_4_4.ma
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 scanline = off 
 faces = both 

Let's try tweaking some of these.  I'll refer to this combination as (4,1,4,off,both). 

 

'Scanline' controls whether any part of the scene is rendered with the traditional 

renderer, and 'faces' somehow relates to whether we properly render all the hidden 

faces.  Let's try turning them both to the lower quality settings (scanline = on, faces = 

front) (download maya file). 

 

 
This 480x360 render takes 2:13 = 133 seconds. 

 

OK something weird happened.  I'm guessing it's the faces=front.  Let's leave 

scanline=on for the moment, and have faces=both (download maya file). 

 

 
This 480x360 render takes 2:38 = 158 seconds. 

 

This is actually worse than the 151 second benchmark.  Maybe our timings are variable, 

maybe it's actually slightly slower.  The image has not changed in any way.  Let's revert 

scanline=off. 

http://www.willsmith.org/maya_gi_tutorial_1/040_acropolis_15_scanline_turned_on_faces_reduced_to_only_front.ma
http://www.willsmith.org/maya_gi_tutorial_1/040_acropolis_16_scanline_turned_on.ma
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Let's now try reducing the ray depths a long way, to see the effect.  We have no 

refraction so we should be able to set that = 0, and the other 2 at 2. 

 

So our original (4,1,4,off,both) becomes (2,0,2,off,both) (load maya file). 

 

 

 
This 480x240 render takes 2:29 = 149 seconds.   

 

That's not much different from the benchmark (151 seconds), and the difference is 

imperceptible.  Using Maya's comparison tool shows a tiny difference in the detail of the 

steps in the front corner, but it's not clear which is better. 

 

With a slight time gain to 149 seconds, this becomes our new benchmark. 

 

Conclusion: Scanline on or off tends to make little difference.  Rendering only front or 

back faces may produce strange effects.  Increasing the ray trace values from 2,0,2 to 

4,1,4 doesn't make much difference in quality or render times for fairly simple scenes 

such as this (perhaps it does for more complex scenes). 

Mental Ray Memory and Performance 

These are available in Render Globals ... mental ray ... Memory and Performance.  

Currently, we have Acceleration Method = BSP, BSP size = 10, BSP Depth = 40. 

 

For the benchmark, maximum memory used during render for the maya process = 

172Mb. 

 

With settings changed to BSP size = 3, BSP depth = 80 (load maya file) 

 

http://www.willsmith.org/maya_gi_tutorial_1/040_acropolis_17_reduce_raytrace_settings_to_2_0_2_off_both.ma
http://www.willsmith.org/maya_gi_tutorial_1/040_acropolis_18_bsp_size_reduce_to_3_depth_increase_to_80.ma
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This 480x360 render takes 2:30 = 150 seconds. 

 

Maximum memory used during the render = 185Mb  Memory is hard to trace accurately, 

in Maya it depends on which subwindows are visible, whether you've minimized the 

application recently, etc.  So no change in rendering time, possible slight increase in 

memory usage.  With 1Gb of RAM available, I don't see that we've gained or lost 

anything, so lets revert.  The image itself is identical. 

 

OK, let's try the 'grid' acceleration method with the default settings (resolution=0, max 

size=128, depth=2) (download maya file). 

 

 
This 480x360 render takes 4:27 = 267 seconds. 

 

The memory usage reduced slightly to 170Mb, but the render time has gone way up!  

Let's go back to BSP and leave this section well alone. 

 

Conclusion : leave the memory and performance options to the default (method=BSP, 

BSP size=10, BSP size=40) unless you have memory problems.  Avoid the 'grid' 

method unless you know what you are doing. 

 

http://www.willsmith.org/maya_gi_tutorial_1/040_acropolis_19_acceleration_method_grid.ma
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Polygon Count, NURBS quality. 

Let's see if the complexity of the scene is causing problems.  We can find the total 

polygon count of the scene using 'Display ... Head up Display ... Poly Count'.  Currently 

we have Verts=64, Edges=92, Faces=41, UVs=104.  That sounds low already. 

 

However, I am aware that some of the tesselation qualities etc are quite high on some 

of the components of the scene. 

In an attempt to reduce this,  modified the following: 

 

Modified all the columns from (curve precison=15, crv precision shaded=4, simplify 

mode=0, simplify u=1, simplify v=1, divisions =3, divisions v=3) down to (4,2,0,1,1,0,0). 

 

Modify the two domes creating the sky and the light from the sky, so that their 

tesselation is reduced from (high quality, u divisions factor=12, v divisions factor = 12) 

down to the default of (medium quality, 4.5, 4.5), also changed their curve precision etc 

down to (4,2,0,1,1,0,0) (download maya file). 

 

 
This 480x360 render takes 2:23 = 143 seconds. 

 

There's little differnce in the image, except the blue line at the horizon (which I don't 

want anyway) is more consistent.  Let's make this the new benchmark.  Possibly at 

higher resolutions better tesselation is necessary, but the defaults are fine at 480x360.  

We've reduced the render time from 149 seconds to 143 seconds, 4% faster. 

 

Conclusion : at relatively low resolutions, stick with low tesselations, and tesselation 

qualities, and the default values in the 'nurbs surface display' settings, for a slight 

benefit in render times. 

Area Light - Global Illumination Photons 

Currently we the spotlight with the area light emits 50000 photons, with energy 

8000,8000,8000 and exponent 1.6 (Spotlightshape1 ..mental  ray ..Caustics and global 

http://www.willsmith.org/maya_gi_tutorial_1/040_acropolis_20_simplify_tessellations_etc.ma
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Illumination).  Can we get the same quality with less photons, or somehow faster? 

 

Let's turn the GI photons off for the spotlight (the sun) to better understand what effect 

the GI is having (download maya file). 

 

 

 
This 480x360 render takes 1:13 = 73 seconds. 

 

Clearly, GI on the spotlight both adds a lot to the render time, but also contributes a lot 

of warm light to the scene, and more importantly, helps to light the inside of the 

Acropolis realistically, rather than leaving it dark inside from the absense of any direct 

light rays.  However, the comparison does reveal that perhaps in the original picture, 

there is too much orange light coming from the spotlight (sun), making the illumination 

on the righthand side just a little too  

 

What about if we just have a few GI photons coming from the spotlight?  Let's try 100 

(download maya file). 

 

 

 
This 480x360 render takes 1:13 = 73 seconds. 

 

The render time hasn't changed, clearly this small number of photons is very quick to 

calculate.  But now the scene is very blotchy.  Perhaps each photon now makes a big 

http://www.willsmith.org/maya_gi_tutorial_1/040_acropolis_21_area_light_no_gi.ma
http://www.willsmith.org/maya_gi_tutorial_1/040_acropolis_22_area_light_50_photons.ma
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difference, and the bright bits are where these photons land.  I'm guessing that with 

more photons, each makes a lower contribution to the overall lighting, so the more there 

are, the more even the GI effect is. 

 

So we can tune the number of photons between 0 (73 seconds) and 50000 (143 

seconds).  Perhaps the relationship is linear.  Let's try a compromise of 10000 photons, 

if adding more photons adds extra time linearly, I predict this will take (73 + 

(10000/50000)*(143-73)) = 87 seconds (download maya file). 

 

 
This 480x360 render takes 1:43 = 103 seconds. 

 

OK, our theory is incorrect - small amounts of photons (few thousand) adds more time 

than the extra time for the larger amount of photons (tens of thousands). 

 

The image is very slightly different from our previous benchmark - slightly duller on the 

righthand steps.  However, if anything, the version with lower photons looks more 

realistic, slightly softer.  Let's make this our new benchmark, since we made a decrease 

gain in rendering time of almost 30%, but let's not try to push the photon count lower, 

since we area already experiencing subtle changes in the scene appearance from the 

higher photon (theoretically more accurate) values. 

 

Conclusion : number of photons emitted by GI emitting light sources makes a big 

contribution to render time.  Too low number of photons makes a uneven effect in the 

lighting, with bright and dark spots.  Above say 10000 photons, you will get only subtle 

changes in the scene smoothness, and your render times will continue to grow. 

Area Light - Global Illumination Energy and Exponent 

Currently, for the area light (the sun) in the light's 'Caustics and GI' section, we have 

exponent=1.6, and all the energies = 8000. 

 

Let's understand what the energies do.  Instead of energy=(8000,8000,8000), let's drop 

http://www.willsmith.org/maya_gi_tutorial_1/040_acropolis_23_area_light_10000_photons.ma
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to (8000,0,0) (download maya file) 

 

 
This 480x360 render takes 1:44 = 104 seconds. 

 

The rendering time has not changed, but all the GI inside the Acropolis is just red.  

(8000,0,0) must is RGB.  Probably, we should leave all values identically unless we 

want some strange effect. 

 

According to the Maya manual, exponent is the way that light should reduce its effect as 

it gets further from the source.  The most realistic, real world value should be 2.  Let's 

see what happens with exponent = 1, first (download maya file). 

 

 
This 480x360 render takes 1:42 = 102 seconds. 

 

There is simply too much GI.  The low exponent is causing it to be too powerful, and 

almost to amplify itself inside the building.  Let's try 2.0, and increasing the energy to 

(16000,16000,16000) - which should perhaps balance the higher exponent - to see 

whether we can get a good looking scene using an exponent of 2.0, which should be 

most realistic (download maya file). 

 

http://www.willsmith.org/maya_gi_tutorial_1/040_acropolis_24_area_light_photon_energy_8000_0_0.ma
http://www.willsmith.org/maya_gi_tutorial_1/040_acropolis_25_area_light_exponent_1.ma
http://www.willsmith.org/maya_gi_tutorial_1/040_acropolis_26_area_light_exponent_2_photon_energy_16k_16k_16k.ma
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This 480x360 render takes 1:43 = 103 seconds. 

 

The inside is quite a bit duller, but I think it's more realistic.  Let's take the energy up to 

(24000,24000,24000) to make it just a bit warmer (download maya file). 

 

 
This 480x360 render takes 1:44 = 104 seconds. 

 

OK, that's a bit nicer, a warm glow to the righthand side, but the inside's dullness feels 

(to me) a bit more natural, not so warm.  This is our new benchmark - the realism is 

better, but the rendering time is the same. 

 

Conclusion: For light sources that emit GI photons, keep the GI energies the same 

unless you are sure they shouldn't be.  Preferably keep the exponent at 2.0.  Try with no 

GI light to see what it's affecting.  Then tune the amount of GI light added to the scene 

by altering the energy values. 

Area Light - Shadow Map 

Why would we want a shadow map, when we already have ray traced shadows?  The 

Maya manual doesn't make this clear.  It does suggest using shadow maps instead of 

ray tracing, for more speed.  Let's try turning on a mental ray shadow map.  It's not clear 

whether this turns off raytracing somehow.  Let's leave render globals alone for the 

http://www.willsmith.org/maya_gi_tutorial_1/040_acropolis_27_area_light_exponent_2_photon_energy_24k_24k_24k.ma
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moment.  This gives us settings in 'spotLightShape1 .. mental ray .. shadow maps' of 

resolution=256, samples=1, softness=0  

 

 
This 480x360 render takes 1:39 = 99 seconds. 

 

Ugh!  The shadow is totally unrealistic, and all of our columns don't even emit a 

shadow.  There's a slight benefit in rendering time.  Let's try a much more detailed 

shadow map (resolution 1024) to see if that helps  

 

 
This 480x360 render takes 1:50 = 110 seconds. 

 

OK, we've solved the issue of the missing shadows from the columns - we just needed 

a higher resolution.  But the shadow edges are still ugly, and we have increased the 

render time over the raytraced shadows.  It's also confusing me how the light has 

settings for raytraced shadows and depth mapped shadows, as well as the Shadow 

Maps option within mental ray.  I think I'll leave this all alone and investigate another 

day! 
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Area Light - Raytrace Settings 

Currently, the area light has 'Shadows ... Raytrace Shadow Attributes' set to Light 

Radius=0, Shadow Rays=32, Ray Depth Limit=5.  Let's experiment with reducing 

Shadow Rays down to 2 (download maya file). 

 

 
This 480x360 render takes 1:43 = 103 seconds. 

 

There's no difference in the rendered image, and no difference in the render times. 

 

What about changing the radius to > 0 of the raytraced light, and using this instead of 

the area light?  Can that give us faster render times with the same effect?  Using the 

distance measure tool (Create ... Measure Tool ... Distance Tool) we see that the 

circumference of the area light is 5.3.  So maybe setting the radius to 2.6 will have the 

same effect?  

 

 
This 480x360 render takes 1:18 = 78 seconds. 

 

This looks like we have some potential - we made a big decrease in the render time, 

and need to increase the quality of the shadow borders a bit, maybe we can do this by 

increasing the Shadow Rays, and still save on render times.  Also, our guess of 2.6 for 

the light radius seems too high - the shadows are much more blurred at the edge than 

with the previous area light. 

http://www.willsmith.org/maya_gi_tutorial_1/040_acropolis_30_area_light_shadow_rays_reduced_to_2.ma
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Let's try with the light radius = 1.7, and the shadow rays set to the same value as before 

we started experimenting, 32.  I actually experimented with a few values, they are not 

interesting enough to show them all here, until I had an image as close as possible to 

the one with the area light.   

 

 
This 480x360 render takes 1:56 = 116 seconds. 

 

It seems that the raytraced light is very sensitive to the number of shadow rays.  Without 

shadow rays up to 16 or 32, there is significant reduction in quality.  But with shadow 

rays up to 32, the render is now taking longer than the benchmark, so we won't persue 

this further. 

 

Finally, can we turn off ray traced shadows and just leave the area light to do the work?  

 
This 480x360 render takes 1:33 = 93 seconds. 

 

The answer is no.  We need some kind of raytracing or the area light doesn't work. 

 

Conclusion : You can get similar results with a raytrace shadow producing spotlight with 

radius, as with a spotlight with a mental-ray added area light.  The render times are also 

similar, for similar qualities.  Increasing the shadow rays from 2 to 32 makes the edges 

of shadows near-perfectly smooth, but adds perhaps 50% to the render time.  Make 
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sure you don't have a radius > 0 as well as an area light, or you get longer render times 

with no benefit.  Make sure to leave 'ray traced shadows' turned on to some extent, or 

you get no shadows at all. 

Final Gather Files 

We already noticed that 'final gather' is a very expensive stage.  Can we optimize this 

(perhaps not for a single render, but for subsequent renders, for example in a movie) 

using some kind of disk caching? 

 

I tried going into 'Render Global ... mental ray ... Final Gather'.  Now, I turned 'final 

gather rebuild' off, and changed Final Gather File to be 'save_final_gather_034' 

(download maya file). 

 
This 480x360 render takes 1:45 = 105 seconds (run 1), 32 seconds (run 2). 

 

That's quite a benefit, the 2nd time we run, we reduced the render time by 70%!  The 

cache file itself is stored in projects/projectname/mentalray/finalgMap/fg_save_500 in 

this case.  It is a 11.3Mb file - not too bad.  Now, we need to know when we can and 

when we can't use this method.   

Can we use it to render a scene with the camera in a different position?  If so, this would 

be great for flypasts etc.  Let's try moving the camera to the front of the building, closer 

inside, and rerendering  

 

 
This 480x360 render takes 1:38 = 98 seconds (run 1), 37 seconds (run 2). 

The algorithm seems to detect when the camera has moved, and does a recalc.  

Interestingly though, some experimentation shows that the more the camera moves, the 

http://www.willsmith.org/maya_gi_tutorial_1/040_acropolis_34_final_gather_file_caching.ma
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more the first render has to start from scratch.  If the camera only moves a tiny bit, the 

first render is able to gains some benefit from the cache.  

 

Three-Point Lighting 

 

Maya Lighting resembles real word lighting techniques used in photography & film. 

Maya has a number of light sources ( Area, Directional, Ambient, Spotlight, & Volume 

light) that let you achieve a wide variety of lighting effects. By default, Maya scenes do 

not contain light sources. However, Maya‘s default lighting helps you to visualize objects 

in Shaded display in the Scene. 

 

To view a scene without the default lighting in a viewport menu  go to Lighting > Use all 

lights. 

 The shortcut / hotkey to view a scene using the default lighting is 5. 

 The shortcut / hotkey to view a scene using all lights is 7. 

 Studio or Three Point Lighting in Maya 3D 2012 
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 The Three Point Lighting Technique is a standard method used in visual 

media such as video, film, & photography. The technique uses three lights 

called the key light, fill light and back light. 

 a. Key Light 

 

 The Key Light is the main light of your scene. It is usually the strongest 

and has the most influence on the look of the scene. It is placed to one 

side of the subject so that this side is well lit and the other side has some 

shadow. However, you must enable shadows of the key light on the 

attribute window (see settings below). 
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b. Fill Light 

 
 

 This is the secondary light and is placed on the opposite side of the key 

light. It is used to fill the shadows created by the key. The fill will usually be 

softer and less bright than the key (see settings below). 

 

 

 

c. Back Light 

 

 The back light is placed behind the subject and lights it from the rear. 

Rather than providing direct lighting (like the key and fill), its purpose is to 
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provide definition and subtle highlights around the subject‘s outlines. This 

helps separate the subject from the background and provide a three-

dimensional look (see settings below). 
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UNIT II 

Texture in Maya 

Texture nodes are a type of render node that, when mapped to the material of an 
object, let you define how the object‘s surface appears when rendered. For more info on 
render nodes, see Render nodes.  Texture node(s) (with the material node(s)) feed into 
the Shading Group node, which tells the renderer how to shade the surface. For more 
information on Maya‘s Shading Group node, see Shading group node.  Texture nodes 
are procedural textures generated by Maya or bitmap images imported into Maya (see 
Procedural textures) that you can use as texture maps for material attributes. Texture 
maps on various attributes such as color, bump, and specularity affect the appearance 
of the material. For more information about texture maps, see Texture mapping.  

2D textures 2D textures wrap around an object, like gift wrapping, or stick to a flat 
surface, like wallpaper.  

 For a detailed description of Maya‘s 2D textures, see About 2D textures.  
 To map a 2D texture, see Map a 2D or 3D texture.  
 To position a mapped 2D texture on an object, see Position 2D textures and 

labels.  

3D Textures  

3D textures project through objects, like veins in marble or wood.  

With a 3D texture, objects appear to be carved out of a substance, such as rock or 
wood. You can scale, rotate and move 3D textures interactively in a scene view to 
achieve the desired results.  

 For a detailed description of Maya‘s 3D textures, see About 3D textures.  
 To map a 3D texture, see Map a 2D or 3D texture.  
 To position a mapped 3D texture on an object, see Position 3D textures.  

Environment textures   

Environment textures are commonly used either as backgrounds for objects in your 
scene or as reflection maps.  

For more information on simulating reflections with environment maps, see True 
reflections.  

For a detailed description of Maya‘s Environment textures, see About environment 
textures.  

http://download.autodesk.com/global/docs/maya2013/en_us/files/Asts_Render_nodes.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Asts_About_shading_networks.htm#WS17956D7ADBC6E736-51D3585C117AE33DCFA-7FF8
http://download.autodesk.com/global/docs/maya2013/en_us/files/Asts_Procedural_textures.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Asts_Texture_mapping.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Shading_Nodes_About_2D_textures.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Asts_Map_a_2D_or_3D_texture.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Asts_Position_2D_textures_and_labels.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Asts_Position_2D_textures_and_labels.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Asts_Position_2D_textures_and_labels.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Shading_Nodes_About_3D_textures.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Asts_Map_a_2D_or_3D_texture.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Asts_Position_3D_textures.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Reflection_and_Environment_True_reflections.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Reflection_and_Environment_True_reflections.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Reflection_and_Environment_True_reflections.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Shading_Nodes_About_environment_textures.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Shading_Nodes_About_environment_textures.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Shading_Nodes_About_environment_textures.htm
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Layered textures  

There are two ways to layer textures in Maya: using the Layered Shader with the texture 
compositing flag (see Layered shaders), or with the Layered Texture Node.  

Though the workflow for using the Layered Texture node is similar to the Layered 
Shader, using the Layered Texture node is recommended because you can set many 
blend modes.  To use the Layered Texture Node to layer textures, see Use a layered 
texture.  

Observing Light And Texture 

his is a follow-up entry to the 3D modeling tutorial of a computer monitor found here. 
This is going to cover basics of lighting and texturing a scene for a final render in 
Autodesk Maya 2012 

. 

 

 
If your Outliner isn‘t up, go to the top menu and navigate Window>Outliner. This will 
show you all of your scene elements and object groups. It‘s also a good way to select 
objects. 

http://download.autodesk.com/global/docs/maya2013/en_us/files/Asts_Layered_shaders.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Asts_Use_a_layered_texture.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Asts_Use_a_layered_texture.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Asts_Use_a_layered_texture.htm
http://www.devwebpro.com/3d-modeling-in-maya-making-a-computer-monitor/
http://usa.autodesk.com/adsk/servlet/pc/index?id=13578047&siteID=123112
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Now let‘s open the Hypershade. This is where we‘re going to build some textures. Go to 
Window>Rendering Editors, Hypershade. Now click Phong. This will create a new 
material in the hypershade. You can name it if you wish. Phongs have a somewhat 
plastic quality and we‘ll end up using this as the main material for the monitor and base. 

 

Ok now that you see the Phong in the Hypershade, double click it. Now you‘ll see the 
phong‘s attributes in the attribute editor on the right-hand side of the Maya workspace. 

 

Click on the color swatch to alter the material colors. Choose a near-black dark gray. 
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In the last tutorial we grouped all the objects we made for the monitor into 1 group. Go 
to the Outliner and select the group with the monitor parts in them. 

 

With that selected go back into the Hypershade and right-click the black phong material 
until the menu appears and choose ―Assign Material to Selection‖. 

 

Now there is a material on the monitor! Time to make a material for the desk. This time 
create a Blinn. Blinn properties tend to mimic metallic qualities. Double click and change 
to a gray and you should now have a silver material to assign to the desk. 
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Now let‘s make the screen. Go ahead and create a flat sheet with the Polygon Plane 
tool. 

 

Click and drag to create an approximate shape flat on the grid floor. 

 

Press ―E‖ to shortcut to the rotate function. And rotate it upwards so the screen is 
standing upright. 

 

Type in 90 in the screen‘s rotation attribute in the first tab in the Attribute Editor. Now it 
should be rotated to a perfect 90 degrees. 
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Press ―W‖ for the move function and place it in front of the monitor. ―R‖ to scale it 
appropriately and right-click the object>Vertex if you want to line them up perfectly in the 
orthographic viewports. 

 

Now the fun part! Take a screenshot of a website of your choosing and save it as an 
image file. The following pic is just a small version, so make sure yours is high 
resolution. 

 

The reason we made a plane and didn‘t use the monitor is that we‘re going to make an 
entirely unique material specifically tailored to the screen, or flat plane we just made and 
lined up. Go to the Hypershade and create a new Blinn. You may want to name it 
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something else as the more materials you make the more confusing it can become. For 
the color, click on the box on the right of the slider to open a new window. In the new 
window choose ―File‖. Now go into the attribute editor and click the folder icon to 
navigate to your saved screenshot and use that. Now this material should have the 
screenshot as it‘s texture map. Click back on the new blinn in the Hypershade to 
activate its properties in the Hypershade. Make sure the settings match on the following 
screenshot. Translucency is the main focal point because it will cause the material to 
glow. 

 

Go ahead and add this material to the screen. With the screen selected press ―6″ to see 
what the material looks like on it. You may notice it‘s not perfectly lined. We‘re going to 
have to alter the UV mapping of the plane object. Don‘t worry it‘s fairly painless. 
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Top menu>Window>UV Texture Editor. 

 

Go to your plane object, right-click and choose UV. Marquee select all of them. 
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Go back into the Texture Editor and notice the UVs have lit up. You‘ll notice that the 
plane‘s UVs are mapping only have of the texture. This is why the image appears 
stretched. 

 

Right click inside the actual Texture Editor and choose ―UV‖. Marquee select the 2 UVs 
in the middle and press ―W‖ to move them over so the 4 corners cover the entire square 
texture. 
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Now for some lighting! In my opinion, lighting is one of the most overlooked aspects in 
common 3D. It‘s what ends up making or breaking a final animation and all too often do 
I see fairly nice models and textures fall flat due to the complete omission of lighting 
sensibilities. For this simple scene, we‘re going to create 3 lights. This alone will 
completely transform the mood of the scene. Go to the top menu and choose 
Create>Lights>Point light. Position it to the rear of monitor and this will serve as a soft 
back light. Create a Spot Light and rotate it to point towards the front from above. Lastly 
create an Area Light. This will serve as the monitor acting as an actual light source. 
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Here are the settings I used for the Point Light as seen in the Attribute Editor. 

 

Settings for the Spot Light… 

 

And settings for the Area Light. You‘ll notice I used 1400 for the Depth Map Shadow 
resolution. I found that anything lower than this shadows can become fairly pixelated. 
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Higher the better of course, but you‘re looking at higher render times. Your choice, of 
course. 

 

One method we‘re going to learn today is ―light linking.‖ This allows you to have control 
over which lights cast on the objects you choose. Go to Window>Relationship 
Editors>Light Linking>Object-Centric. 

 

This will list all of your objects on the left side of panel, and the lights on the right. By 
default all lights are casting on all objects. 
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Click on the monitor group and link it only to the spot light. 

 

Do the same for the screen. 

 

Lastly we‘re going to tweak some Render Settings. Click the movie clapper icon with the 
2 dots on the side. Change the image size to HD 720 or your personal preference. 
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Frame the computer how you‘d like for it to appear in the render in the perspective view. 
The perspective camera is the default render view. Click the movie clapper 2 icons left 
of the render settings icon. 

 

Here‘s the completed render! Click for the hi-rez image. 

http://www.devwebpro.com/wp-content/uploads/2010/06/3drender-screenshotfinal-large.html
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Observing Lights And  Materials 

Select Window > Rendering Editors > Hypershade. 

You need to create two types of materials, a Lambert for the tire and a Blinn for the wheel. 

Select each material once and notice they show up in the Work Area tab in the Hypershade 

window. 

 

 
 

To apply these materials to the wheel and tire: 

 Select the wheel group so the entire wheel is selected.  
 Right-click the Blinn material in Hypershade and select Assign Material to Selection.  
 Do the same for the Lambert and apply it to the tire.  

 
Now concentrate on the tire. To give the tire the tread look you must apply a texture to 
the Bump Mapping attribute of the Lambert material. 
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1. In the Perspective view select the tire and press Ctrl-a. This opens the Attribute Editor 
on the right side of the Maya application window. 

2. Select the Lambert tab in the Attribute Editor. 

3. Change the color to a darker gray. 
 

 

4. Scroll down in the Attribute Editor until you see the Bump Mapping attribute and then 

click the Map button beside it. The Create Render Node window appears. 

5. Select the File node. 

6. In the Attribute Editor under the File tab, click the folder button and select your tire tread 
image file. After you select it, the Attribute Editor should look like this: 

 

 

 
 

  
 
 

Now you need to adjust the texture placement for the tire. You currently can't see what it 
looks like but you can do a quick render by clicking on the Render current frame icon. 

 
 

Notice the texture is not well placed. 
 

In the Attribute Editor click the Place2d texture tab for the image file and adjust the 
settings as seen in the following image: 
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Finally you need to change the bump value for the Lambert material. 

1. Select the tire and in the Attribute Editor under the Lambert tab click the button 

beside the Bump Mapping attribute. This will take you to the File tab. 

 Then you must click on the output button to get to your bump value. 
 

 

 Change the Bump Depth settings to a –1.00. 
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2. Now you will work on the Blinn Material for the wheel. 

 Select an object on the wheel.  
 In the Attribute Editor change the following settings under the Blinn tab.  

This will give you the setup you need to get a chrome look. 
 

 

 
3. You need to set up a light. 

 Select Create> Lights > Directional Light.  
 Modify the light settings in the light's Attribute Editor.  
 Rotate X = –45  
 Intensity = 0.8  
 Ray Trace Shadows = ON  

4. Create a floor. 

 Select Create > Polygon Primitives > Plane.  
 Modify the plane settings in the plane's Attribute Editor. 

Scale XYZ = 400  

 
5. Prepare for your render. 

 Select Window > Rendering Editors > Render Globals. The Render Global Settings 
window appears  
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 Change the following settings in the Common tab. 
 

 

 Change the following settings in the Maya Software tab. 
 

 

You are now ready to render. You may have to increase each surface's tessellation for 
better quality. 
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Texturing for Dummies 

As we all know, we are able to see things because ofthe way that light is reflected off 
things around us – the reflected rays shoot into our eyes, bounce around a complex 
setup of lenses and things inside our eyeballsthus enabling us to see this wondrous 
world around us So, basically, when setting up textures in CG, we have to bear in mind 
that we are dealing with reflection of light , and therefore creating the "instructions" for 
how the light should be reflected off the objects sur face by creating texture maps, right? 
Every detail we see on a surface is there for us to see because light h as bounced off it 
and into our eyes, showing us what the surface looks like. To sum it all up – shininess is 
the reflection of light – the stronger the reflection, the shinier the object. So, how do we 
set that up? This brings us back to the question – do we set this up using specularity? 
Or reflection?? To fully illustrate both sides of this question, let's look a little more 
closely at these two options... 

Photorealistic Texturing For Dummies 

 

Reflection – The Real Deal  

Fake not good enough for you? Well, reflection is pr etty self-explanatory. 
Using reflection on the surf ace  will obviously allow the object to reflect its 
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surroundings and local light-sources correctly. No need for any  in-depth 
explanations here, as we are all aware of what ref lection is and what it 
looks like.  
 
 

 
 
The Big Showdown – Specularity VS Reflection  Right, now that we understand 

what specularity is and  what reflection is, we can look at the argument as  to  whether 
to employ one or both in a surface.  
 
Photorealistic Texturing For Dummies 
Firstly, specularity renders faster than reflection . Accurate reflections require complex 
raytracing,  which  takes a lot longer to render that specularity. In or der to utilize 
reflection in most software, one has  to  activate a reflection option in the rendering 
settings, which adds time to the render in order to calculate the  reflections. And we all 
hate waiting for renders.  
Secondly,  reflection almost always makes objects begin to app 
ear mirror-like . To go back to our  earlier example of a plastic cup, if I want to make a 
plastic cup that should be realistic, using reflection  instead of specularity is more than 
likely going to  make the cup look unnecessarily mirror-like. Perhaps plastic isn't the 
best example here, as it usually  
is a bit reflective as well as shiny, so let me give another example – wood. Wood that 
has no varnish on it, and is  fairly dull, and really doesn't appear reflective at a ll, will 
nevertheless have a hotspot (however faint and spread-out it might be) on it if you shine 
a light di rectly  onto it. Giving the wooden surface a certain amount of specularity will 
allow this hotspot to show on  the  surface without it reflecting like a mirror, which is 
what would happen were you to use reflection instead.  The same goes for cloth. Look 
at the clothes you are wearing – light is creating highlights on your clo 
thes – these highlights are especially noticeable on folds  in the fabric, where it is 
catching the light. Fabric,  however, is most certainly not reflective in the sense of 
reflecting objects around it. So using specularity instead of reflection in this case is more 
feasible too.All this is rather mind-boggling when you consider the fact that the reason 
that objects appear shiny in the first place is because they are, technically, reflecting 
light. So even fabric is technically reflecting light. So is dull wood. It's justthat using 
reflection is CG tends to makes these surfaces look too mirror-like.  
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Texturing 

Materials are a critical part of creating attractive images and animation in a 3D program. 
Materials interact with lights, so lighting drives some material choices; for example, if 
your overall lighting is bright, you might need to make your scene materials somewhat 
more matte and light absorbing so that they don't blow out when hit by bright lights.  

What do we mean by "materials"? It's a catch-all term to describe all aspects of what a 
surface looks like. At first glance, beginners usually notice the surface color—red, wood 
brown, metallic silver. To an artist, however, there are many other factors: An object 
isn't just metallic silver, for example—it's a mirrored smooth finish that relies on the 
reflected surroundings for its appearance. In addition to factors of color, shine, and 
reflection, Maya also considers transparency, incandescence, translucency, refraction, 
bumpiness, and many other user-controlled parameters. Attention to these details gives 
your rendered results more subtlety and complexity. 

Realistic Skin 

The first thing youll want to do, before you even start a model, is a Character Reference 

Sheet. Here you put your concept art, or full turnarounds you use for modelling, and add 

your base color schemes and other details. For this tutorial, Ill be using the model and 

character from the above book, named Kila. Put as many details as you can on the 

character sheet, it helps with modelling and texturing. After the model is complete, make 

sure your UVs are aligned correctly. This book has a wonderful UV layout method, and 

Ill start the tutorial with the finished UV model. 

 

1. With your UVs imported into Photoshop, create a new layer under the UVs and name 

it 'Flats'. Use the colors on your character reference sheet and quickly lay in your flat 

colors. After they are complete, save them as flat images (Layer > Flatten Image) in a 

new file and then create new Lambert textures and place them on your model. Its best 

to keep two different Photoshop documents - a working file with everything on different 

layers, and a texture file that is flattened and attached to your model. Below are the flat 

colored UVs. 
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2. At this point, take the time to closely inspect your model to make sure all the UVs line 

up nicely on the painted texture. Its easiest to fix all the line errors now as opposed to 

later! 

 

3. Now its time to add shadows. Its easiest to add a new layer in your working file, name 

it 'Darker Tones' and paint in the darker shades you have on the character Sheet. Look 

at lots of real life references to get skin, hair, and clothing to look realistic. 
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1. Now for the lighter tones! Same concept as the darker tones, only brigher, of 
course. Make a new layer named "Lighter Tones" on top of flats and Darker 
tones, and paint in the highlights on the character, clothes, and hair. I would 
suggest two layers of lighter tones for the hair, as hair is much more complex in 
texture. 

                   

2. Now make two new layers "Shadows" and "Highlights" and make small, dark and 
bright, areas where shadows and highlights would naturally hit this character no 
matter the lighting. This can be very subtle in effect, however its one of the small 
details that really makes a character 'real'. 
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6. Now finish painting all the little character details, such as eyes, her tatoo, and other 

details laid out in the Character Reference sheet. Remember to use a new layer per 

detail, not only does that make it easier to change opacities, colors, and other details 

you can change your mind much easier if its not all one layer! 

  

7. Now, Kila is all painted and ready to go. There are some added details you can add 

through Alpha maps, however! First the hair, make a new layer in the hair file. Paint 

outside the hair shape with black, and all the hair white. Now, take the Smudge tool and 

blur the 'ends' of the hair - moving the black into the white. Ending up with something 

like the alpha map below. Now save the Alpha file as a seperate flattened image. 
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Now go into photoshop into the hair texture file. Go to the Channels box and create a 

new layer, called Alpha 1. Cut and paste the Alpha Hair into this channel.  Once again, 

flatten the image. Now go into Maya, and look at the Hair texture. Drag and drop the 

KilaHair file onto the texture's Transparency attribute. Now her hair has transparency! 

This step might cause some gaps - so redo some steps if the alpha was too stringy. 

Double check that you have black, white, a small amount of grayscale if you are still 

having troubles. 

 8. Using the hair texture, create a duplicate of the eyes geometry in Maya and move 

them forward for a realistic eye shine. Create black circles at first and then create eye 

details, looking at real eyes for reference. On the same map, you can create eyelashes 

as well. 

 9. Now, for the final steps. Kila doesnt really need a very enthusastic bump map, due to 

her clothing. Her skin could use a specular map due to the shininess of skin, but since 

she is a game character genereally these details are left out. Here are some final 

screenshots of Kila, with all her textures, specular maps, and a tiny amount of bump 

map. 
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 Texture Map  Nurbs Dragon 

 

Texture Map NURBS Dragon 

In this section, I would like to use Deep Paint 3D to help me to indicate the location of 
UV on the NURBS surfaces. But 3D Paint package only recognizes polygons with UV. 
So, we need to convert NURBS to polygon, then export the polygons to 3D paint 
program. First, I will create bump map in 3D-paint program, and then I will use 
PhotoShop to define the bump map. Let start now, 

1.Rename all the surfaces you had created, you can do this in the modeling stage. 
Select a surface, in the Channels window, key in a proper name for your surface.  

2.After renamed all the surfaces; I will apply a material for the surfaces.In this case, I 
would like to use Blinn for the skin as Blinn has the Softest specular highlight among the 
rest. 

Open up the Hypershade window, from the visor window's material folder, MMB drag 
the Blinn to the working space. (Figure 38). 

 

(Figure 38) 

Shift select the surfaces that u wish to assign to Blinn material, then point your mouse to 
Blinn in working space, Left click on Blinn (don't let go, a menu will pop- up, select 
Assign Material to Selected. (Figure 39) 
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(Figure 39) 

3. Toggle to Rendering mode; create a Direction Light from light panel. Place it to light 
up your model. Save your work. 

4.1 Now, we going to convert NURBS to polygons for Deep Paint 3D.I will going to do it 
part by part. First, I will do for left side head. Select the left side head, toggle to 
Modeling mode, go to Display->NURBS components->Normal (shaded mode) to check 
the Surface Normal is pointing out. Go to your perspective window, in the Shading 
panel->smooth Shade Selected Item to view the result. If the "hair" pointing in, go to 
Edit Surface panel->Reverse Surface Direction. This is to make sure that the polygon's 
surface normal point to the correct direction (Figure 40) 

 

(Figure 40) 

4.2 While the surface still selected, go to Polygons panel->NURBS to Polygon options. 
Set number U & V to 24. Click Tessellate. Move up the polygons, Now you will have the 
polygons Left Head and NURBS Left Head still remain. (Figure 41) 
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(Figure 41) 

4.3 Go to your Window panel -> General editor ->Plug-in Manager, select obj. 
Export.mll to loaded and auto load. Now, have your Lt_Head selected polygon, go to 
File->Export Selection's options, pick the file type as OBJexport, then save it to obj 
directory under your project directory or any directory that you like. 

5.1 Ok, we are going to leave Maya for a while. Launch any paint package that you like 
to import the Lt_Head. I will use Deep Paint 3D in this work. File -> open to the directory 
contain Lt_Head. obj and you will see this Material import window. In the Object column, 
your will find UV word, that's mean your polygons are prepared with UV, It's ready to 
paint! (Figure 42) 

 

(Figure 42) 
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5.2Click on the Material column's gray area to call up Set Material Size window, enter 
your texture size. It's good to keep your master copy texture in higher resolution that u 
can scale it down later according to your needs. 

5.3 I prefer to work on bump map as a colour map in grey rather then paint the real 
bump on the model. So I click on C (colour) in Material Channel, then click on colour in 
Add New Channel. Select white as my colour and will get this. (Figure43) 

 

(Figure43) 

5.4 After painted (figure 44) 

 

(figure 44) 
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click on export material to photoshop icon to further define the texture in photoshop. 
(Figure 45)  

 

(Figure 45) 

or save your image in 2D file format for Photoshop. 

5.5 This is my final bump map for Lt_Head. (Figure 46) Save your work to popular file 
type such as Targa in your texture directory. 

 

(Figure 46) 

5.6 From the bump texture, I used Photoshop's layering capability to create my colour 
map (Figure 47)  

 

(Figure 47) 

as well as specular map. (Figure 48) 
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(Figure 48) 

This texture can be reused to it mirrored or duplicated object without redraw your 
textures. It perfectly matches to them. So you only need to do for left side head 's 
colour, bump and specular and these are reusable for right side head. As well as one 
side of limb for map 2 side. 

5.7 I repeat these steps from 4.1 to 5.6 for the rest of the surfaces that I wish to do 2D 
mapping. (Figure 49) 

 

(Figure 49) 

5.8 As I proceed to the body, I found out that the creature's body in a piece is pretty 
hard to control my mapping, so I decided to detach it and rename them into 3 different 
surfaces: neck, torso and tail. Then stitched them back accordingly. (Figure 50)  

 

(Figure 50) 
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5.9 I deleted all of the polygon geometry in Maya after I completed my 2D textures paint 
because I going to use this textures map as UV map for my NURBS geometry. To 
delete all polygons geometry, go to Edit panel ->Select All by Type -> Polygon 
Geometry then press Backspace key to delete them. Now we remain all the NURBS as 
beginning stage. 

Press Backspace key to delete them. Now we remain all the NURBS as beginning 
stage. 

Using Triple Shading Switch to Shade the Creature 

This is the time to see how our textures go with the surfaces. As u can see, I will assign 
colour, bump and specular map to Blinn material. I'm going to use Switch node to 
enable me to specify a shading group for many objects to have different characteristic 
within the shaded members. 

1.Open Hypershade window and locate the early created Blinn. Rename it to Skin. 
Double click on it to bring up it's Attribute Editor. 

2.Click on the colour's map button (Figure52) 
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(Figure52) 

and you will bring up Create Render Node window. 

3.As for colour maps; the Triple Shading Switch will allow the switching of three-channel 
values (RGB). With this switch you can have a single shader control the general surface 
attribute of many objects but different texture of each object. Click on Utilities tab -
>Switch Utilities->Triple Shading Switch. (Figure 53) 

 

(Figure 53) 

4. Open Outliner window, put it beside Triple Shading Switch1 Attribute Editor window, 
select the renamed surface, MMB drag to inshape's column. (Figure 54) 
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(Figure 54) 

5.Click on Lt_head's inTriple column, then click on Map Item on the above will bring up 
Create Render Node window. Click on File under Texture's tab (figure 55)  

 

(figure 55) 

and will bring you to this window. (Figure 56) 

load the texture from your textures directory and change the "File #" to" Lt_Head 
colour".  

 

(Figure 56) 

6.Go to your perspective window's press 6 to turn on Hardware Texturing. (Figure 57) 
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(Figure 57) 

7.Repeat step 5 for the rest of inTriple's column. (Figure 58) 

(Figure 58) 

8.I will use the same way to map specular maps to the surfaces. Now, double click on 
the Skin (Blinn) from the Hypershade window's working space to bring up its attribute 
window. 

9.This time, I will click on Specular Colour's map button to add in Triple Shading Switch 
to allow the Skin (Blinn)'s shader to control the general surface attribute of many objects 
but different specular map of each object. (Figure 59) 

 

(Figure 59) 

You may want to take a look at Hypershader's workspace to view the connection 
between them. Right click and hold on the Skin (Blinn) to bring up a pop-up menu, 
select Graph Shader Network to view their render connection. (Figure 60)  
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(Figure 60) 

To see how's the specular maps placed on the model, go to the Skin's Attribute Editor, 
expend Hardware Texturing, select specular color. (Figure 61) 

 

(Figure 61) 

Using Single Shading Switch to Map Bump Maps 

The Single Shading Switch allows the switching of single float attributes, for example, 
bump depth.  

1, Bring up the Skin (Blinn) attribute, click on Bump mapping's map button, click on 
Utilities tab and select Bump 2d. (Figure 62) 
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(Figure 62) 

2. From the Bump 2d window, click on Bump Value's map button, Utilities Tab and 
Single Shading Switch. (Figure 63) 

 

(Figure 63) 

3. Doing the same way as before to load In Shape and In Single. (Figure 64).  
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(Figure 64) 

You may want to do a test render to view the result. 

 

Texture Mapping  

 Maya has a number of textures that you can map onto objects. For more information on 
these textures, see 2D and 3D textures.  

To apply a texture to an object you map (connect) it to the attributes of an object‘s 
material. (Textures and materials are render nodes. Render node attributes describe 
how the node appears and behaves; for more information, see Render nodes.) The 
attributes to which the texture is connected determines how the texture is used and 
therefore how it affects the final results.  

For example, if you connect Maya‘s 2D black and white Checker texture to the color 
attribute of an object‘s material, you have applied a color map; the checkered pattern 
determines which parts of the object appear black and which appear white (or other 
colors if you adjust the texture‘s color attributes).  

To map a texture, see Map a 2D or 3D texture.  

 

http://download.autodesk.com/global/docs/maya2013/en_us/files/Asts_2D_and_3D_textures.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Asts_Render_nodes.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Asts_Map_a_2D_or_3D_texture.htm
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If you connect the black and white Checker texture to the transparency attribute, you 
have applied a transparency map; the checkered pattern determines which parts of the 
object are opaque and which are transparent.  

 

For a description of how textures stick to materials of objects, see Mapping methods.  

Commonly used texture maps  

To map a texture, see Map a 2D or 3D texture.  

Color maps  

By mapping a texture to the Color attribute of an object‘s material, you create a color 
map which describes the color of the object.  

To learn more about how you can work with color in Maya, see Color .  

Transparency maps  

By mapping a texture to the Transparency attribute of an object‘s material, you create a 
transparency map which lets you make parts of an object opaque, semi-transparent, or 
entirely transparent.  

To learn more about how you can work with transparency in Maya, see Transparency.  

Specular maps  

By mapping a texture to the Specular attribute of an object‘s material, you create a 
specular map which lets you describe how shine appears on objects (by controlling 
highlight).  

To learn more about how you can work with highlight in Maya, see Specular highlight 
(shine).  

Reflection maps  

By mapping a texture to the Reflected Color attribute of an object‘s material, you create 
a reflection map which lets you describe how an object reflects its surroundings.  

http://download.autodesk.com/global/docs/maya2013/en_us/files/Asts_Mapping_methods.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Asts_Map_a_2D_or_3D_texture.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Asts_Surface_texture.htm#WS17956D7ADBC6E736-51D3585C117AE33DCFA-7FFD
http://download.autodesk.com/global/docs/maya2013/en_us/files/Asts_Surface_texture.htm#WS17956D7ADBC6E736-51D3585C117AE33DCFA-7FFC
http://download.autodesk.com/global/docs/maya2013/en_us/files/Asts_Surface_texture.htm#WS17956D7ADBC6E736-51D3585C117AE33DCFA-7FFB
http://download.autodesk.com/global/docs/maya2013/en_us/files/Asts_Surface_texture.htm#WS17956D7ADBC6E736-51D3585C117AE33DCFA-7FFB
http://download.autodesk.com/global/docs/maya2013/en_us/files/Asts_Surface_texture.htm#WS17956D7ADBC6E736-51D3585C117AE33DCFA-7FFB
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To learn more about how you can work with reflection in Maya, see True reflections.  

Bump maps  

By mapping a texture to the Bump attribute of an object‘s material, you create a bump 
map which lets you add the illusion of surface bump detail to a surface.  

To learn more about bump maps in Maya, see Bump maps.  

Displacement maps  

Displacement maps let you add true dimension to a surface at render time, a process 
which may reduce or eliminate the need for you to create complex models.  

To learn more about how you can work with displacement maps, see Displacement 
maps.  

Surface Parameterization 

Texture Mapping and Surface Parameterization 

Natural Surface Parameterization 

When designing the appearance of your props and characters, the natural 
parameterization, or "st coordinates", of your surface can often be the easiest means to 
describe how to lay out a pattern there. Alternate approaches involving projection are 
also quite useful because they can describe parameterizations that are continuous 
across multiple surfaces. Projective methods often fall short of perfect in that the simple 
geometries we use to describe the projections can't capture the complexities of organic 
shapes with odd topological structures. The general rule on parameterization is: if your 
problem can be solved with the natural parameterization then use it! 

Maya and MTOR may Differ 

Prior to MTOR 3.0, MTOR/RenderMan always parameterized NURBS differently than 
Maya's internal renderer. This "legacy" parameterization results when you constrain the 
CV ordering to match between the RenderMan 
representation and Maya's internal representation.  This 
difference is  easy to compensate for, but it can lead to 
confusion if it isn't understood.   

Starting in MTOR 3.0, we allow you to choose between 
the legacy parameterization and the standard Maya 
parameterization.  If you choose the latter, MTOR 
reorders your CVs (and Primitive variables) to achieve a 
parameterization match. In order to support backwards 

http://download.autodesk.com/global/docs/maya2013/en_us/files/Reflection_and_Environment_True_reflections.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Surface_Relief__Bump_maps.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Surface_Relief__Displacement_maps.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Surface_Relief__Displacement_maps.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Surface_Relief__Displacement_maps.htm
http://www.hradec.com/ebooks/CGI/RMS_1.0/mtor/shading/shader_concepts/ProjTex.html
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compatibility we've provided you with two controls.  First there's a "gang switch" located 
in $RATTREE/etc/mtor.ini.  This preference (mtorNURBSStyle) allows you to specify 
that all NURBS should be converted according to one approach or another.  In order to 
guarantee backwards compatibility, we've set the value to "legacy" but you can choose 
the default behavior for your site or project.  The second control is per-NURBS and can 
be found in the RenderMan->Attributes->NURBS UVs menu.  You can select one or 
more NURBSs and assign either the legacy behavior or the new Maya-match behavior.  

Maya has an assortment of useful tools to manipulate the standard parameterization of 
a surface and the ability to parameterize your surface by chord length. MTOR allows 
you to take advantage of these Maya tools, but lets you decide whether or not to use or 
ignore Maya's ideas about parameterization.  

The Difference - Legacy Parameterization 

Above is a typical NURBS surface as seen in Maya. If you create and attach a Maya 
texture to this surface, then render the image using the Maya renderer, you'll get a 
picture like the one directly below, left. Alternatively, if you create and assign a 
RenderMan texture (we used the Mondo shader for this example), then render with 
RenderMan, you'll get the picture below, right. The fact that the pictures are different 
may at first be rather unsettling.  

 

The difference comes about due to differences in RenderMan's and Maya's definition of 
NURBS parameterization. On closer inspection, you may notice that the 
parameterizations aren't that different. In fact we can simply rotate the texture 90 
degrees to achieve a match. This turns out to be an easy thing to do. So, rather than 
simply adopt the Maya default parameterization, we allow you you to decide which 
parameterization should apply. 

Compensating 

When building shading networks with Slim you can compensate for this by using the ST 
manifold. Simply set the parameter Angle to 270 degrees to match up with Maya.  

To make the same compensation with the Mondo shader is a little more complicated. At  
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right are screen dumps from portions of three different instances of the Mondo shader, 
as viewed within Slim. The parameters STMatrix0 and STMatrix1 transform the natural 
parameterization of your surface and are present in most texture mapping shaders. To 
add these parameters to your custom shaders, please refer to the source for the Mondo 
shader and associated .sli file.  

The default values for the STMatrix parameters are represented at top and have no 
affect on the parameterization. The second set of STMatrix values represent the 90 
degree rotation values required to cause the RenderMan image to match Maya's. If you 
need more precise control over texture placement and scale, you can use Maya's 
texture placement tools. Currently, MTOR only translates the values associated with UV 
remapping: Repeat UV, Offset and Rotate UV. Now, you can refer to the 
parameterization associated with the texture placement tools as indicated by the third 
(bottom) set of STMatrix values. Here we construct a expressions whose argument is 
the name of the Maya texture placement node. This can be determined through the 
MultiLister or Attribute Editor windows.  

Applying Chord Length 

So now we know how to cause RenderMan to match the Maya parameterization and 
this lets you take advantage of Maya's texture placement tools. However, we still have a 
problem with our surface parameterization. In the images above you can see how the 
texture is squished or stretched according to the locations of the so-called isoparms. 
Sometimes it's desireable to eliminate these distortions and, for this, a technique known 
as chord length parameterization can be 
employed. Starting with Maya 1.5 you can correct 
this distortion via the Texture Map controls 
associated with your surface. A dump from the 
Maya Attribute Editor window at right shows the Fix 
Texture Warp checkbox. When you enable this 
feature, MTOR automatically calculates and 
attaches the correct RenderMan vertex variables to perform chord length 
parameterization. Note that the chord length corrections are independent of the 
mapping issues outlined above. Thus you can toggle this checkbox on and off and still 
get the same relationship between Maya and RenderMan renderings. With Fix Warp 
enabled, we get this image:  

http://www.hradec.com/ebooks/CGI/RMS_1.0/mtor/rendering/intro_MTOR/primitive.html
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To correct for parametric distortions, the Fix Warp button can be quite handy. If you plan 
to animate your surface, however, this isn't the best solution. This is due to the fact that 
the chord-length calculations are performed every frame and this can cause some 
unwanted texture swimming artifacts.  

ST Vertex Variables 

A better solution is to stick the chord length parameterization at 
a particular point in time. To accomplish this, choose the Vertex 
Variables->st: chord length menu item from the 
MTOR/RenderMan menu. The moment you invoke this 
command, MTOR computes the chordlength correction factors 
and sticks these results to your surface. These values are now 
associated with the individual CVs and will move with them. 
Since the parameterization values are stuck to the CVs, any 
deformations applied to the CVs will affect the texture and you'll get the familiar and 
usually desireable rubber-sheet texture distortions. 
 
As discussed elsewhere, natural projections are not always sufficient. If not, you can 
use the Vertex Variable menu entry __Pref: freeze to freeze the surface CVs into a 
special vertex variable named __Pref. Instead of 2-dimensional surface parameterization 
embodied in the s and t vertex variables, this results in a 3-dimensional 
parameterization which can form the basis for projective and 3D paint techniques 
employed in many RenderMan shaders.  

The menu functions associated with RenderMan vertex variables are independent of the 
Maya version and so you can get chord length parameterization in your RenderMan 
pictures whether you're using Maya 1.0.1 or Maya 1.5, etc. We've provided some 
additional features to manipulate RenderMan vertex variables. The Vertex Variables-
>st: random causes random st values to be associated with the CVs of your selection. 
This can either be useful for debugging shaders or just to achieve strange results.  

http://www.hradec.com/ebooks/CGI/RMS_1.0/mtor/shading/shader_concepts/ProjTex.html
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Deleting Data 

Since these functions actually stick data onto your surface CVs, you'll find the st: delete 
and any: delete commands useful. The latter can be used to delete vertex variables 
attached by mel scripts or via the Artisan interface.   

Texture Resolution 

A common question when new to texture mapping, is what resolution should textures 
be? This is assuming that you are going to be making your own in a 2D package, such 
as Photoshop, either from scratch or from a scan. Well, the first thing to do is ignore dpi 
settings. All you care about is the pixel by pixel resolution of the image. If you are 
scanning an image, most scan software will have you specify dpi. A 4"x5" photo 
scanned at 300dpi will yield a 5MB 1200x1500 pixel image. But once the image is 
scanned, you will no longer concern yourself with it's dpi setting. So lets say we did 
scan the aforementioned image and now have a 1200x1500 pixel document. This is 
going to be much larger than necessary for most applications. And using textures which 
are too big simply slows down your render time and gives your scene a bigger memory 
footprint. (meaning the amount of RAM needed on the machine to render the scene). If 
your memory footprint is bigger than the amount of RAM on the system, the machine 
will need to use space on your hard drive, known as 'swap' space, and when you begin 
swapping, things really slow down... and then you're on the verge on not being able to 
render the scene at all... not a good thing. 

http://www.hradec.com/ebooks/CGI/RMS_1.0/mtor/modeling/artisan/artisan.html
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So, here's a simple example: you need to texture a doorway. Well, in the above image, 
the doors are a single NURBS plane, as they do not need to open. You need to ask two 
questions... what is the closest the doors will get to the camera, and what is our final 
output resolution? If the above example IS the closest we will get to the doors, then let's 
also say we are rendering at 640x480. 

Since 100% of the door is in the frame, then what percentage of the frame is it filling? It 
looks like it is about 1/3 the width of the frame, which would be 213 pixels. Maya, 
however, prefers textures to be in multiples of 64, so the best horizontal size for the 
texture would be 256. Maya also prefers textures to be square, so our texture should be 
256x256 pixels. It is not 'necessary' for them to be square, however and I often use non-
square textures. Its just that a 256x128 texture will use up the same amount of memory 
as a 256x256 texture when rendering. So now that this is all figured out, we can go to 
Photoshop and reduce our texture to the correct size. It is a good habit to have higher-
res versions archived in-case you want to render your scene at a very high-res for print, 
for example. 
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So above is the texture we're going to put on the door. Its too big, but we'll archive it. 

 

So here we go... 256x188 pixels. 

 

Looks ok in Maya... But watch out. Maya blurs imported file textures a bit by default, so 
even though you we're responsible and determined the optimum size for your texture, it 
will look a bit blurry in a rendering. Select the File texture in the Multilister, open the 
Attribute Editor, and in the Effects folder, set the Filter setting to '0'.... it defaults to 1. 
This can be useful if your texture is too small. The 'Filter' can blur your texture to reduce 
pixelation, but if your texture is the right res, be careful.  

So after all this, we're ready to render...  
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Now this example may seem simplistic, but that's the point. It is never really gets any 
more complicated that this. Lets look at that stone wall which the door is inset within. 
We are only seeing about 1/3 of that surface's total width. Thus its texture needs to be 
1920x240 if we were to use a single texture to cover the whole thing. But instead of 
dealing with such a large texture, I used a 256x256 texture which is repeated four times 
horizontally. If we are never going to have the entire wall in frame at once, the repeats 
will be much less noticeable. 

Sky Maps  

Introduction  

This tutorial covers the details of working with Mental Rays Physical Sun and Sky.  

Documentation  

Mental Images provides documentation that is available through the Maya help: mental 
ray for Maya architectural shaders - Sun and Sky.  

Requirements  

Although the Physical Sky can be used with most shaders, it's recommended to use the 
Mental Images Architectural (mia) shaders to get the best results.  

Rendering using either Final Gather or Global Illumination (or both) is mandatory.  

 

http://wiki.bk.tudelft.nl/toi-pedia/Mental_ray_rendering
http://toi.bk.tudelft.nl/maya/help/docs/Maya2011/en_US/mr/shaders/architectural/arch_sunsky.html
http://toi.bk.tudelft.nl/maya/help/docs/Maya2011/en_US/mr/shaders/architectural/arch_sunsky.html
http://toi.bk.tudelft.nl/maya/help/docs/Maya2011/en_US/mr/shaders/architectural/arch_sunsky.html
http://wiki.bk.tudelft.nl/toi-pedia/Rendering_Mental_Ray:_mia_material
http://wiki.bk.tudelft.nl/toi-pedia/Rendering_Mental_Ray:_Final_Gather
http://wiki.bk.tudelft.nl/toi-pedia/Rendering_Mental_Ray:_Global_Illumination
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Creating a Physical Sky  

Open your Render Settings: use the button in the Status Line or go to 
Window » Rendering Editors » Render Settings.  

Set Render using to Mental Ray.  

If the Mental Ray option is not shown in the pull-down menu of the Render Settings, go 

to: Window » Settings/Preferences » Plug-in Manager and make sure the check-boxes 

for Mayatomr.mll are checked. 

Open the Mental Ray tab ans scroll down to the section Environment:  

 

Click the Create' button for Physical Sun and Sky  

Maya will create all the required nodes. The settings for the Physical Sky will open in 
the attribute editor. In the origin, a directional light, called sunDirection will be created. 
Rotating this light will determine the direction of the sun rays. At render time, Mental 
Ray will create a matching sky (with a sun disk at the correct location) and the correct 
physical properties.  

Settings  

Sky settings  

You can open the settings of the physical sky from the Render Settings. Go to the 
Environment section and click the link button:  
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The settings will open in the Attribute editor:  

 

RGB Unit Conversion  

Mental Ray uses a Physical correct light intensity of 127500 lux for the sky dome. 

As this would produce images that are way overexposed, Mental Ray corrects 

this using the Unite Conversion factor. The default is fine in most cases. Use the 

Tone mapper (mia_exposure_simple) that is created by default for fine tuning. 

See the section Color corrections on this page for details.  

Sun Disk Scale  

Size of the Sun disk in the sky. 1.0 would be accurate, but many prefer a slightly 

bigger sun disk for a more pleasing result.  

 
A complete overview of these settings is documented in the Mental Ray docs, available 
through the Maya help: Sky Parameters.  

 

http://wiki.bk.tudelft.nl/toi-pedia/MR_Using_the_Physical_Sun_and_Sky_environment#Color_corrections_.28Tone_Mapping.29
http://toi.bk.tudelft.nl/maya/help/docs/Maya2011/en_US/mr/shaders/architectural/arch_sunsky.html#Sky_Parameters
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Camera connections  

The Physical Sky environment needs to be linked to your camera. When you create a 
new camera, these connections aren't made by default. You have to do that 
manually. Open the settings for the physical sky (see above).  

Update Camera Connections (button)  

When clicked, Maya will connect the Exposure control node (mia_exposure_simple) to 

any camera that was created since the physical sky was created (and thus isn't 

connected yet).  

Sun settings  

You can open the settings of the physicalsun through the attribute editor of the 
sunDirection Directional light, or through the attribute editor of the physicalsky. To do 
this select the directional light and press 'ctrl+A'. Switch to the tab mia_physicalsun# (# 
can be any number, in most cases: 1). Most of the settings are good by default for a 
simple render. Changing the default shadow settings can increase image quality  

 

The settings for the Physical Sun open in the attribute editor:  

 

Shadow Softness  

Determines the softness of the shadows. 1.0 is physically correct. You could decrease 

the value to get less grainy (but also less soft) shadows without increasing render time.  

Samples  

Determines the accuracy of the soft shadows. The default of 8 may produce grainy soft 

shadows. Increase as needed, but this will also increase render time.  
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A complete overview of these settings is documented in the Mental Ray docs, available 
through the Maya help: Sun Parameters.  

Color corrections (Tone Mapping)  

When you create the Physical Sun and Sky, the Tone Mapper, mia_exposure_simple 
will be automatically connected to the cameras that where present when you created 
the Physical Sun and Sky (with exception of the orthogonal cameras).  

If you've created cameras since, you need to update the connections of the 
mia_exposure_simple. You can use the Update camera connections button to do this 
automatically.  

For a simple render the default settings of the tone mapper are sufficient. However if 

your render has very dark looking areas or overexposed parts, it could be handy to 

change the settings as described below. 

Configuring the Tone Mapper  

The mia_exposure-simple node can be accessed in several ways. The easiest way is 
through your Hypershade:  

 

Open the Utilities tab. You should find an overview of all mia_exposure nodes present in 
your scene. You can doucle-click the node or select it and open your Attribute Editor.  

The mia_exposure_simple node has several settings. A brief overview:  

Pedestal offset for the entire range (darken or lighten the absolute black) gainmultiplication 

factor.  

Knee value above which the range should be compressed  

 

http://toi.bk.tudelft.nl/maya/help/docs/Maya2011/en_US/mr/shaders/architectural/arch_sunsky.html#Sun_Parameters
http://wiki.bk.tudelft.nl/toi-pedia/MR_Using_the_Physical_Sun_and_Sky_environment#Settings
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compression 

compression ratio to squash the range that is compressed  

gamma 

gamma correction  

For details on these settings, refer to Mental Ray Tone Mapper Settings.  

Start of with the gain setting. If your render is to dark, increase its value. If it's too bright, 
lower the gain. You should aim to have the dark- and mid-tones rendered properly. You 
highlights may still be overexposed.  

The increase the Compression setting to compress the highlights within the visible 
color range. Settings of up to 50 may be necessary. Increase the value in steps of 5-10 
and make test renderings.  

When very high compression settings are needed (>30), you may consider lowering the 
Knee value a bit. Decrease in steps of 0.05. Don't go below 0.5.  

Finally you can use the Gamma to tone down your image (1.8) or make it more vivid 
(2.2 or even 2.4).  

Textures and Tone Mapping  

File textures may get washed out, because of incorrect gamma. The 
mia_exposure_control applies gamma correction on the final image. Mental Ray 
expects file textures to be 'gamma neutral', which they are (probably) not. Chances are 
you've created them for a gamma of 2.2 or so, which is the default for computer 
screens. If the mia_exposure control corrects the final rendered image to the gamma 
you specified, the textures would get gamma-corrected again, which causes them to 
look washed out:  

 

 

http://wiki.bk.tudelft.nl/toi-pedia/Rendering_Mental_Ray:_Tone_mapping#Theory_of_mia_exposure_simple


110 | P a g e  

 

 

 

Show only beforeShow only after 

The left side shows a render without proper gamma correction, the right side shows the 
render as it is supposed to be, after proper gamma correction of the file textures.  

There are two main methods to solve this problem: Change the Mental Ray internal 
framebuffer gamma and the Exposure control gamma, or gamma-correct each 
filetexture.  

The first method is the easiest to implement:  

 Open you Render settings, Mental Ray tab. Find the Framebuffer section and 
open the Primary Framebuffer subsection. Set the gamma to 1/desired gamma, 
so 1/2.2 = 0.4545 for a end-result gamma of 2.2  

 Set the Gamma of your mia_exposure_simple to 1.00.  

Alternatively you could use the MR Gamma correction MEL script to correct the gamma. 
This will add gamma correction nodes to all file textures, counter-correcting them for the 
specified gamma, so the end result should look good.  
 

Physical Sun and Sky Nodes  

The Physical Sun and Sky setup uses several nodes. They are accessible in various 
ways. One unified way to access them all is through the Utilities tab of the Hypershade:  

javascript:void(0)
javascript:void(0)
http://toi.bk.tudelft.nl/?module=meldb&page=details&sID=42
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Transparency Shadows 

Be aware that volume shadow occlusion only works with depth-map shadows. This 
creates problems if you have transparency mapped objects, as is the case with the wall. 
So how can we get an object with a transparency map to cast accurate shadows without 
raytracing? (i.e. depth-map shadows). 

 
Shading Network: Transparency, Specular, Bump 

In the above scene we have a trashcan made from a revolved surface with a Blinn 
shader which uses specular, bump and transparency maps to create the desired 
appearance of being made out of a wire mesh.  
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trashcan with Depth-map (left) vs Raytrace shadows 

In the above image, the key light is using D-map shadows (left), which are casting a 
fully opaque shadow based not on the object's transparency but on its tesselation. The 
right image displays accurate shadows, at the cost of enabling raytrace shadows. For a 
720x480 render, the D-map shadow took 7sec while the raytrace shadow took 150 sec!  

In order to solve this dilemma (which if you are going to use fog volume occlusion you 
must solve somehow but, if not, you still want to avoid raytracing), we are going to 
create a 'shadow object'. A surface whose purpose is to cast the accurate Dmap 
shadow, but not actually render. We will therefore end up with two objects on top of 
each other in our scene. 

Step by Step on a Sphere: 

 
mesh Shader on sphere: Dmap vs raytrace shadows 

1. Select the original transparency mapped object and turn off the 'casts shadows' 
attribute in the Attribute Editor render stats. 

 

2. Put the object on a display layer called 'primary object'.  

3. Duplicate the primary object and put the copy on another layer called 'shadow object'.  
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4. Turn off the visibility of the primary object's layer. 

5. Assign a new lambert shader to the shadow object. 

6. Assign the primary object's bump map to the shadow object's displacement. 

 
render of mapped Displacement with default settings 

7. Determine the appropriate tesselation and alpha gain to yield the desired 
displacement. 

An object's tesselation settings determine how accurately the displacement represents 
the source image... the higher the tesselation, however, the more polys you are going to 
get. Keep this to a minimum through the understanding that the displacement will be 
used to create the Depth map... therefore if your scene is going to have soft light 
sources (soft shadows), you can get away with fewer polys in the shadow object. 

 
render of displacement after lowering 'alpha gain' 

Also be sure to have the depth of the displacement correlate to the shader on your 
primary object. With the default settings, the displacement was way too deep. To reduce 
the displacement's depth, lower the 'alpha gain' attribute on the displacement texture. 

8. Select the shadow object and utilize 'Modify/Convert/Displacement to Polygons'. This 
step will create a new poly surface which is the actual 'shadow object'. The object which 
was converted can be deleted.  
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shadow object converted to polys 

9. Delete faces which represent the 'primary' objects's transparency. Select the poly 
shadow object, goto Edit/Paint Selection and the vertices will appear. To switch to 
faces, right-click on the surface and choose 'faces' from the pop-up. You can now 'paint 
select' with Artisan. To re-size your brush, the default hotkey is 'b'. 

 
progress of deleting faces via Artisan 

This step can be time consuming if you select and delete faces manually. Artisan can 
greatly speed up this process and is almost always faster, unless your shadow object is 
flat and faces can be quickly selected from an orthographic view. 

note: one question that you may be asking is why even bother with the primary object 
once you have modeled/created the shadow object. The reason is simply that you can 
get a much smoother level of detail via transparency. The shadow object does not need 
to have as many polys as the primary object would need... especially when dealing with 
soft shadows. 

10. Turn off 'primary visibility' for the poly shadow object. 

11. Turn on the visibility for the primary object's layer. 

At this point we have two objects, primary and shadow, which should both be visible in 
Maya before rendering. One is the object which we see and which the light illuminates, 
the other we do not see, but the lights incorporates it into the Dmap calculation. 
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Primary and Shadow objects visibile 

The only thing left to do is determine the Dmap settings necessary for the quality of 
shadows required... high-res for hard shadows, low-res for soft shadows... this will 
depend on your project. 

 
Dmap Shadows: 256x vs 512x, filter size = 5 

In the above image we have achieved our goal... A transparency mapped object casting 
Dmap shadows which can be efficiently managed in regards to quality and render time. 
The above images took only 10 seconds to render at 720x480, while raytracing 
softshadows for the object took about 150 seconds. Plus, we have the added benefit of 
being able to incorporate fog shadow occlusion effects with the object. 

 
point light with Dmap shadows and fog 

Well, that about covers it for now... hope this technique helps you out of a tough spot 
someday, and shows you how to manage Dmap calculation time as well 
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UNIT III 

Rendering in Maya 

MAYA Tutorial - Rendering  

  
 

  

  The process of creating an image or sequence of images from a scene. During 
rendering, Maya generates a two-dimensional image, or series of images, from a 
specific view of a three-dimensional scene, and saves it as an image file. 

You can control the properties of rendered image files according to your post-
production or presentation requirements. 

Maya software Renderer 

Maya's software renderer is an advanced, multi-threaded renderer. It is based on a 
rendering technology that is built directly into Maya's dependency graph architecture, 
which means its feature nodes can be intimately connected with any other feature in 
Maya. It is a hybrid renderer, offering true raytracing plus the speed advantages of a 
scan-line renderer. 

The Maya software renderer supports all of the various entity types found within 
Maya including particles, various geometry and paint effects  and fluid effects. It also 
has a robust API for the addition of customer-programmed effects.  

Rendering an Animation  

When you're ready to render a finished animation, open the Render Globals button 
on the Status Line, just to the right of the IPR Render button. You can also activate it 
with Hotbox >Window > Rendering Editors > Render Globals. 
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Render Global Settings  

  

         

Fig 9-1 Render Globals 

                

You can select the Maya Software (or standard) renderer, the Maya Hardware 
renderer, Mental Ray, or the new Maya Vector renderer from Render Global Settings 
window. In all renderers, however, the information in the Common tab remains nearly 
the same. The settings for Start Frame, End Frame, and By Frame are activated if 
you choose a movie file output format or a filename numbering extension for your 
saved files. A Frame Padding setting of 3 or 4 works for almost all situations. This 
setting determines how many digits are added to the end of the filename, so setting 
Frame Padding to 4, for example, results in files being numbered as 
filename.0001.TGA, filename.0002.TGA, and so forth.  

The default animation render length is set to frames 1 through 10—a short 
animation. 

The Resolution section is where you set the image size; you can use the Presets list 
box to choose from a range of resolutions. Most of your tests will be at a lower 
resolution, typically 320x240 or 640x480. 

The second tab changes its name depending on what renderer you've selected. If 
the only renderer options you see are Maya's software and hardware renderers. The 
Anti-aliasing Quality setting has a big impact on rendering speed and image quality. 
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Images that are poorly antialiased have a jagged appearance, particularly visible 
where different-colored objects overlap or in areas of high contrast.For tests, you'd 
select the Preview Quality setting in the Presets list box; for final rendering, use the 
Production Quality setting, and select the Gaussian or Quadratic B Spline Filter in 
the Multi-pixel Filtering section for smoother-looking images.  

Render the scene using raytracing 

The Raytracing section is where you configure raytraced reflections, refractions, or 
shadows to appear in the rendering; it's disabled by default, so you need to expand 
that section to enable the options. Raytracing can also slow your rendering time 
dramatically. The numbers for the Reflections, Refractions, and Shadows attributes 
refer to the depth of raytracing—the number of bounces allowed for a ray. As the ray 
strikes reflective or refractive objects, it ricochets through the scene. If the number of 
bounces reaches the limit set here, no further raytracing is done, and the pixel is 
colored based on the contribution of the previous bounces added to black. 

Rendering a Still 

When you want to render a test frame, you simply activate the panel of the view you 
want, and click Hotbox > Render > Render Current Frame. The settings in the 
Render Global Settings window determine the resolution, ant aliasing, and 
raytracing, but only one frame renders, and it's saved as a temporary .iff (or 
whatever image format you've chosen as the default) file in the Images directory of 
your project. When the rendering is finished, you can save the rendered image to a 
permanent file by right-clicking on the Render View window and choosing File | Save 
Image in the Save dialog box that opens. 

For images you have rendered and saved, you can view them with Maya's FCheck 
utility.  

To cancel the render 

Press Esc.  

Rendering Engines in Maya 

Maya 5 has added new rendering engines called Mental Ray and the Vector 
renderer. You can access these new renderers plus the Maya software and 
hardware renderers in the Render Global Settings window. With these new rendering 
options, Maya can quickly produce cartoon or web-like media with the Vector 
renderer and photorealistic renders using Global Illumination or HDRI in Mental Ray.  
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Introduction to Rendering   

 

Rendering is the final stage in the 3D computer graphics production process.  

Though the wider context of rendering begins with shading and texturing objects and 
lighting your scene, the rendering process ends when surfaces, materials, lights, and 
motion are processed into a final image or image sequence.  

Visualization vs. the final render  

As you build your scenes (shade and texture objects, light scenes, position cameras, 
and so on), you‘ll want to visualize your scene many times before you produce the final 
rendered image or image sequence. This process may involve (depending on your 
particular project) creating and setting up additional cameras.  

Visualize a scene during early iterations to detect and correct image quality problems or 
to estimate and reduce the amount of time the final render takes before you spend time 
performing the final render.  

When you are satisfied with the results of your scene during test renders, you can 
perform the final render.  

You can visualize and final render a single frame, part of an animation (multiple frames), 
or an entire animation in Autodesk® Maya®.  

The key to successful rendering  

The key to rendering is finding a balance between the visual complexity required and 
the rendering speed that determines how many frames can be rendered in a given 
period of time.  

Rendering involves a large number of complex calculations which can keep your 
computer busy for a long time. Rendering pulls data together from every sub-system 
within Maya and interprets its own data relevant to tessellation, texture mapping, 
shading, clipping, and lighting.  
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Producing rendered images always involves making choices that affect the quality (anti-
aliasing and sampling) of the images, the speed with which the images are rendered, or 
both.  

The highest quality images typically take the most time to render. The key to working 
efficiently is to produce good-enough quality images in as little time as possible in order 
to meet production deadlines. In other words, choose only the most economical values 
for options that let you produce images of acceptable quality for your particular project.  

Introduction to Rendering   

Rendering Maya for HD720 

1. Setting Up a Camera In Maya 

From the menu choose Create->Cameras->Camera. 

In the channel editor on the right, rename the camera "Shot_1". 

With the camera selected, choose Window->Attribute Editor and match the settings 

marked in red below. 
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In the Maya Preferences (Window->Setttings/Preference->Preferences set the following 
the match the window below. If you change the frame rate at this point (after you have 

created keyframes) maya will scale your keyframes and they will no longer fall on exact 
frames. Could be messy. Its good to set these preferences before you start animating. 
For my classes - this should be set to 24fps. If you are adding maya animation to live 

action footage this should match the frame rate of your footage and ultimately the fps of 
the final work. 
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2. Set up the Render Globals 

Before setting the Render Globals, go to (Window->Settings/Preferences->Plug-in 
Manager) and make sure to check MayatoMR.bundle. 

Then open up (Window->Rendering Editors->Render Settings). Match the settings to 
this screen shot. 
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Then click on the Mental Ray tab at the top and match the other picture below and 
match the settings. 

 

4. Check that your Maya project database is set correctly. 

Choose File->Project->Set. Then navigate to your Maya Database (the folder containing 

all of the folders that Maya created when you created a new project.) 
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This step is important because it insures that your files will be rendered to the images 

folder in your database, rather than the images folder in your default database on your 

H drive. 

5. Begin the Render. 

Switch Maya into rendering mode (press F6 on the keyboard). 

Choose Render->Batch Render->OPTIONS square 

Check the "Use all available processors" (we have dual processors). 

Click Batch Render 

You will be able to monitor the progress of the Render in the blue feedback strip along 

the bottom of the Maya application. When the render is complete, you will be able to 

find your files in the Images folder inside of your Maya Database. 

Render Setup 

Software rendering  

Software rendering produces images of the highest quality, letting you achieve the most 
sophisticated results.  

Computation occurs on the CPU, as opposed to hardware rendering, which relies on the 
machine‘s graphics card. Because it is not restricted by the computer's graphics card, 
software rendering generally is more flexible. The trade-off, however, is that software 
rendering is generally more time consuming.  

Exactly what you can render depends on which software renderer you use and its 
particular limitations.  

Maya has the following software renderers:  

 The Maya software renderer  

To find out about Maya‘s software renderer, see Maya Software renderer.  

 NVIDIA® mental ray® for Maya®  

http://download.autodesk.com/global/docs/maya2013/en_us/files/About_rendering_and_renderers_Maya_Software_renderer.htm
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To find out about mental ray for Maya, see About the mental ray for Maya 
renderer.  

Hardware rendering  

Hardware rendering uses the computer's video card and drivers installed on the 
machine to render images to disk. Hardware rendering is generally faster than software 
rendering, but typically produces images of lower quality compared to software 
rendering. In some cases, however, hardware rendering can produce results good 
enough for broadcast delivery.  

Hardware rendering cannot produce some of the most sophisticated effects, such as 
some advanced shadows, reflections, and post-process effects. To produce these kind 
of effects, you must use software rendering.  

Maya has the following hardware renderer:  

Use the Maya Hardware 2.0 renderer to perform command line rendering for Viewport 
2.0, or to batch render to disc or to Render View.  

Render Types 

You can select the Maya Hardware 2.0 renderer using the following methods:  

 Render View window  
 Render Settings window  
 Render > Batch Render  
 From the command line using the Render command  
 From the command line in prompt mode (-prompt)  
 From the command line in batch mode (-batch)  
 From the MEL tab in the Script Editor (ogsRender)  

Supported features  

 File Output settings in the Common tab in the Render Settings window are 
supported.  

 Rendering from different camera types (including stereo cameras) are supported.  

H/W and S/W Render Settings 

Limitations of the Hardware 2.0 renderer  

 In the Render View window:  
o Render region is not supported.  
o IPR is not supported.  

 Render layers is not supported.  
 Only color output is supported. Depth channel is currently not supported.  

http://download.autodesk.com/global/docs/maya2013/en_us/files/mental_ray_for_Maya_rendering_About_the_mental_ray_for_Maya_renderer.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/mental_ray_for_Maya_rendering_About_the_mental_ray_for_Maya_renderer.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/mental_ray_for_Maya_rendering_About_the_mental_ray_for_Maya_renderer.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Rendering_Windows_and_Editors_Render_View.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Rendering_Windows_and_Editors_Render_Settings_window.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Render__Batch_Render.htm
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mental ray for Maya offers all the features traditionally expected of photorealistic 
rendering and includes functionality not found in most rendering software.  

mental ray for Maya allows interactive and batch mental ray rendering from within the 
Maya user interface. With the help of built-in shaders supporting almost any effect 
available in Maya, mental ray for Maya allows the rendering of scenes created within 
Maya or their export into the NVIDIA file format (.mi).  

(For detailed information on the mental ray standalone application, see the mental ray 
reference User Manual and the mental ray Shaders Guide, available from the Maya 
help.)  

After you load the mental ray plug-in (and select mental ray as the renderer), the 
Render menu lists available menu items for mental ray for Maya. As well, the Attribute 
Editor contains a mental ray section in which you can edit attributes that are used 
exclusively when rendering with mental ray for Maya.  

To load the mental ray for Maya plug-in, see the note in Select a renderer.  

IFF File format  

The IFF image support in mental ray permits both color and depth information written 
into a single file. This requires the proper parameters to be set in the Render Settings 
(Depth Channel [Z Depth] in the File Output section must be turned on).  

File Export  

mental ray for Maya can also be used in Maya as a file exporter. When you export a 
Maya scene file to the proprietary NVIDIA (.mi) file type, the file export simply writes a 
.mi file to disk with the given name. Additional options are available in the user interface 
to control ASCII or binary mode export and file-pre-frame creation for animations.  

Geometry Types  

Maya supports three types of geometry: polygonal (Polygon Mesh), free-form objects 
(NURBS curves/surfaces), and subdivision surfaces.  

Known differences  

The native Maya and mental ray renderers may produce different results in certain 
situations. For more details, see mental ray for Maya renders look different than Maya 
renders .  

Shading Networks and Nodes  

http://download.autodesk.com/global/docs/maya2013/en_us/files/About_rendering_and_renderers_Select_a_renderer.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/mrfm_Troubleshoot_general_mrfm_rendering_issues.htm#WS17956D7ADBC6E736-4C703DEC117AE33B1E3-7FB1
http://download.autodesk.com/global/docs/maya2013/en_us/files/mrfm_Troubleshoot_general_mrfm_rendering_issues.htm#WS17956D7ADBC6E736-4C703DEC117AE33B1E3-7FB1
http://download.autodesk.com/global/docs/maya2013/en_us/files/mrfm_Troubleshoot_general_mrfm_rendering_issues.htm#WS17956D7ADBC6E736-4C703DEC117AE33B1E3-7FB1
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A shading group in Maya defines the material, volume, and displacement shaders, 
along with the list of lights used in the illumination calculation for renderable objects. 
Such a shading group can directly be translated into a .mi material.  

For more information on mental ray for Maya shaders, see mental ray for Maya 
shaders.  

Global illumination, Caustics, Final Gather, and HDRI  

For information and procedures, see Indirect (global) vs. direct illumination.  

Global illumination  

mental ray for Maya can render with Global illumination, the technique used to capture 
indirect illumination (the natural phenomenon where light bounces off anything in its 
path until it is completely absorbed).  

Caustics  

mental ray can render with Caustics, the light effects that caused by specular reflected 
or refracted light, like the shimmering light at the bottom of a pool of water.  

Final gather  

mental ray for Maya can render with Final gather (a method of global illumination) to 
create very (or purely) diffuse scenes where the indirect illumination changes slowly.  

Support for HDR images  

mental ray for Maya supports HDR images as file textures.  

Direct light with mental ray for Maya Area Lights  

The main purpose of area light sources is to generate more realistic lighting, resulting in 
soft shadows. This is achieved by using one of four primitives (rectangles, discs, 
spheres, and cylinders) as light sources with nonzero area.  

For more information about mental ray for Maya areas lights, see Default lighting in 
Maya.  

Scene rendering  

Parallelism  

mental ray for Maya supports both host and network parallel rendering. It renders 
identical output on all common and widely-used platforms. For network rendering, it 

http://download.autodesk.com/global/docs/maya2013/en_us/files/mrfMS_basics_mental_ray_for_Maya_shaders.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/mrfMS_basics_mental_ray_for_Maya_shaders.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/mrfMS_basics_mental_ray_for_Maya_shaders.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/BoL_Indirect_global_vs_direct_illumination.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/BoL_Default_lighting_in_Maya.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/BoL_Default_lighting_in_Maya.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/BoL_Default_lighting_in_Maya.htm
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performs best in a client-server setup, where it takes care of load balancing and network 
communication reduction.  

For information on mental ray for Maya network rendering, see mental ray network 
rendering: Satellite and Standalone.  

Animations  

When rendering animation files or previewing animations inside Maya, mental ray for 
Maya exploits incremental changes. This means it determines if scene elements 
actually have changed between frames and just processes those changes, thus 
accelerating the render cycle. The check is based on Maya information and includes 
both geometry (plus instances) and shading nodes. If no changes are detected, the 
corresponding object or shader is not updated in subsequent frames and appear 
animated.  

Incremental changes are not used if animations are exported as file per frame.  

mental ray object rendering flags  

You can control how particular objects contribute to certain rendering stages by setting 
per-object rendering flags in the object‘s Attribute Editor.  

Motion Blur  

For information about mental ray for Maya motion blur, see mental ray for Maya motion 
blur.  

Customizations  

(For mental ray advanced users only.)  

The Custom Text Editor can be used to create and attach custom text to certain scene 
entities. This replaces the internally created .mi output with the custom text. Using the 
Custom Text Editor you can integrate custom mental ray shaders into Maya.  

To use the Custom Text Editor, see Custom mental ray text.  

mental ray for Maya checks and reads special custom attributes on certain Maya nodes 
and uses them for customized scene processing. Additionally, it adds its own custom 
nodes to Maya for convenient handling of mental ray extensions.  

All of these customizations are located in the Custom Entities section of the Render 
Settings window. For descriptions of the mental ray for Maya Custom Entities attributes, 
see Render Settings: mental ray tabs, Options tab.  

http://download.autodesk.com/global/docs/maya2013/en_us/files/mental_ray_for_Maya_rendering_mental_ray_network_rendering_Satellite_and_standalone.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/mental_ray_for_Maya_rendering_mental_ray_network_rendering_Satellite_and_standalone.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/mental_ray_for_Maya_rendering_mental_ray_network_rendering_Satellite_and_standalone.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/mental_ray_for_Maya_rendering_mental_ray_for_Maya_motion_blur.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/mental_ray_for_Maya_rendering_mental_ray_for_Maya_motion_blur.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/mrfMS_Custom_mental_ray_text.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Rendering_Windows_and_Editors_Render_Settings_window.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Rendering_Windows_and_Editors_Render_Settings_window.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Rendering_Windows_and_Editors_Render_Settings_window.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Rendering_Windows_and_Editors_Render_Settings_mental_ray_tab.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Rendering_Windows_and_Editors_Render_Settings_mental_ray_tab.htm#WS1A9193826455F5FF-2ADE9D9118A20D4F81-1C12
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WarningTo reduce the potential of unpredictable results, the processing of such entities 

is disabled by default for the integrated preview rendering in Maya. Turn on Custom 

Entities at your own risk.  

It is, however, enabled for the .mi file export to create customized scene files for 
external rendering.  

Custom mental ray text  

mental ray for Maya supports a method to produce custom text in the output stream 
written to the .mi file. This is for text-only integration of custom mental ray shaders 
within Maya; it allows for the creation of special-purpose Maya nodes that hold 
customized NVIDIA (mi) text.  

Custom vertex data  

mental ray for Maya checks Maya polygonal meshes for additional dynamic (custom) 
attributes that supply per vertex data. This data is exported as additional mental ray 
texture spaces for shader access.  

For more information about custom vertex data, see Custom vertex data.  

Error handling and diagnostics  

mental ray for Maya checks for errors in a Maya scene and recognizes various 
operating system errors. You can use diagnostics to help you diagnose issues with 
samples and photon maps.  

For more information on mental ray for Maya diagnostics, see mental ray for Maya error 
handling and diagnostics.  

mental ray specific image formats  

The following image formats are unique to the mental ray renderer.  

 mentalray Color (ct)  
 mentalray Alpha (st)  
 mentalray Normal (nt)  
 mentalray Motion (mt)  
 mentalray Depth (zt)  
 mentalray Tag (tt)  
 mentalray Bit (bit)  
 mentalray HDR (cth)  

 

http://download.autodesk.com/global/docs/maya2013/en_us/files/mrfMS_Custom_vertex_data.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/mental_ray_for_Maya_rendering_mental_ray_for_Maya_error_handling_and_diagnostics.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/mental_ray_for_Maya_rendering_mental_ray_for_Maya_error_handling_and_diagnostics.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/mental_ray_for_Maya_rendering_mental_ray_for_Maya_error_handling_and_diagnostics.htm
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Rendering Color and Z-depth  

The following is true when rendering to a format other than Maya IFF or RLA. If 
rendering to Maya IFF or RLA, all channels RGBAZ are written to one file. For all other 
image formats, when the Depth Channel (Z depth) option is enabled in the mental ray 
Render Settings, mental ray will write out a separate image file containing depth 
information. Z-depth is now written out in IFF format and rendered to a separate file that 
has ―Depth‖ as a suffix to the image name, for example, imageDepth.#.iff.  

Limitations  

Hyperthreading can slow down mental ray rendering  

The mental ray IPR and the Auto Render Threads option in Render > Render Current 
Frame > and Render > Batch Render > do not distinguish between dual core CPU's 
and hyperthreading. Therefore, these options report all virtual CPU's as available 
threads.  

Workaround 1: Turn hyperthreading off.  

Workaround 2 (for Auto Render Threads option): Turn off Auto Render Threads and 
reduce the number of threads by 1/2.  

Unsupported features  

mental ray for Maya does not support the following Maya rendering features:  

 Keyframing or set driven keyframing on the RGB components of a ramp shader‘s 
colorEntryList (the list of colors that comprise the ramp shader) are unsupported.  

 postprocessing effects: Paint Effects, light glow, optical effects, and 2d motion blur  
 Field Rendering  
 The -hardware_echo flag is not supported through the command line.  

Unsupported File Texture Formats  

The following file texture formats are currently unsupported by mental ray for Maya:  

 AVI files  
 Maya BOT files  
 Cineon CIN files  
 EPS files  
 GIF files  
 IFF16 files  
 Wavefront-alpha files 

 Workaround 

http://download.autodesk.com/global/docs/maya2013/en_us/files/Render__Render_Current_Frame.htm#WS73099CC142F487553B93539F117EA10CE8F5CF8
http://download.autodesk.com/global/docs/maya2013/en_us/files/Render__Render_Current_Frame.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Render__Render_Current_Frame.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Render__Render_Current_Frame.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Render__Batch_Render.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Render__Render_Current_Frame.htm#WS73099CC142F487553B93539F117EA10CE8F5CF8
http://download.autodesk.com/global/docs/maya2013/en_us/files/Render__Render_Current_Frame.htm#WS73099CC142F487553B93539F117EA10CE8F5CF8
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(TIFF,CIN,GIF) For these unsupported file formats, Maya's imgcvt image 
conversion tool can be used to convert the files to a supported format such as 
IFF or RGB. For a complete list of file texture types supported by mental ray, see 
the mental ray reference User Manual.  

(BOT) There is currently no workaround that will allow Maya BOT files to be used 
in conjunction with mental ray for Maya. mental ray does support its own 
memory-mapped map file texture format, however. Standard image files can be 
converted to this format using the imf_copy command:  

Render Layers 

Render Layer Options  

Find this section in each render layer‘s Attribute Editor. Right-click the desired layer and 
select Attributes from the right-mouse menu to display the render layer‘s Attribute 
Editor.  

Renderable  

Determines whether the select layer is renderable. When a layer is rendered, it is 
processed into a final image or image sequence.  

Global  

Converts the selected layer into a Global layer. A Global layer is a render layer that 
does not have membership. Instead it contains all the objects in the scene. By 
converting a layer into Global, all the objects in your scene automatically appears in the 
layer.  

A sample application of this attribute is if you have created a model and wanted to test 
different colors for the model. For example, if you have modeled a car, and wanted to 
test out different colors of paint, you can create five global layers, and in the Attribute 
Editor for the shader, override the color attribute for each paint color and then batch 
render all layers.  

Number  

Render layer index number. Use this attribute to merge layers when importing files with 
render layers. You can choose to merge by layer name or layer number. Set your layer 
number in this field.  

You can also merge layers when importing files with display layers. See Display Layer 
editor in the Basics guide for more information.  

http://download.autodesk.com/global/docs/maya2013/en_us/files/Basics_Windows_and_Editors_Display_Layer_editor.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Basics_Windows_and_Editors_Display_Layer_editor.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Basics_Windows_and_Editors_Display_Layer_editor.htm
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Render Concepts 

Ray tracing is a rendering algorithm that simulates how light travels through a scene: 
emitted from a light source, being reflected or refracted by geometric objects with 
certain material properties, and finally appearing at the observer‘s eye, typically on the 
film of a camera. In order to minimize computational costs and render just the visible 
parts of a scene, the algorithm works backwards: it starts at the camera and sends a ray 
in the direction of the current view. If this ray hits an object, then its material is 
evaluated, and the final color information is returned and stored. In case the material is 
reflective or refractive, further rays are sent into the scene to compute these 
contributions to the final color. This process is repeated recursively until a certain 
traversal depth is reached.  

Ray tracing can be combined with other techniques, such as the scan line or rasterizer, 
to accelerate the detection and shading of those objects that are primarily visible to the 
observer. In this case, the more expensive ray tracing algorithm will be deferred until a 
secondary effect actually needs to be computed.  

Some applications of ray tracing  

 Calculating reflections and refractions.  
 Calculating very accurate shadows by evaluating whether any objects exist 

between a point and a light source. Shadows can also be calculated by other 
methods; however, these methods, although faster, are less accurate.  

 Raytracing is capable of creating semi-transparent or translucent shadows (for 
example, shadows cast by colored glass). 

 Ray tracing is capable of supporting soft, blurry shadows from area light sources. 

While ray tracing offers all these features, it is processing intensive, so rendering with 
ray tracing typically takes longer than other methods.  

Render Outputs 

Maya can save rendered image files in several standard image file formats.  

By default, Maya saves rendered image files in the Maya Image File Format (Maya IFF). 
The Maya IFF is the most efficient format, in which no data loss occurs. All other file 
formats are translated from the Maya IFF format.  

For information about the File format syntax, see Subfolders and names of rendered 
images.  

For a list of image formats in which Maya can save rendered image files, see Supported 
image formats (rendering).  

http://download.autodesk.com/global/docs/maya2013/en_us/files/Vari_Subfolders_and_names_of_rendered_images.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Vari_Subfolders_and_names_of_rendered_images.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Vari_Subfolders_and_names_of_rendered_images.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/File_management_Supported_image_formats_rendering.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/File_management_Supported_image_formats_rendering.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/File_management_Supported_image_formats_rendering.htm
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To set the file format, see Set the rendered image file format.  

For a list of supported file formats, see Supported file formats.  

Bitmap vs. vector  

Maya can render and save an image in either bitmap or vector format. A bitmap image 
uses pixels (colored squares) arranged in a grid to describe the image. When you zoom 
into a bitmap image, you can see the jagged edges of individual pixels. Common bitmap 
formats include TIFF, GIF and BMP.  

Rendering in Passes 

The following information is included for reference. If you are using the Maya Software 

renderer, we recommend that you use render layers instead of render passes. For more 

information see Render layer overview. If you are using the mental ray renderer, we 

recommend that you use multi-render passes.  

When you render in passes, you render attributes of your scene differently. Rendering 
in passes gives you precise control over the color of objects and the shadows that fall 
on them.  

Typically you render in passes to render various attributes, such as color, shadows, 
highlights, of your scene separately. You can fine-tune a scene without re-rendering it 
by modifying different passes in a compositing program.  

Beauty pass  

This is the default pass. You can select your render pass from the Attribute Editor of 
your render layer.  

 

It produces a complete rendering of the components produced by a shadow pass and a 
color pass. Because the color pass produces a complete rendering of the components 
produced by a diffuse pass and a specular pass, a beauty pass ends up producing a 
complete rendering of all possible components.  

http://download.autodesk.com/global/docs/maya2013/en_us/files/Vari_Set_the_rendered_image_file_format.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/File_management_Supported_file_formats.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Vari_Render_layer_overview.htm


134 | P a g e  

 

 

If you need to tweak shadows independently in a compositing package or paint 
application, run the color and shadow passes separately.  

Color pass  

Produces only the color component of the image. No shadow information is produced.  

A color pass is subdivided into a diffuse and specular pass.  

Shadow pass  

Produces only the shadow component of the image. No color information is produced.  

Diffuse pass  

Only diffuse shading is performed. The diffuse pass contains the diffuse and ambient 
information and is modulated by color, transparency, and Diffuse Coeff (diffuse 
coefficient).  

 

Specular pass  

Only specular shading is performed. The specular component is modulated differently 
depending on the type of material associated with the object. Phong, PhongE, Blinn, 
and Anisotropic materials produce specular contributions differently. On a Phong 
material, the specular pass can be modulated using cosine power, and specular color.  
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Custom shadow and reflection passes  

You can also create custom shadow and reflection passes with the useBackground 
material which catches shadow and, or reflections. When the shadow pass is rendered, 
a black image is created with mask channel that contains the shadow information. A 
compositor can work with this channel to blur, lighten, darken, and so on, the look of the 
shadows. When the reflection pass is rendered, an RGB image is created with a white 
mask in the mask channel.  

RenderMan  

EMERYVILLE, CA - (October 22nd 2010) Pixar Animation Studios today announced the 
release of RenderMan Studio 3.0 and RenderMan for Maya 4.0. Both new versions offer 
substantial gains in performance, enhanced workflows, and new state-of-the-art 
technologies for rendering visual effects and animation.      

RenderMan for Maya 4.0 provides any user of Autodesk‘s Maya with fast and easy 
access to the core rendering technology developed by Pixar and used to create the 
stunning visual effects seen in the majority of today‘s feature films.  

RenderMan Studio 3.0 includes all of the above while also featuring powerful new 
shading and lighting tools. RenderMan Studios 3.0 includes the latest version of Pixar‘s 
shader authoring toolset Slim 9.0, providing excellent integration with RenderMan for 
Maya, a new production-quality shader library, co-shader support, Ptex support, and 
more. Also included is a new relighting tool built on RenderMan‘s re-rendering API. In 
addition, RenderMan Studio includes Tractor 1.0, Pixar‘s new distributed render 
management solution, featuring an innovative architecture designed with the flexibility 
and power to manage small or large, multi-core render farms.  

MAYA to RenderMan 

RenderMan® for Maya delivers all of RenderMan's legendary performance and quality 
to provide your creations with that distinctive visual edge. Combined with an intuitive 
workflow, RenderMan for Maya sets a new standard for rendering high-quality visual 
effects and animation. RenderMan for Maya is a plug-in that offers a lot of performance. 
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Easy Integration 

RenderMan for Maya brings RenderMan's speed, power, and stability directly to Maya 
users, without the added cost and complexities of our premium, high-end products, 
RenderMan Pro Server and RenderMan Studio. If you've been looking for an affordable, 
easy way to get RenderMan, your wait is over. 

Ease of Use 

1. Clean integration with Maya 
2. Software rendering of all Maya Particles 
3. Automatically render Maya Fur and Hair 
4. Render Maya Material networks, PaintFX, and much more! 

 

Quality 

1. World renowned cinematic-quality imagery 
2. High quality anti-aliasing for minimal artifacts  

Power  

1. Multithreading 
2. RenderMan's famous motion blur 
3. High quality displacements 
4. Fast and efficient fur and hair 
5. Robust secondary outputs for easy compositing 
6. Render enormous amounts of geometry  

Features 

1. "Deep Shadow" technology 
2. Advanced subsurface scattering  
3. Point based ambient occlusion and global illumination 
4. Fast HDRI and image based lighting effects 
5. Texture baking 
6. Camera effects, including bokeh and shutter timing 
7. Photon based caustics 

http://renderman.pixar.com/products/whats_renderman/4.html
http://renderman.pixar.com/products/whats_renderman/3.html
http://renderman.pixar.com/products/whats_renderman/5.html
http://renderman.pixar.com/products/whats_renderman/4.html
http://renderman.pixar.com/products/whats_renderman/2.html
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8. Render time CSG boolean operations 
9. Production statistics 
10. And more . . . 

                   

Get Started Right Away 

RenderMan for Maya takes all your Maya scene data — Maya Materials, lights, 
geometry, Maya Fur, particles, Maya Hair, et cetera — and renders them with Pixar's 
RenderMan. Simply select ―RenderMan‖ from the 'Render using' menu and your image 
will appear in the Maya 'Render View' window. Get the same production-quality motion 
blur and displacements, ambient occlusion, 3D caching and baking, not to mention the 
legendary power, speed, and stability of Pixar's RenderMan, right there in the Maya UI.  

 

 

 

Special RenderMan Features 

Maya users can enjoy the same global illumination and subsurface scattering effects, 
deep shadows, and super-efficient subdivision schemes available in RenderMan Pro 
Server. Ray-tracing effects, such as global illumination, and other effects, like motion 
blur, are set up via the Render Globals. Other RenderMan features, like Deep Shadows 
or subsurface scattering, are attached directly to Maya nodes. 

RenderMan for Maya was designed with ease-of-use and affordability in mind, without 
sacrificing the most important features of RenderMan: speed, stability, and quality. 
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Those who require the versatility of RIB in and out, the robust, highly programmable 
shading tools in Slim, or the dynamic capabilities of plug-in procedurals are encouraged 
to use our premium, high-end products: RenderMan Studio and RenderMan Pro Server. 
If, however, you're looking for the speed and quality of Pixar's RenderMan, fully 
integrated with Maya, check out RenderMan for Maya. 

Rigging 

Before animating the characters and objects in your scene, you set up your scene by 
rigging all your characters and by applying the appropriate constraints and deformers to 
all the objects you want to animate.  

Rigging a character, also known as character setup, involves creating skeletons and IK 
handles for your characters, binding skins to the skeletons, and setting up deformers 
and constraints. You can also create deformers for your character and animate them to 
produce effects; for example, the jiggling belly (jiggle deformer), furrowing brow (wire 
deformer), and flexing biceps (lattice deformer) of a sumo wrestler model.  

Non-character objects are also very important to bringing your scene to life. You can 
limit and control the transformations of objects by constraining them to characters or 
other models in your scene. You can also create deformers for objects to create 
complex deformation effects. For example, you can apply a squash deformer to the 
model of a ball and then parent constrain the ball to the hands of a character. With this 
setup, you can key the weights of the character‘s hands and the squash deformer‘s 
attributes to create an animation of the character bouncing the ball from hand to hand 
while the ball squashes on the ground and stretches as it rises back into the air.  

Creating Character Sets After Setting 

Using skeletons 

Skeletons are the underlying joint and bone hierarchies that let you animate your 

characters. Every skeleton has several parent joints and child joints, and one root joint. 

Parent joints are joints that have joints below them in the skeleton‘s hierarchy. For 

example, an elbow is the parent of the wrist and the child of the shoulder. The root joint 

is the first or top joint in a skeleton‘s hierarchy. For more information on setting up 

skeletons, see What are skeletons?.  

You can use the following methods to animate a skeleton: forward kinematics (FK), 
inverse kinematics (IK), or IK/FK blending.  

Forward Kinematics (FK)  

http://download.autodesk.com/global/docs/maya2013/en_us/files/CSS_What_are_skeletons.htm
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With forward kinematics, you transform and key joints directly, rather than using an IK 
handle to animate a skeleton.  

Forward kinematics are useful for creating detailed arcing movements, but not very 
intuitive for goal-directed movements. For example, you can easily use FK to animate 
the rotation of an arm at the shoulder joint, but not the arm reaching for a glass. For 
more information on FK, see Forward kinematics (FK).  

Inverse Kinematics (IK)  

With inverse kinematics, you transform and key an IK handle to animate a skeleton. The 
IK handle is drawn as a straight line between the start and end joints of its IK chain. The 
effect the IK handle has on the joint chain depends on the type of IK solver used by the 
IK handle. See IK solvers.  

Inverse kinematics are useful for goal-directed movements. For example, you can use 
IK to animate an arm reaching for a glass of water, but not for specific movements at 
individual joints. For more information on IK, see Inverse kinematics (IK).  

Blending IK and FK  

Instead of using only FK or IK to pose and animate a joint chain, you can use both FK 
and IK on the same joint chain. The Ik Blend attribute on the ikHandle lets you apply FK 
and IK animation to the same joints. Ik Blend specifies the amount of influence (weight) 
that FK or IK have over the animation of the joints.  

Blending IK and FK is useful for posing complex characters that have a wide range of 
movements in their animations. For example, you can use IK to animate the directed 
motion of a character‘s arms, and you can use FK to animate the rotation of the 
shoulder, elbow, and wrist joints in the arm. For more information, see IK/FK blending.  

Skinning your character 

Skinning is the process of binding a modeled surface to a skeleton. You can bind any 

model to its skeleton using skinning, or you can model over a pre-existing skeleton to 

create its skin. When a model is bound to a skeleton using skinning, it then follows or 

reacts to the transformations of the skeleton‘s joints and bones. For example, if you bind 

a model‘s arm to its underlying skeleton using skinning, rotating the elbow joints causes 

the skin at the elbow to crease and pucker.  

There are three types of skinning in Autodesk® Maya®: smooth skinning, rigid skinning, 
and indirect skinning.  

 

http://download.autodesk.com/global/docs/maya2013/en_us/files/CSS_Posing_skeletons.htm#WS17956D7ADBC6E736-185AC66B117AE30DA36-7FEE
http://download.autodesk.com/global/docs/maya2013/en_us/files/CSS_IK_solvers.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/CSS_Posing_skeletons.htm#WS17956D7ADBC6E736-185AC66B117AE30DA36-7FED
http://download.autodesk.com/global/docs/maya2013/en_us/files/CSS_IK_FK_blending.htm
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Smooth Skinning  

With smooth skinning, you can create smooth, articulated deformation effects. Smooth 
skinning specifies that multiple joints and other influence objects can have varying 
influences on the same points (CVs, vertices, or lattice points) on a model. For more 
information on smooth skinning, see Smooth skinning.  

Rigid Skinning  

With rigid skinning, you can create stiff, articulated deformation effects. Rigid skinning 
specifies that only individual joints can influence each CV, vertex, or lattice point on a 
model. For more information on rigid skinning, see Rigid Skinning.  

Indirect skinning  

With indirect skinning, you can bind lattice or wrap deformers as skins to a skeleton. 
When a character is indirectly skinned, posing its skeleton causes the bound deformers 
to transform the model‘s skin. For more information on indirect skinning, see What are 
lattice deformers? and What are wrap deformers? in the Deformers guide.  

Creating Deformation Effects 

You can add deformation effects to your characters and objects to enhance their 
animations. Deformers are tools that let you transform or animate objects in ways that 
simple manipulation and keyframes cannot. Deformers have two main applications: to 
model surfaces or to add extra shape animations to an object.  

Deformers as modeling tools  

You can use deformers as modeling tools. You can create a deformer, for example a 
sculpt deformer tool, tweak the model‘s shape with it, and then delete the history from 
your object when the deformer is no longer needed. When you delete the object‘s 
history, you delete the deformer and retain the object‘s deformed shape.  

Deformers as animation tools  

You can use deformers as animation tools. You can create a deformer, tweak the target 
object with the deformer, and then key the deformer‘s attributes over time to produce an 
animation. For example, you can create a blend shape deformer for a model of a face. 
Then over time, you can manipulate and key the sliders for the deformer in the Blend 
Shape editor to create an animation.  

 

 

http://download.autodesk.com/global/docs/maya2013/en_us/files/Skinning_Level_Smooth_skinning.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Skinning_Rigid_Skinning.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Lattice_deformer_What_are_lattice_deformers_.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Lattice_deformer_What_are_lattice_deformers_.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Lattice_deformer_What_are_lattice_deformers_.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Wrap_deformer_What_are_wrap_deformers_.htm
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Animation Curves 

Extra options  

Use scene name  

Normally, the Maya FBX plug-in saves Maya scene animation in the FBX file as Take 
001. If you want the scene animation to instead be named for the Maya scene, activate 
this option.  

This option is deactivated by default, so the take is automatically named Take 001, and 
so on.  

Remove single key  

When you activate this setting, the exporter removes keys from objects on export if the 
plug-in determines that the animation has only one key. When two or more keys exist in 
the file, the keys are exported.  

If you disable this option, the plug-in does not remove keys from the animation on 
export.  

Quaternion interpolation mode  

Use the Quaternion interpolation mode menu to select how to export your quaternion 
interpolations from the host application. Select from the following three options:  

Resample as Euler interpolation  

This is the default conversion setting for quaternion interpolations.  

This option converts and resamples quaternion interpolations into Euler curves to 
ensure interoperability.  

Retain quaternion interpolation  

This option retains quaternion interpolation types during the export process.  

You can specify custom colors for the animation curves that appear in the Graph Editor.  

Change individual animation curve colors from the Graph Editor 

To change the color of individual animation curves  

1. In the Graph Editor, select the curves whose color you want to change.  
2. Select Edit > Change Curve Color > .  
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The Change Curve Color Options window appears. (See Change Curve Color > 
in the Edit menu.)  

3. Set a new color for the animation curves you selected and do one of the following:  
o Click Color to apply the current color and close the Change Curve Color Options 

window.  
o Click Apply to apply the current color to the curves and keep the Change Curve 

Color Options window open for further editing.  

The colors of the selected curves change to the color you specified in the 
Change Curve Color Options window.  

Associate curve colors with attribute names  

To associate an attribute name with a curve color  

1. Select an object that has animation curves for the attribute(s) you want to assign with a 
curve color.  

2. In the Graph Editor (Window > Animation Editor > Graph Editor), select the attributes 
you want to associate with a color.  

3. From the Graph Editor menu bar, select Edit > Set Curve Colors.  

The Curve Colors window appears with the attributes you selected listed in the 
left panel.  

4. Do the following for each attribute you want to assign with its own color:  
o Select the attribute in the Curve Colors window.  
o Click the color swatch to open the Color History settings.  
o Choose the color you want in the Curve Colors window.  

The animation curves controlling this attribute are now set to the color you have 
assigned.  

To reset the curve color  

1. Select the attribute in the Graph Editor‘s Outliner, then select Edit > Set Curve Colors.  
2. Select the attribute name in the Curve Colors window that appears.  
3. Click Remove.  

The animation curve is reset to its default color.  

Change animation curve colors through the Attribute Editor or with MEL  

With the UseCurve Color and Curve Color attributes you can set the colors for individual 
curves or use more global operations such as coloring a curve based on which 
characters they drive to color groups of curves at a time. This type of global operation 
can be achieved through MEL scripts. For a sample MEL script, see Example MEL 
procedure for customizing the color of multiple animation curves.  

http://download.autodesk.com/global/docs/maya2013/en_us/files/GUID-6B2EBCB3-766F-48D1-A079-7B5672AF54D1.htm
http://download.autodesk.com/global/docs/maya2013/en_us/files/Keyframe_Animation_Change_animation_curve_colors.htm#WS17956D7ADBC6E73647E34F8F117AE307467-7FB4
http://download.autodesk.com/global/docs/maya2013/en_us/files/Keyframe_Animation_Change_animation_curve_colors.htm#WS17956D7ADBC6E73647E34F8F117AE307467-7FB4
http://download.autodesk.com/global/docs/maya2013/en_us/files/Keyframe_Animation_Change_animation_curve_colors.htm#WS17956D7ADBC6E73647E34F8F117AE307467-7FB4
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1. Turn the Use Curve Color attribute on or off.  

Use Curve Color is located in the Anim Curve Attributes section of each 
animation curve node (for example, animCurven). See the following procedure.  

To set custom animation curve colors  

1. Select the animated object.  
2. Open the Graph Editor.  
3. In the graph view, select the animation curve.  
4. Select Curves > Spreadsheet.  

The Attribute Editor opens.  

5. In the Anim Curve Attributes section of the animCurven tab, turn on Use Curve 
Color.  

6. Click the color swatch to launch the Color History settings.  
7. In the Color History settings, select a custom color for the curve.  

The color you selected appears in the Curve Color swatch. In the Graph Editor‘s Curve 
View, the animation curve is now the color of the Curve Color swatch.  

Rigging - Inverse Foot Setup 

In this Maya Reverse Foot Tutorial you will find the step by step instructions to create 
a complete reverse foot system. Maya Reverse Foot is uses to create complete and 
artist friendly rig setup for realistic leg animation. Though this reverse foot system 
contains a little complexity, but it will be easier with repeated practice. 

To follow this Maya Reverse Foot Tutorial you should have a human model in your 
hand. You also need a complete bone structure to animate it. The following is the image 
of the model and the skeleton structure from the side view. 
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Now, you have to create an IK handle which should be a Rotate Plane IK for the knee. 
So, use the menu Skeleton > IK Handle Tool. By default the IK Handle Tool containing 
the Rotate Plane IK system. So, connect from the hip joint to hill joint with a Rotate 
Plane IK. Now, select and move the IK handle in any direction to see the resulting effect 
of the IK system. 

In this way select the single chain IK solver (ikSCsolver) from the IK Handle Tool 
settings window. And implement the IK system (ikSCsolver) from hill joint to ball joint 
and finally ball joint to toe joint. 

 

Create new bone-joints for the Reverse Foot system 

Now, we have to create the bone structure for the reverse foot lock system. So, select 

the joint tool using the menu Skeleton > Joint Tool from the Animation menu set. Now, 

go to the side view and create few joints underneath the left foot joint as the following 

image. The newly created joints should be named as L_RF_Base, L_RF_Toe, 

L_RF_Ball and L_RF_Hill respectively. But by default the names are as joint2, joint3, 

joint4 and joint5. So, we have to rename them. How? Open the Outliner window and 
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double click on every joint and write down the names maintaining the above mentioned 

naming convention. 

 

Align new bone-joints (Reverse Foot bone joints) with the existing left foot joints 
Now, we have to align the newly created bone-joints perfectly with the existing left foot 
joints. You can create it easily. How? Just hold down the ‗v‘ key on your keyboard and 
drag a little to align the base joint (RF) with the main left foot Ankle joint. Then drag the 
left foot base joint (RF) a little down in Y-axis to align with the lowest level of previous 
bone-joint. Because it is the base joint and should be placed under all joints of the left 
foot. Now, align other newly created joints or Reverse Foot joints like L_RF_ Toe, 
L_RF_Ball and L_RF_Hill with the respective main joints. Alternatively you can say that 
L_RF_Toe should be aligned perfectly with the main L_Toe and so on. Now, open the 
‗Outliner‘ window and select all Reverse Foot joints at a time either by expanding the 
joint structure and dragging on them or select one by one by pressing the Shift key. 
Then change the Radius value to 0.7 in the Channel Box. 

 

Create control curves to support Reverse Foot 
Now, you have to create few control curves to control the Reverse Foot system. You 
can create these curves using the NURBS menu Create > NURBS Primitives > Circle. 
So, at first create a curve by dragging on the perspective view after selecting the above 
mentioned menu.  Position it just under the left foot of the model. Scale the NURBS 
curve or circle so that you can select it easily. Then you have to change the pivot point 
of the curve because the pivot point should be aligned perfectly with the main left hill 
joint. You can align the pivot point of the curve easily. Select the curve using the move 
tool. Then hold down two keys at a time. In this case the first key should be the ‗d‘ and 
the second key is the ‗v‘. Now move the cursor pressing the left mouse button towards 
the left hill joint. The pivot point will be snap aligned with the left hill joint. But, here you 
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have to be careful about the alignment. This control curve should be named ‗Left Foot 
Control‘. 

 

Now, you have to create another two control curves like the ‗Left Toe Control‘ and ‗Left 
Ball Control‘. So, create two curves as the following image and align the pivot of those 
curves one with the Ball and another with the Toe after positioning them perfectly. Then 
open the ‗Outliner‘ window and rename these curves maintaining the protocol. Select all 
the curves and press Ctrl+g to create a group. Rename the group as ‗L_FootControls‘. 
Create a new layer in the Layer Editor window and name it ‗left_foot_controls‘ and 
change the layer color to yellow. Now, add the controls group in the layer. 

 

Here, we can find that all the control curves containing the transformation, rotation and 
scale values. But, we need all control curves with basic values like (0, 0, 0, 0, 0, 0, 1, 1, 
1) from transformation to scale respectively. So, expand the controls group and select 
all curves. Then select the menu Modify > Freeze Transformations. And then delete 
construction history using the menu Edit > Delete All by Type > History. Now, select and 
move the L_FootControls group under the ‗body_rig_gr‘. 

Constraining the curves with the reverse foot system 

 
This part of this Maya Reverse Foot tutorial is very important. Actually, this is the 
complete rigging procedure for the left foot. Here we have to do few constraining task. 
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At first you have to constrain the L_RF_Base with the L_Foot_Control using the parent 
constrain method. To do this, select the L_Foot_Control at first and then the 
L_RF_Base holding the Shift key. Now click on the small-box beside the menu 
Constrain > Parent.  A Parent Constraint window will appear. In this window, click on the 
menu Edit > Reset Settings to get the default settings. Then click apply and close 
button. Now, if you select and rotate the L_Foot_Control then the whole Reverse Foot 
system will rotate with the Parent. 

 

Now, we have to constrain the main joint chain with the Reverse Foot joint chain. After 
the joining procedure, the left foot control (L_Foot_Control) drives the Reverse Foot joint 
chain, the Reverse Foot joint chain drives the IK system of the main joint-chain, the IK 
implemented joint chain drives the main bone structure which will drive the body part. 
Let‘s start the constraining procedure. 

Now, at first we have to create a point constraint between the L_RF_Hill and the 
l_leg_ik_handle. In this case the parent should be the reverse-foot-hill joint which will 
control the movement of the left IK. To do this point constraint, at first select the 
L_RF_Hill joint and then the L_leg_ik_handle. Now click on the small-box-icon beside 
the menu Constrain > Point. The Point Constraint Options window appears. In this 
window confirm the ‗Maintain Offset‘ option and the ‗Constraint Axes‘ option is in turned 
on condition. Then click on the Apply button and finally close this window. Now, if you 
move the ‗L_Foot_Control‘ then you will find the left leg IK will move with it. 

 

But for the reverse-ball joint a Point constraint isn‘t really needed. Because if you create a Point 
constraint between the reverse-foot-ball joint (L_RF_Ball) and the left-leg-ik-ball-joint 
(L_leg_ik_handle_ball) then after constraining them you can‘t get the proper rotation effect from 
the reverse ball joint. So, a Parent constraint is good for this reverse ball constraining. So, at 
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first select the L_RF_Ball joint and then the L_Leg_ik_handle_ball. Then click on the small box 
icon beside the menu Constrain > Parent. The Parent Constraint Options window appears. Here 
confirm the Maintain Offset, Translate All and Rotate All options are in checked on condition. 
Now, click on Apply and close the window. If you now select the left-reverse-ball joint 
(L_RF_Ball) and rotate it then you will get proper rotation effect from this. 

 

Finally we have to create a constraint between the left-reverse-foot-toe (L_RF_Toe) joint and 
the left-leg-ik-handle-toe (L_leg_ik_handle_toe). Here this constraint should be an Orient 
Constraint. So, click on the small box icon beside the menu Constrain > Orient. Here confirm 
the Maintain Offset and Constraint Axes All both in checked on condition. Now, if you select the 
reverse-foot-toe joint and rotate it then you will find a natural animation as per your requirement. 

 

The reverse foot system is now working to support a true foot and leg animation. But, I 
need to select and manipulate the reverse foot system quickly and easily. But, how can 
we do this? We have already few control curves to support the reverse foot system. Just 
constrain these control curves with the reverse foot system. Then they will be useful to 
control the reverse foot system to animate the leg normally. 

So, select the left-ball-control curve (L_Ball_Control) and then the left-reverse-foot-ball 
joint (L_RF_Ball). Now, create an Orient Constraint between them after confirming the 
Maintain Offset and Constraint Axes All checked on. Now, if you select the left-leg-ball-
control and rotate it then you will find a nice rotation effect. 
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Now, you have to do the same constrain between the left-foot-toe-control curve 
(L_Toe_Control) and the reverse-foot-toe joint (L_RF_Toe). Then apply the same Orient 
constraint onto them after confirming the Maintain-Offset and Constraint-Axes-All 
checked on. Now, if you select the left-foot-toe-control curve and rotate it then you also 
be able to get the real rotation effect. But, if you select the left-foot-toe-control curve and 
move it then you will not be able to get any movement from the reverse foot joint. But, I 
think it is required for complete rig setup for the toe. So, select the left-leg-toe-control 
curve (L_Toe_Control) and the ik-handle for toe (L_leg_ik_handle_toe). Then create a 
Point Constraint between them. Now, you will be able to get the movement effect from 
the left-toe-control curve. 

 

Still we have some task to do. Our aim is to create real reverse foot lock system. So, we 
need some grouping task. But, in this case the grouping should be done on a single 
object. Because we need two pivot point of a same control curve for different purposes. 
We have to create this so that the control can have a pivot point and the group can have 
a pivot point. Here, both the toe and the ball control curve needs the grouping. 

 

Do the same grouping procedure for the ball control curve. But, here the pivot point 
should be in place of toe-joint. 

 

So, at first select the toe control curve and press Ctrl+g to create a group and name the 
group as ‗L_Toe_Control_Group‘. Now, position the pivot point of this group just in the 
place of the hill joint. To do this, select the group and press Insert button. Now, press 
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and hold the ‗v‘ key on the keyboard and move the pivot point. After completion press 
Insert button once more. 

Now, we have to do another constraint and that is between the left-toe-control 
(L_Toe_Control) and the ball-control-group (L_Ball_Control_Group). So, select the 
L_Toe_Control first and then the L_Ball_Control_Group. Now, create an Orient 
Constraint with ‗Maintain Offset‘ option checked on. 

 

But, still the rig setup with the reverse foot is not completed. Why? Because, the ball-
control-curve is not moving with the left-foot-control. So, we have to create another 
Point constraint between the L_RF_Ball joint and the L_Ball_Control. So, select the 
L_RF_Ball first and then the L_Ball_Control and implement a Point constraint between 
them. You have already done this. 
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UNIT IV 

Modeling In Maya 

These settings determine how far the selection continues based on the angles between 
edges. The 2d angle refers to angle made by the surface topology, regardless of the 
surface's shape. The 3d angle refers to angles made by the surface's shape, as 
measured in world or local space.    

Modeling a polygonal mesh 

 

In this lesson, you model a helmet for an interactive game character, using polygonal 

surface modeling techniques.  

In this lesson you‘ll be introduced to some of the polygon modeling tools Maya 

provides by learning how to:  

 Use 2D image planes as a reference for constructing 3D models  

 Use 3D primitives as the basis for creating more complex models  

 Work with the components of a polygon mesh (faces, edges, and vertices)  

 Smooth a polygon mesh  

 Select the faces, edges, and vertices of polygonal meshes  

 Create polygon faces by placing vertices  

 Scale and extrude faces on a polygon mesh  

 Move and rotate extruded polygonal meshes  

 Split vertices and subdivide polygonal faces  

 Combine separate meshes into one mesh  
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 Bridge between meshes  

 Add faces to an existing mesh  

 Use Snap to Grid  

 Preview a smoothed high resolution version of a polygon mesh  

 Harden and soften polygon edges  

 

Setting modeling preferences 

Before you create your polygon model change some of the default settings to better 

work through this lesson.  

1. Select Window > Settings/Preferences > Preferences.  

The Maya user preferences window appears.  

In the Categories section of the Preferences window select Polygons.  

2. In the Polygon Display settings, set the following:  

 Border Edges: On  

 Edge Width: 4  

This displays border edges prominently on polygon meshes. Displaying 

border edges distinctively lets you differentiate them from other edges on your 

models and troubleshoot issues.  

3. In the Categories section of the Preferences window, choose Selection.  

4. In the Polygon Selection settings, set the following:  

Select faces with: Whole face  

The Whole face setting lets you select polygon faces by clicking anywhere on 

the face (the Center setting requires you to click on the face‘s center dot). In 

addition, when a face is selected in the scene, the entire face appears 

highlighted.  

5. Click the Save button to close the settings window.  

6. Turn off the Interactive Creation option for primitives: Select Create > Polygon 
Primitives > Interactive Creation (no check mark).  

 

Using 2D reference images 

file:///C:\Program%20Files\Autodesk\Maya2009\docs\Maya2009\en_US\files\Window__SettingsPreferences__Preferences.htm
file:///C:\Program%20Files\Autodesk\Maya2009\docs\Maya2009\en_US\files\Create__Polygon_Primitives.htm%23WS73099cc142f487553b93539f117ea10ce8f3f1e
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 You can use front, side, and top views from drawings, sketches, or photographs to help 
visualize your 3D model in Maya, much like an architect or engineer creates their 
designs from the plan and elevation views of a blueprint.  

You can import 2D images into your orthographic camera views as image planes. An 

image plane is a 2D object (plane) that places an image file in the scene view. By 

default, an image plane only appears in the camera to which the image plane is 

connected. Image planes are also used to create backgrounds and environments 

when rendering.  

When you load an image into an image plane, it appears in your selected 

orthographic view at the origin along an axis that is perpendicular to the selected 

orthographic view. You can refer to the image in the orthographic view to define the 

silhouette and character lines of your model. You can move the image plane, change 

its transparency, or turn it off.  

For this lesson you load two images we‘ve provided for the lesson into image planes 

in the front and side orthographic views of your scene. You‘ll refer to them frequently 

while you model the helmet.  

 

To load reference images into the front and side orthographic views  

1. In the Toolbox, click the Four View shortcut from the Layout Shortcuts bar.  

The perspective view is located in the top right corner and the other views 

show your scene from the top, front, and side.  

2. In the front view panel menu, select View > Image Plane > Import Image.  

3. Select the image file named HelmetFront.jpg.  

This image can be found in the GettingStarted directory that you set as your 

Maya project:  

GettingStarted/PolygonModeling/sourceimages 

4. In the browser, click the Open button.  
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HelmetFront.jpg appears in the front view and depicts a drawing of the 

helmet.  

5. In the side view panel menu, select View > Image Plane > Import Image.  

6. Select the image file named HelmetSide.jpg.  

This image can be found in the Getting Started project directory:  

Getting Started/Polygon Modeling /source images 

7. In the browser, click the Open button.  

HelmetSide.jpg appears in the side view.  

NoteThe front and side images for this lesson were created so that the two 

views are aligned and the height of each image is identical. When you import 

them as image planes, they appear at the same scale. These are important 

considerations when you construct your own reference images in the future. 

Otherwise, your reference images may not align or may be at different scales 

between the two orthographic views.  

By referring to the image planes in the orthographic views as you work, you 

can correlate how a feature in one view, appears in another. While a top view 

reference image is useful in many cases, it isn‘t critical for this lesson.  

The image planes can be set so they appear partially transparent to allow you 

to work with the polygonal components more easily. To do this you‘ll select 

the front and side orthographic cameras and modify the transparency of the 

images.  

To modify the transparency of the reference images  

1. In the front view panel menu, select View > Select Camera.  

The camera for the front orthographic view is selected.  

2. Display the Channel Box by clicking the Show/Hide Channel Box icon on the 
Status Line.  

The Channel Box displays the keyable attributes for the Front orthographic 

camera.  

3. In the Inputs section, click the ImagePlane1 name to display the attributes for 
the image plane.  

4. Set the Alpha Gain attribute to a value of 0.25.  

The image appears partially transparent.  
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5. In the side view panel menu, select the camera and change the Alpha Gain 
setting for the side view image plane exactly as you changed the front view 
image plane.  

 

TipYou can change the Alpha Gain at any time if you want the image planes 

to appear more or less transparent.  

6. In the perspective view‘s panel menu, select Show > Cameras to temporarily 
turn off the display of the image planes in the perspective view.  

 

Creating a polygon primitive 

You‘ll create the top portion of the helmet mesh from a cube primitive using the image 
planes as a reference. Primitive objects are one method for starting 3D meshes 
because they can be modified to create other forms.  

To create a cube primitive for the helmet mesh  

1. Ensure you are working in the perspective view.  

2. Select Create > Polygon Primitives > Cube > .  

3. In the options window, select Edit > Reset Settings, and then set the following:  

 Width: 14  

 Height: 14  

 Depth: 14  

 Width divisions: 1  

 Height divisions: 2  

 Depth divisions: 1  

4. Click the Create button.  

A cube primitive is created at the origin with the dimensions you specified and 

one subdivision around the middle. This cube primitive is comprised of four-

sided polygon faces called quads. Quad polygons are used frequently with 3D 
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character models as they are easily smoothed and deform well when bound 

into a skeleton.  

 

You can smooth the cube so it appears more rounded on the corners and 

subdivide it into smaller faces using the Smooth feature.  

To smooth and subdivide the cube primitive  

1. With the cube still selected in the scene view, select Mesh > Smooth > , and 
set the following options in the window that appears:  

 Add divisions: Exponentially  

 Division levels: 2  

2. Click the Smooth button  

The cube primitive is smoothed and is rounded at its corners. The cube has 

also been subdivided into smaller faces.  

 

The polygon faces are still four-sided even though their shape and position 

have been modified by the smooth operation.  

NoteIf the top, domed portion of the smoothed cube doesn‘t roughly match 

the helmet sketches as indicated in the image below, scale the cube with the 

Scale Tool to make it match.  
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To rename the polygon mesh  

1. With the cube still selected, rename the cube primitive using the Channel Box 
from pCube1 to helmet mesh 

 

Modeling in Shaded Mode 

Modeling a polygon mesh in shaded mode gives you a better sense of the 3D volume 
that the model occupies as well as how any surface details appear.  

You can control the shading of an object separately in each view. For example, you 

can display the object as shaded in the perspective view only, and set the 

orthographic views to display objects in wireframe mode. You can also set the display 

settings to show both a shaded and wireframe display simultaneously.  

To display the helmet mesh in Wireframe on Shaded mode  

1. In the perspective view, right-click on the helmet mesh and select Object Mode 
from the marking menu that appears.  

This changes the selection mode to Objects.  

2. Select the helmet mesh.  

3. In the perspective view, select Shading > Smooth Shade All from the panel 
menu.  

The helmet mesh displays in smooth shaded mode.  

4. From the panel menu, select Shading > Wireframe on Shaded.  

The wireframe appears on the mesh as well as the shading (whether or not 

the mesh is selected).  

 

The opacity of the smooth shading in the side and front views prevents you from 

seeing the image planes behind the object. X-Ray display mode solves this problem 

by making the smooth shaded surface appear semitransparent.  

To display the helmet mesh in shaded X-Ray mode  

1. With the helmet still selected, choose the following from the side view‘s panel 
menu:  
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 Shading > Smooth Shade All  

 Shading > Wireframe on Shaded  

 Shading > X-Ray.  

The helmet mesh updates to a semitransparent shaded display with the 

wireframe. You can see the 2D image behind the mesh.  

2. Repeat the previous step for the front view as well.  

 

After setting the shading for the objects in the various views, you may wish to 

adjust the Alpha Gain setting on your image planes to change their 

transparency. As you gain experience with Maya, you‘ll develop your own 

personal preferences for modeling in wireframe or shaded mode and 

switching between the various shading modes.  

Model symmetry 

 Whenever you model an object, you should take advantage of any symmetry that the 
form provides. It can save you time and effort if you work on only one half of the model 
and then later copy it across the model‘s axis of symmetry. The sketch of the helmet is 
symmetrical along its center line (YZ plane).  

To delete the faces on the left half of the mesh  

1. In the top view, right-click on the mesh and select Face from the marking menu 
that appears.  

2. Drag a bounding box around the faces on the left half of the helmet mesh to 
select them.  

3. Press the delete key.  

The selected faces are deleted.  

 



159 | P a g e  

 

You now have half as many components in your model. When you near the 

completion point of the model, you will copy the finished half across the axis of 

symmetry to get the complete model.  

Selecting components by painting 

You can delete some of the faces that are not needed on the front and lower section of 
the helmet mesh using the Paint Selection Tool. This is useful when you need to select 
components that are in an irregular region and are not easily selected using the 
bounding box.  

To select faces for deletion using the Paint Selection Tool 

1. In the Toolbox, click the Paint Selection Tool icon.  

 

2. In the side view, right-click the helmet mesh and select Face from the marking 
menu that appears.  

3. In the side view, paint select the faces that appear along the front and lower 
areas of the mesh (see image) by dragging the mouse over the faces.  

NoteThe Paint Selection Tool only selects components on the mesh that face 

towards the camera.  

 

4. Press the delete key to delete the selected faces.  

5. Tumble the perspective view to review your work so far.  

The edges that reside along the outside perimeter of a polygon mesh, called 

border edges, are displayed with a thicker line than the interior edges on the 
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mesh. You set this display setting early in the lesson so you could 

differentiate this edge type from other edges.  

Selecting Edge Loops 

In the top view, the rows of edges immediately above and below the X axis, and the row 
to the right of the Z axis are not straight. You‘ll want to align the edges in these rows 
(referred to as edge loops) by snapping them to the grid using the Move Tool. An edge 
loop is a path of polygon edges that are connected in sequence by their shared vertices. 
Edge loop selections are very useful when you model using polygons.  

 

To align edges on the helmet mesh  

1. Right-click the mesh and select Edge from the marking menu that appears.  

Maya‘s component selection mode is set to edges.  

2. Double-click one edge in the edge-loop directly below the X axis.  

The edge loop is selected.  

3. On the Status Line, turn on the Snap to Grids feature by clicking the icon.  

 

Snap to Grids lets you move selected components to the closest grid line or 

grid intersection point. When many components are selected, you can align 

them to each other via the grid simultaneously.  

4. In the Toolbox, double-click the Move Tool to display its tool settings.  

5. In the Move Snap Settings, turn off the Retain component spacing setting.  
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6. In the top view, click-drag the blue arrow on the Move Tool manipulator 
downwards a small distance.  

The edge loop immediately snaps to a lower grid line. It is not positioned at 

the location you want, but all of the edges in the loop you selected are now 

aligned to each other.  

7. On the Status Line, turn off the Snap to Grids feature by clicking its icon.  

8. With the Move Tool still active in the top view, drag the manipulator arrow 
upwards a short distance so the edge loop is positioned roughly at its original 
location (which should be at the second grid line below the X axis).  

9. Using the steps described above, align the other edge loop that appears above 
the X axis and then align the edge loop directly to the right of the Z axis. 
(Remember to turn on and off Snap to Grids as required.)  

When you have finished, the edge loops nearest the X and Z axes are 

aligned. (see image below)  

 

Editing components in the orthographic views 

Component selection and transformation is one fundamental method for editing the 

shape of a polygon mesh. As you model, you‘ll find yourself frequently examining and 

then refining the position of the polygon components (vertices, edges, and faces) 

while working in the various scene views so they match the reference images on the 

image planes.  

To manually reposition the vertices on the rear of the helmet  

1. Right-click the helmet and select Vertex from the marking menu that appears.  

2. In the side view, select the pair of vertices at the rear lower edge (see image) 
by dragging a bounding box around them.  

3. In the Toolbox, click the Move Tool.  

4. In the side view, click-drag the blue arrow on the Move Tool manipulator 
towards the right until the vertices are repositioned so that your helmet matches 
the reference sketch on the image plane.  
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By moving the vertex as well as the vertex adjacent to it along the axis of 

symmetry, you ensure that the symmetrical shape of the helmet is maintained. If 

you move one vertex independently of the other it may result in an unwanted bump 

or valley in the mesh. These types of anomalies will become more apparent when 

you copy the completed half of the mesh across the axis of symmetry.  

5. Repeat steps 2 through 4 for the other pairs of vertices on the rear of the 
helmet. Ensure that the edge loops appear smooth in relation to each other.  

When you have finished, the back region of the helmet should closely match 

the reference image on your image plane.  

 

6. In the side view, select other pairs of vertices along the top and front of the 
helmet and move them in a similar fashion so they match the reference image. 
Do not reposition the vertices for the top of the face shield yet.  

TipYou can click in the center of the Move Tool manipulator to drag a vertex 

selection freely.  

 

Next, you‘ll reposition the border edges that lie along the bottom edge of the mesh. 

You can select these edge types using the Select Border Edge Tool.  

To reposition the lower border edges on the helmet  

1. In the side view, select the lowest horizontal edge loop on the helmet by 
choosing Select > Select Border Edge Toolfrom the main menu, and then 
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clicking the first and then the last edge on the loop as indicated in the image 
below.  

2. Using the Move Tool, drag the selected edge loop downwards until the left 
hand vertex roughly matches the lower edge indicated in the reference sketch.  

 

3. In the side view, select and reposition the remaining vertices individually on the 
edge loop using the Move Tool so they match the reference sketch.  

 

NoteUp to this point in the lesson, you‘ve been instructed to reposition the 

vertices on the helmet mesh only within the side view (Y, Z plane). Once you 

achieve the shape you want in the side view you will then concentrate on how 

the model appears when viewed from the front and perspective views.  

To edit the border edges on the upper edge of the face shield  

1. From the Select menu, choose Select Border Edge Tool.  

2. In the side view, click the first border edge that will be used as the upper edge 
of the face shield, then click the last border edge (see image).  

The border edges in between are selected.  

 

3. In the Toolbox, select the Rotate Tool by clicking its icon.  

4. In the side view, click-drag the rotate manipulator in a clockwise direction until 
the border edges are rotated at roughly the same angle as the corresponding 
edge in the reference sketch.  



164 | P a g e  

 

 

5. With the border edges still selected, click the Move Tool again and drag the 
green manipulator upwards to match the location of the border edges in the 
reference sketch.  

 

6. Reposition the pairs of vertices on the upper front of the helmet to match the 
reference sketch.  

 

At this point in the lesson, the outline of your helmet should roughly match the helmet 

in the side view reference image. If it doesn‘t, review the earlier steps in this lesson 

and make any adjustments to your polygonal mesh as required.  

If you view your helmet in the front orthographic view, you‘ll notice that the helmet 

shows a wider profile from this view than the reference sketch. In the next steps you‘ll 

correct this using the front and top orthographic views of the helmet for reference.  

To reposition vertices on the side of the helmet to match the sketch  

1. Display the front view.  

2. In the front view, select the vertices that extend beyond the outline of the 
helmet as shown in the reference sketch (see image).  

 

3. In the front view, move these vertices to the left until they match the widest 
area of the helmet in the reference sketch (see image).  
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When you view your helmet from the top orthographic view the region between the 

side and rear of the helmet appears a bit flat in relation to the other areas. To correct 

this you can move the other vertices in this region outwards in a similar fashion so the 

curvature in this area appears fuller and more rounded. However, viewing only from 

the orthographic views can be limiting, and you should also use the perspective view 

to examine the mesh.  

To examine the mesh using the perspective view  

1. Enlarge the perspective view.  

2. Dolly and tumble the perspective view while you closely examine the helmet 
mesh.  

As you examine the vertices along any particular edge loop, the vertices on the mesh 

should appear to cascade in a smooth gradual fashion to create the curvature of the 

mesh with no undesirable spikes or dips.  

Ensuring that the mesh appears relatively smooth at various stages throughout the 

modeling process will reduce the possibility for issues when you create a high 

resolution version of the mesh later on.  

If you find areas where one vertex (or more) appears to protrude outwards (or 

recedes) on the mesh in relation to neighboring vertices, you can correct these 

protruding regions by repositioning the affected vertices in the perspective view.  

Editing components in the perspective view 

Repositioning polygon components in the perspective view can be more challenging 
when compared to the orthographic views because your frame of reference changes as 
you track, dolly, or tumble the 3D view.  

By default, the Move Tool lets you reposition components in relation to world space 

coordinates. That is, the movement of a component is referenced to a direction based 

on the center of the 3D scene and the X, Y, or Z axes.  

It is also possible to set the Move Tool to move objects and components based on 

other coordinate systems, such as object space and local space.  
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In addition, you can also move a polygon component in relation to its surrounding 

mesh. For example, you can select and move a vertex in a direction that is 

perpendicular or normal to its surrounding surface mesh. This is a useful technique 

for correcting any protruding vertices on the mesh.  

To move a vertex on the mesh in a direction normal to the mesh  

1. Dolly and tumble the perspective view while examining the mesh until you find 
vertices that protrude outwards from the mesh in an unwanted fashion.  

 

2. In the Toolbox, double-click the Move Tool to display the Move Settings editor.  

3. In the Move Settings editor, in the Move section, turn on the Normal option.  

 

4. In the perspective view, click the vertex you wish to reposition.  

The vertex highlights and the Move manipulator appears to indicate the three 

directions of movement that are possible in this mode.  

 

The U and V handles slide the vertex in relation to its associated edges, while 

the N handle moves the vertex either away or towards the mesh depending 

on the direction you move your mouse.  

5. Drag the N handle outwards or inwards depending on what‘s required for that 
particular vertex. Dolly or tumble the view as required to examine the mesh after 
you‘ve done this and make any modifications as necessary.  

6. Repeat the above steps for any other protruding or receding vertices on the 
mesh until you are satisfied that the mesh appears smooth.  

7. Before you proceed to the next section, double-click on the Move Tool and 
return the Move setting to the default World setting.  
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If you examine your model in the perspective view your helmet mesh should now 

match the reference sketches as they appear in both the front and side image planes 

(see image below). The mesh should also have a relatively uniform distribution of 

polygon faces on the mesh and the edge loops should flow smoothly.  

 

 

Drawing a polygon 

To create the lower front region of the helmet (that is, the region that would protect the 

mouth and jaw of the wearer) you‘ll create a polygon for the cross section of the lower 

front region by manually placing vertices using the Create Polygon Tool ( Mesh > 

Create Polygon Tool).  

To place vertices for a polygon  

1. In the side view, select Mesh > Create Polygon Tool > .  

The Create Polygon Tool settings editor appears.  

2. In the tool settings editor, set the following options:  

 Limit the number of points: On  

 Limit points to: 6  

These settings specify that a closed polygon face will be created once you 

have placed six vertices in the scene.  

3. In the side view, place six points for the profile as it appears in cross section of 
the lower front region of the helmet (see image below). Ensure that you place 
the vertices in a counter-clockwise direction for this step.  

The new polygon face is created along the YZ plane (the axis of symmetry for 

the model).  
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4. Press the q key to quit the Create Polygon Tool when the polygon face is 
complete.  

The new polygon component remains selected in Object Mode.  

NoteIf the polygon face doesn‘t appear shaded in the side view but does 

appear shaded in the perspective view, it means that the polygon face and 

the image plane lie on exactly the same plane. You can correct this by 

moving the image plane backwards in the side view so it doesn‘t lie directly 

on the YZ plane, but this step is not critical to the success of the steps that 

follow.  

You‘ll extrude this polygon face to create the remainder of the lower front region of 

the helmet. Before you can extrude the new face it needs to be selected in Face 

mode. You can do this quickly by converting the existing selection to Faces.  

To convert the object selection to face selection  

1. With the face still active in Object Mode, choose Select > Convert Selection > 
To Faces.  

The selection is converted to a face selection.  

TipYou can also press Ctrl + F11 or Ctrl + right-click on the selected object 

and choose To Faces > To Faces from the marking menu that appears.  

Extruding Polygon Components 

 You can create new polygon components from existing ones using the Extrude feature 
( Edit Mesh > Extrude). When you extrude a polygon component (for example, a face, 
edge, or vertex), you create additional polygon components from the ones you selected. 
Using the Extrude feature you will:  

 Create the lower front region of the helmet by extruding the polygon face you 
created in the last section of the lesson.  

 Extrude edges around the face shield and along the lower bottom edge.  

To extrude the polygon face for the lower front region  
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1. Enlarge the scene view to a single perspective view.  

2. With the polygon face still selected, choose Edit Mesh > Extrude.  

The extrude manipulator appears on the selected face.  

3. In the perspective view, drag the blue arrow on the manipulator to extrude a 
section of mesh out from the face (positive X) a distance of approximately one 
half a grid unit (see image).  

 

4. Press the g key to extrude again.  

5. Click the large circle that surrounds the manipulator to display the rotate 
manipulators and then drag the green circular manipulator to rotate the angle of 
the extrusion to match the angle in the reference sketch (see image) and then 
drag the arrow manipulator a second time to extrude a second section of mesh.  

TipAs you change the angle of rotation and extrude the mesh you can also 

momentarily switch between the move or scale manipulators to fine tune the 

position and scale of each section as you extrude it.  

 

6. Press the g key once again and create a third extruded region using the 
manipulator to move, rotate, or scale the extruded segment of the mesh so you 
position it correctly when compared to the reference sketch (see image). You 
may also want to view the extrusion from either the top or front view to ensure 
your extrusion doesn‘t extend outwards more than the side region.  

 

7. Save your work.  

To delete unwanted faces on the extruded mesh  
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1. Tumble the perspective view until you can view the inside of the lower front 
region (see image below).  

2. Select the faces that appear on the inside of the mesh you just extruded, 
including the faces on either end of the extrusion.  

These faces were required for creating the extruded portions of the lower 

region but are not needed beyond this point.  

3. Press the Delete key to delete the selected faces.  

 

When you are finished, a gap will exist between the last extruded segment of 

the lower region and the helmet mesh.  

 

You‘ll combine these separate meshes together and then create a mesh that bridges 

between them in the next section of the lesson. To prepare for the bridge, you need to 

extrude more edges on the helmet mesh so that the number of edges match when 

you create the bridge. 

  

To extrude the bottom edges of the helmet mesh  

1. In the perspective view, select the lower edges of the helmet mesh using 
Select > Select Border Edge Tool.  

2. Select Edit Mesh > Extrude, then drag the blue arrow manipulator in a direction 
towards the inside of the helmet to create a row of edges that are perpendicular 
to the selected bottom edges. Extrude these edges a distance that is 
approximately one grid unit in depth (see image below).  
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To extrude top and side edges for the face shield  

1. In the perspective view, select the upper and side edges on the helmet mesh 
using Select > Select Border Edge Tool (see image below).  

2. Select Edit Mesh > Extrude and then drag the blue arrow on the extrude 
manipulator in a direction towards the inside of the helmet to create edges that 
are perpendicular to the top and side edges of the face shield. Extrude these 
edges a distance that is approximately one grid unit in depth (see image below).  

 

To move vertices on the lower front region to match the reference sketch  

1. In the perspective view, right-click on the helmet and select vertex mode to 
change the selection type to vertices.  

2. Select the four vertices on the lower front region of the helmet that are near the 
axis of symmetry (see image below) and using the Move Tool, move the 
selected vertices upwards by dragging the green arrow on the Move Tool 
manipulator so that the lower front region of the helmet matches the reference 
sketches as they appear in the various orthographic views.  

 

3. Adjust any vertices on the lower region that may require minor repositioning by 
selecting and moving them as necessary.  
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Bridging Between Edges 

 Next you‘ll connect the lower front region to the helmet mesh. You can create meshes 
that bridge between one or more border edges of a mesh using the Bridge feature ( Edit 
Mesh > Bridge).  

When using the bridge feature you must ensure that:  

 the edges to be bridged are in the same polygon mesh. That is, you must 
combine the two meshes into one using the Combine feature, before you perform 
the bridge.  

 you select an equal number of border edges on either side of the region to be 
bridged.  

To combine the two meshes into one  

1. In the perspective view, right-click the mesh and select Object Mode from the 
marking menu that appears.  

2. Select the helmet mesh, and then shift-select the lower front mesh, so both 
meshes are selected.  

3. Select Mesh > Combine.  

The two meshes are combined into one. When you select either object now, 

the other is also selected because they are in the same mesh.  

The edge of the mesh on the lower front region of the helmet is comprised of five 

edges. The corresponding region on the side region of the helmet only has three. You 

can increase the number of edges on the lower side region by inserting two edge 

loops across the mesh. Inserting two edge loops in this region of the mesh also 

divides the large faces so they better match the size of the other faces on the rest of 

the mesh.  

To insert edge loops on the side region of the helmet  

1. Select Edit Mesh > Insert Edge Loop Tool > .  

The Insert Edge Loop Tool settings editor appears.  

2. In the tool settings editor, set the following options:  

 Maintain Position: Relative distance from edge  

3. In the perspective view, click-drag the edge on the side region of the helmet 
near the bottom of the edge as indicated in the image below. Without releasing 
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the mouse button, drag the mouse upwards about one third of the distance 
along the edge and then release the mouse button to insert the edge loop.  

NoteClick-dragging an edge when using the Relative option inserts an edge 

loop that closely matches the existing edge layout on the mesh. That is, the 

lower region of the mesh is much wider near the front than at the rear. The 

Relative setting adjusts the position of the edge loop locator based on this 

topology so is ideal in these situations. When you click-drag using the 

Relative option, remember to click near the edge whose layout you want the 

edge loop to match.  

 

4. With the Insert Edge Loop Tool still active, click-drag the side region of the 
helmet near the top of the same edge and insert a second edge loop about two 
thirds of the distance along the edge.  

 

5. Press the q key to return to selection mode, and click anywhere off the mesh to 
unselect the edges.  

Now that you‘ve inserted the necessary edges, you can proceed with creating 

the bridge.  

To bridge between the lower front and side region of the helmet  

1. Choose Select > Select Border Edge Tool and then click the border edges on 
both the lower front as well as the side region of the mesh where you want the 
bridging mesh to be constructed. (You should have five edges selected on 
either side).  

TipWhen you select border edges using the Select Border Edge Tool you can 

click on the first and last edge in a series on one side of the bridge and the 

tool will select the edges in between.  
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2. Select Edit Mesh > Bridge > .  

3. In the Bridge Options window, set the Divisions to 0, then click the Bridge 
button to create the bridge.  

 

4. Press the q key to return to select mode, and click anywhere off the mesh to 
unselect the edges.  

NoteIf your bridge appears to twist or cross over itself it indicates that the two 

meshes have their surface normals mismatched. In this particular case it 

likely indicates that you did not create the original profile shape for the lower 

front by placing the six vertices in a counter-clockwise direction.  

If this occurs you must undo your steps to the point immediately before you 

combined the two meshes and then reverse the surface normals on only 

the lower front section by selecting it and then selecting Normals > 

Reverse. You can then redo the instructions in this section as required.  

Adding Polygons To A Mesh 

For the protective face shield on the helmet, you'll create one large multi-sided polygon 
using the Append to Polygon Tool and then split it into multiple four-sided polygons 
(quads) so that the new polygons match the existing four-sided topology of the helmet 
mesh.  

To create the face shield using the Append to Polygon Tool  

1. Tumble the perspective view so you can see all of the edges surrounding the 
area for the face shield.  

2. Select Edit Mesh > Append to Polygon Tool> .  

3. In the Append to Polygon Tool settings window, set the following:  
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 Keep new faces planar: Off  

If the planar option is on, the Append to Polygon Tool will not create a multi-

sided polygon as the edges you‘ll select do not form a planar region.  

4. In the perspective view, click once on the top inner border edge of the helmet 
mesh to indicate which mesh you are appending to, and then click the same 
edge a second time to begin the append operation (see image below).  

5. Click the bottom edge of the face shield that is opposite the first edge you just 
clicked.  

A polygon appears that spans the two edges.  

 

6. Continue to click the remaining border edges in a counter-clockwise direction 
around the opening for the face shield (see image above) until you reach the 
last edge.  

7. When you are finished clicking the perimeter border edges for the face shield, 
press the q key to quit the tool.  

The multi-sided polygon is completed and added to the existing mesh. Multi-

sided polygons are also referred to as n-gons.  

 

Ideally, all faces should be four-sided to match the other faces on the helmet mesh. In 

the next section, you'll split the n-gon vertically and horizontally into several smaller 

four-sided polygons using the Split Polygon Tool.  

Splitting Polygon Faces 

Earlier in the lesson you split the helmet mesh by inserting edge loops across the mesh. 

You can split localized areas of a mesh using the Split Polygon Tool. When using the 
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tool you draw a line across the faces to indicate the location for the split. You'll begin by 

vertically splitting the face shield.  

To split the face shield vertically  

1. Select Edit Mesh > Split Polygon Tool > .  

The Split Polygon Tool settings editor appears.  

2. Set the following options:  

 Split only from edges: On  

 Use snapping points along the edge: On  

 Snapping tolerance: 100  

These settings let you begin and end your split at a location that corresponds 

exactly with an edge and lets you snap to the midpoint and ends of the edge 

you select. (The number of points setting of 1 ensures this). These settings 

will help to ensure that the faces you split align exactly and that the four-sided 

topology of the mesh is maintained.  

3. Tumble the camera in the perspective view so you can view both the upper 
inner edges of the face shield as well as the lower inner edges.  

4. Click-drag the top inner edge of the face shield to indicate the start of the split 
(see image below). Drag the mouse to position the vertex until it stops at the 
right side of the edge.  

5. Click-drag on the lower inner edge of the helmet mesh to indicate the end of 
the split (see image). Drag the mouse to the right until the vertex stops at the 
right side of the edge.  

6. Press the y key to split the face.  

 

7. Press the g key to select the Split Polygon Tool again, and then continue to 
split the face shield vertically at the other locations specified in the image below. 
Remember to press the y key after each split and then the g key to select the 
tool again.  

file:///C:\Program%20Files\Autodesk\Maya2009\docs\Maya2009\en_US\files\Edit_Mesh__Split_Polygon_Tool.htm


177 | P a g e  

 

When you are finished the n-gon for the face shield will be split into four or five new 

polygons (depending on how you've constructed your mesh).  

One polygon on the side of the face shield will still be five-sided. To correct this, you'll 

also split the face shield horizontally. Splitting the face shield horizontally will also let 

you modify its shape afterwards.  

 

To split the face shield horizontally  

1. In the perspective view, with the Split Polygon Tool still active, click-drag the inner side edge 
(see image) to indicate the start location for the horizontal split.  

2. In the side view, click-drag the front vertical border edge of the face shield (this border edge 
lies on the axis of symmetry) and release the mouse button at the mid-point along the edge 
where the vertex naturally snaps (as if a magnet were attracting it towards that location).  

 

3. Press the y key to split the faces.  

 

NoteWhen you split across multiple faces at the same time you only need to click an edge to 

indicate the start point for the split and on a second edge to indicate the end point. The Split 

Polygon Tool automatically splits the edges in between.  

4. Press the q key to quit the Split Polygon Tool.  

In the next steps you'll reposition some of the vertices along the horizontal split to make the face shield 

protrude outwards a small amount.  
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To adjust the shape of the face shield  

1. In the side view, select the middle two vertices at the front of the face shield 
and use the Move Tool to move the vertices outwards (+Z) a small amount (see 
image).  

2. In the perspective view, select the remaining middle vertices on the face shield 
one at a time and reposition them outwards a small distance using the Move 
Tool with the Move Setting option set to Normal.  

 

 

TipTumble the perspective view so you can see the relationship between the 

vertices as you move them outwards.  

3. Reset the Move Tool's Move Settings to World before continuing to the next 
steps.  

To create the diagonal grill vents on the lower front of the helmet you‘ll insert edges 

on the face, reposition some of the vertices, and then extrude some of the faces.  

To insert multiple edges for the diagonal grill vents  

1. Select Edit Mesh > Insert Edge Loop Tool > .  

2. In the Insert Edge Loop Tool Options window, set the following:  

 Multiple Edge Loops: On  

 Number of edge loops: 4  

 Auto Complete: Off  

These settings let you insert four evenly spaced edges on the face where you 

want the grill vents to appear.  

3. In the perspective view, click the border edge of the face where the grill vents 
will appear and then click the edge directly opposite that border edge (see 
image).  
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4. Press the y key to complete the edge loop insertion  

5. Click off the mesh to deselect the edges.  

6. Press the q key to exit the tool and return to selection mode.  

To make the grill vents appear diagonally you‘ll select the vertices on the right side 

and then slide them downwards using the Move Tool.  

To move vertices along an edge using the Move Tool  

1. Right-click the helmet mesh and change the selection mode to Vertex.  

2. Select the vertices on the right side of the grill feature (see image below).  

 

3. Double-click the Move Tool icon to display the Move Tool‘s settings editor.  

4. In the Move Tools‘ settings editor, click the Set to Edge button.  

The vertices appear unselected temporarily. The Move Tool expects you to 

select an edge it will reference for the axis of movement.  

5. Click an edge that is on the same line of the edges as the vertices you 
selected.  

The Move Tool manipulator appears and is aligned to the edge you selected. 

The vertices appear selected again indicating that the Move Tool is now set to 

move those vertices along the axis defined by the edge you selected.  

6. Drag the red arrow on the Move manipulator downwards to move the vertices 
so that the shape of the faces for the grill are more diagonal (see image).  
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NoteMake sure you do not move the vertices so that the lowest vertex 

touches the corner vertices or you‘ll create an edge that has zero length.  

7. Click off the mesh to deselect the vertices.  

8. Before proceeding to the next section, double-click the Move Tool and reset 
the tool settings by clicking the Reset Tool button.  

To make the grill vents three-dimensional, you‘ll extrude some of the thin diagonal 

faces inwards.  

To extrude the faces for the grill feature  

1. Right-click the helmet mesh and change the selection mode to Face.  

2. Beginning at the bottom of the grill feature, shift-select the two diagonal faces 
as indicated in the image below.  

 

3. Select Edit Mesh > Extrude.  

The Extrude manipulator appears.  

4. Drag the blue arrow on the Extrude manipulator towards the helmet a short 
distance to create the two recessed vents for the grill.  
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5. Press the q key to quit the Extrude feature.  

6. Shift-select the two side faces on the grill vents that lie on the axis of symmetry 
and delete them (see image below). These faces will not be required when you 
create the opposite half of the helmet.  

 

7. Save your work before proceeding to the next section.  

 

Terminating Edge Loops 

 When you inserted the edges for the grill vents the adjacent face was changed from 
four-sided to eight-sided as a result of the splitting that occurred along the shared edge.  

This situation can easily occur when you are splitting polygons in a localized region of 

a mesh, and should be anticipated if maintaining four-sided polygons is a constraint 

for your polygon models.  

When this occurs you‘ll need to find a way to gradually divide the n-gons into four-

sided regions by terminating the edge loops. Terminating edge loops is when you split 

a multi-sided n-gon gradually into multiple four-sided polygons.  

When you do this, a single vertex may have five or more shared edges coming out of 

it as a result. This process lets you create regions on a mesh that have more detail 

while maintaining a particular mesh type—four-sided polygons in this case.  

To manually split the multi-sided polygon into three four-sided polygons  

1. Select Edit Mesh > Split Polygon Tool.  
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2. In the perspective view, click-drag on the top side edge of the top grill vent. 
Drag your mouse so the vertex is positioned at the bottom of the edge (see 
image).  

 

3. Click-drag on the top edge of the multi-sided polygon and slide the vertex to 
the right end of the edge (see image).  

4. Press the y key to split the face.  

The region above the split edge appears like a polygon but is actually four-

sided because of the edges on the grill vent.  

5. Split the side edge on the bottom grill vent in a similar fashion by click-dragging 
your mouse so the vertex is positioned at the top of the edge (see image 
below).  

 

 

 

6. Click-drag the bottom edge of the multi-sided polygon and slide the vertex to 
the right end of the edge (see image).  

7. Press the y key to split the face.  

Your multi-sided face is now split into three four-sided faces, maintaining the 

overall quad topology on the helmet mesh.  

8. Press the q key to exit the Split Polygon Tool.  
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Deleting Construction History 

Maya keeps track of the options, attribute settings, and transformations made to an 
object via its construction history. Construction history is useful when you‘re working on 
a surface and want to edit an attribute from an earlier stage of the model‘s development.  

The simplest way to access the construction history for an object is via its various 

input nodes in the Channel Box or via the Attribute Editor. Selecting an input node 

displays the attributes associated with that particular modification to the object. You 

then edit the attributes on that node as required and the surface updates.  

For example, the input nodes for the helmet mesh include: polyCreateFace, 

polyCube, polyExtrudeFace, polySmoothFace, polyMoveVertex, polyUnite, and so 

on. You can associate the steps in creating the helmet mesh with nodes that are 

related to a particular stage of its construction history.  

As you near the completion of a model, these construction history nodes are not 

required. If your production work entails having another person texture or animate the 

model, you‘ll want to delete these history nodes from the objects in your scene 

altogether so another user doesn‘t accidentally change your work.  

Deleting the construction history is usually done only when a model is completed to a 

particular milestone stage and the next major phase of production with it needs to 

occur. For example, skinning, animating, texturing, and so on.  

To delete the construction history on the helmet mesh  

1. Right-click the mesh and change the selection mode to Object, and select the 
helmet mesh.  

2. Display the Channel Box if it isn‘t already, and notice the list of history nodes 
that appear in the Inputs section.  

3. Select Edit > Delete by Type > History.  

The construction history is deleted on the helmet mesh. Notice the list of 

items under Inputs has only one item remaining—the polySurfaceShape 

node.  
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4. Save your work before proceeding to the next section.  
 

Mirror Copying A Mesh 

Once you‘ve finalized one half of your polygon model (and deleted its construction 
history) you‘ll want to create the opposite half by copying it across the axis of symmetry 
so you have the complete model. You can produce a mirrored copy of a polygon mesh 
using Mirror Geometry ( Mesh > Mirror Geometry).  

Before copying one half across the axis of symmetry, you should check that all of the 

border edges lie along the axis of symmetry. If any edges do not lie along this axis, 

the original half will be copied based on the vertices that create the widest point and a 

gap between the two halves may result.  

To ensure that the border vertices lie along the axis of symmetry  

1. Enlarge the front view so you can view the vertices that lie along the axis of 
symmetry.  

If any vertices on the mesh protrude across the Y axis, you‘ll need to snap 

these to the Y axis using the Move Tool in combination with the Snap to grids 

feature.  

NoteAny vertices that protrude across the Y axis likely occurred as a result of 

an earlier extrude operation. Because the extrude feature extrudes 

components based on the face normal, a few vertices may have moved 

across the axis of symmetry.  
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2. In the front view, select all of the vertices that should lie along the axis of 
symmetry (Y axis) using a bounding box selection.  

3. On the Status Line, turn on Snap to Grids.  

4. In the Toolbox, double-click the Move Tool to display its tool settings and 
ensure that the Retain component spacing setting is turned off.  

5. In the front view, click-drag the red arrow on the Move Tool manipulator to the 
right a small distance.  

The vertices immediately snap to the grid line to the right. They initially will not 

be positioned at the location you want, but you‘ll notice that all of the vertices 

you selected are now aligned to each other.  

6. Drag the manipulator towards the left until the vertices snap to the Y axis.  

 

7. On the Status Line, turn off Snap to Grids.  

8. Click off the mesh to unselect the vertices.  

To mirror copy the polygon mesh  

1. Right-click the mesh, change the selection mode to Object, and then select the 
helmet mesh.  

2. Select Mesh > Mirror Geometry > , set the following options, and then click 
the Mirror button.  

 Mirror Direction: -X  

 Merge with original: On  

 Merge vertices: On  

The mesh is copied along -X to create the opposite half of the model. The two 

meshes are combined into one and vertices are merged so they become 

shared.  
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3. Save your work before proceeding to the next section.  

At this point, the low resolution version of the helmet model is complete. In the next 

section you‘ll preview how the model appears at a higher resolution using the subdiv 

proxy feature. 

Working With A Smoothed Mesh  

 Depending on the intended use of your polygonal model, you may want a low 
resolution version, a high resolution version, or both. In Maya, its easy to increase the 
resolution of a model using the Smooth feature ( Mesh > Smooth).  

In addition, you can preview a higher resolution version of the mesh using either 

Smooth Mesh Preview or the Proxy > Subdiv Proxy feature. You can then view and 

edit the low resolution and high resolution smoothed version of the mesh separately 

or simultaneously.  

Smooth Mesh Preview lets you quickly preview how your mesh will appear when 

smoothed.  

The Subdiv Proxy feature links the original and the high resolution smoothed versions 

via construction history, you can make changes to the low resolution version and 

immediately see the effect on the high resolution smoothed version.  

In this lesson, you‘ll use Subdiv Proxy to work with your smoothed mesh.  

To create a high resolution smoothed model using Subdiv Proxy 

1. Right-click the mesh, change the selection mode to Object, and then select the 
helmet mesh.  

2. Select Proxy > Subdiv Proxy > , and set the following:  

 Division Levels: 2  
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 Mirror Behavior: None  

 Subdiv Proxy Shader: Keep  

3. Click the Smooth button.  

A higher resolution, smoothed copy of the helmet mesh is created in the 

same position as the original mesh. It is possible to see the two versions in 

this position (and you can toggle the display to show either or both) but in this 

lesson you‘ll select the high resolution version and move it slightly to the left.  

NoteThe two versions of the model are also grouped into the same node 

hierarchy when the Subdiv Proxy operation is performed.  

 

4. Select both the low and high resolution versions of the mesh in Object Mode.  

5. Press the ‗ key (located to the left of the 1 key) to toggle the display between 
the low and high resolution versions.  

Toggling the display between the two versions is useful when you want to 

view one or the other.  

6. Press the ~ key to toggle the display so that both are visible again.  

NoteThe Toggle Proxy Display (‗) and the Both Proxy and Subdiv Display (~) 

display items are also available from within the Proxy menu.  

7. Select only the smoothed version of the mesh in Object Mode and move it to 
the left about 25 units (X = -25).  

As you edit the low resolution version of the helmet mesh you‘ll see the 

resulting updates on the smoothed version beside it.  

 

  



188 | P a g e  

 

Creasing And Hardening Edges On A Mesh 

You can crease or harden the edges on your polygon meshes. Hardening or creasing 
the edges sets how the mesh transitions between faces enhancing the realism of your 
model.  

When you harden an edge on a polygon mesh, you change the direction of the 

normals associated with the shared edge, which in turn affects the shading along 

those edges. When you crease an edge of a mesh that has an associated subdiv 

proxy, the edges on the smoothed high resolution version are creased by physically 

modifying the polygon smoothing surrounding those edges.  

In this lesson, you‘ll try both methods on your helmet mesh.  

To display hard and soft edges on a mesh  

1. Right-click the low resolution mesh, set the selection type to Object Mode, and 
then select the helmet mesh.  

2. Select Soft/Hard Edges.  

The wireframe mesh on the helmet updates to display both dashed and solid 

lines. The dashed lines indicate edges that are set to display as soft shaded. 

The solid lines indicate edges that are set to display as hard shaded. The 

reason some of the edges are hard and some are soft relates to the particular 

settings for some polygon tools.  

 

 

To soften the edges on the mesh  

1. With the low resolution version of the helmet still selected, select Normals > 
Soften Edge.  
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All of the edges on the helmet mesh are set to be shaded in a softened fashion. The 

wireframe mesh updates to display as dashed lines indicating that all of the edges are 

set to be soft shaded. You may not notice any immediate effect on the smoothed high 

resolution version, but its important that you perform this step before you proceed to 

harden specific edges on this model.  

 

To harden the edges surrounding the face shield  

1. Right-click the low resolution mesh and set the selection mode to Edge.  

2. Select the inner edges that surround the perimeter of the face shield (see 
image below).  

TipYou can quickly select the inner edges surrounding the perimeter of the 

face shield using the Select Edge Loop Tool. You may need to double-click in 

a couple of areas to complete the selection.  

3. Select Normals > Harden Edge.  

The selected edges are hardened on the low resolution mesh.  

 

 

Notice that the same edges on the smoothed high resolution version of the 

helmet are unchanged. For edges to display sharp on the smoothed version, 

you must turn on the Keep Hard Edge attribute.  

To turn on the Keep Hard Edge attribute  
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1. In the perspective view, select only the smoothed high resolution version of the 
helmet mesh.  

2. In the Channel Box, in the Inputs section, click the listed proxy to display its 
attributes.  

3. Set the Keep Hard Edge attribute to On.  

The sharper transition between the face shield and the rest of the helmet now 

appears on the smoothed high resolution version.  

4. Select all of the edges for the grill vents and harden them as well.  

 

To crease edges on the mesh  

1. Select the lower outer edges on the face shield (see image).  

2. Select Edit Mesh > Crease Tool.  

3. In the scene view, press the middle mouse button then drag the mouse to the 
right to add a crease to the selected edges.  

A thick line appears on both the low resolution model and the high resolution 

version to indicate that a crease has been applied. Notice on the high 

resolution version that the related edges have become sharper in 

appearance, but not as sharp as if they were hardened using the Harden 

Edge feature.  

 

4. Save your work.  
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NoteYou can toggle the creased edge display (thick lines) by selecting Crease 

Edges.  

 

Your model is now complete. Depending on your requirements you can delete the 

construction history on both the low resolution and high resolution versions.  

Modeling a Car 

Hi everyone. This is part 1 of my tutorial series on how to model a ford focus WRX. In 
this part you will learn how to properly set up the image planes. Now you might think 
that we should get straight into modeling but reference images are very important and 
this is just a good way of doing this. Well let's start. First bring the image into Photoshop 

 

Next use the rulers to form a smug rectangle around all the views we are going to need. 
Now you would probably need all four views but I did just three because the front and 
back view are pretty much the same. So align the rulers with the images. 
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Now we need to make sure that all of the images are the same size. I will start with the 
top view. Just select the view (this is where the rulers come in handy because the 
selection tool just snaps to them), go to edit>free transform and move and scale the 
selection so it is exactly the same size as the side view. 

 

Now we need to align the front view. I think that it is the hardest to align properly. So 
select it like in the step before and drag it next to the side view so we can adjust the 
height. 

Now that we have aligned the height we need to make sure that it is the same width as 
the top view. So select it again and suing free transform move and scale it so it is 
exactly the same width as the top view. You will probably need to rotate it to align 
properly and you can do this by going to edit>transform>rotate 90 CW and rotate 90 
CCW to rotate it back to the needed position. 
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Now that they are all aligned we need to make them into separate images. To do that 
simply select the view using rulers and go to copy, file>new and you should see that 
conveniently the proportions are already set for the view you have just selected. Write 
down width and height somewhere because we will need it later. 

 

Now just paste into new file and voila! 



194 | P a g e  

 

 

Do the same thing for all the views and save them as JPEGs. 

 

Now to bring them into Maya. Open Maya and go to four camera view. Now select the 
top view camera and rotate it 90 in Y. This will keep the images aligned. 
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Now select each of the four view cameras and create image planes for them through 
the attribute editor. Next we need to make them the same size as the images. To do 
that simply take an image planes and in the width and height bar in the channel edit 
enter the height and width values that you wrote down before. Note: use should 
probably use X.XX because having just a number XXX pixels will make your images too 
big. 

 

And now to just add the images by going back to the attribute editor and assigning an 
image to an appropriate view. 

 

Ford Focus Part 4 

Hi everyone and welcome to the final part of the Ford Focus tutorial series. While this is 
the last part of modelling the body , there might be more tutorials on detailing and 
interior. This is just for those who want to smooth out their model ready for texturing and 
son on. So Let's start. 

Note: For this tutorial you need to know the basic layout and menus of Maya 

I will be using a very simple technique. While it is simple it is quite repetitive. There will 
probably be seams and sometimes gaps in your model but you will need to fix them up 
yourself , for I believe that when every single step and tweak is written down, the artist 
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just reads the instructions and follows them, while if you were to figure out some 
problems on your own, it would help you learn. 

Hi everyone. Well without further blabber let's get started. 

1. Create a polygon cube and set the subdivisions along height to 15 and along width to 
5. Then scale it so it fits exactly one half of the car. 

2. Delete the side faces so that when we mirror and convert to Sub-D later we will not 
get any problems. 

 

3. Now select the cube and snap the axis to the origin X. Then go to Edit > Duplicate 
options and set SCALE X -1 and turn on INSTANCE. That way whenever we change 
one side of the car, the other changes as well. 

5. Now it's time to tweak the verteces so the surface resembles the shape of the car. In 
the side view just select the vertices row by row and move them down in the Y axis only. 

 

5. Now do exactly the same in the top view (except move in a different axis of course). 
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Now we have something that resembles a car. 

Quick Sub-D check 

7. In the top view select one vertex (say following the bonnet line and then in the side 
view move it down until it sits on the bonnet line as well. Do exactly the same with every 
vertex we just moved in the top view and that will define the shape of the car. 

 

 

8. As you see the outside edges are still very ugly but inside are looking good. So select 
the outside edges one bo one and move them in the Y axis (side view) to follow the 
straight line that goes right through the car. 
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So now we have the top half looking pretty good. 

 

10. Now to define the top window ledge. In the top view select the second row of 
vertices (one by one) and move the across to the top line of the window. 
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DON'T CONVERT LEAVE IT AS POLY. I was just checking :) 

6. Now in the top view select another row of vertices and move them across to follow 
the window line as you see below. 

 

 

And after the window finishes make it follow the bonnet line. 

Now we have some weird looking shape but not to worry. It will be fixed. 
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10. Now again in the top view select another row of vertices (again and always one by 
one) and move them across to a line as you see on the picture below. 

 

Then just move the vertices to follow the windscreen and the bonnet line that cuts 
across the bonnet diagonally. 
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Note: Sorry for my English, it's not very good :) 

11. Now the last last undefined row of vertices that we have can be just moved to form a 
curvatire of the car. 

 

12. Now to create the wheel arches. Using Split Polygon Tool (Edit Polygons > Split 
Polygon Tool) split the poly object using the ref plane as a reference. Be rough. 
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13. Select those new faces you have just created and delete them. 

 

13. Let's define the bumper. Using the same tool as above split the object where you 
see the line like below. 
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14. Then split some more as you see on the pictures below. 

What you should have. 

 

15. Now across those just split line split some more. Very thinly split around them so 
that when we move the verteces in the bits that are supposed to be poking out stay out. 

16. Now move those verteces in so that we get a bumper looking something like that. 
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17. Let's make the grill straight away. Using Split Polygon Tool split the car like below in 
the forn view. 
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18. Now just delete the grill faces and voila! 

 

19. The car looked a bit square so I split the bonnet as you see below. 

 

And make it go all the way through the car. 
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Quick check... not bad 
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20. Now for the headlights. Split the mesh in the front view as you see below. 

 

 

 

. Delete the faces and we have headlights. 

 

Tweak them to your liking, I have donejust that. 

22. Now to make holes for the windows. Split the mesh using iamges as reference and 
then delete the faces. 
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front... 

 

side... 

 

and back... 
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Here I have just converted one half to Sub-D and left the other poly. Don't do it, I just 
like to compare and check ;) 

23. Now to define the back bumper. Same basic principal. Split, and move. 

What we have so far... 

 

24. Now using Append To Polygon Tool create something like you see below. Just click 
on the edges and Maya should do the rest. 
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1. Here we have our original, low poly model. First we need to mirror it and them 
merge some vertices. Snap the pivot of the model to the middle X axis and then 
duplicate in -X (see previous parts for further explanation).  

 

 

2. To help us see the vertecis in need of merging turn on Polygon Count.  
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3. Combine the two halves of the car. 

 

6. Select the middle row of vertices of the car and look and the poly count window 
where it says how many vertices are selected.  

 

Now merge the vertices (Edit Polygons > Merge Vertices and set the value to 
about 0.1) and you should have a lot less vertices now showing in the poly count.  
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7. We will set all the parts of the car into different layers, so you can template 
them when they are not needed. So create a layer and name it something like 
front_bumper. Just use desctiptive names for easy selection.  

 

8. Now select the faces of the front bumper and then Edit Polygons > Duplicate 
Face. Assing the new surface to the layer we just created (Right click the layer 
and Assign to Layer) and then transform it to the side.  
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9. Now the exact same thing for the bonnet.  
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10. Now go arounf the car and do exact same thing to other parts shown below. 
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216 | P a g e  

 

 

 

11. Now to Sub-D. Hide all layer exept the bonnet and convert in to Subs.  



217 | P a g e  

 

 

 

12. Select the following edges and then Sub-Div Surfaces > Partial Crease 
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13. Now the following edges and exactly the same thing, exept this time Full 
Crease them. I will not tell you to Full crease or Partial Crease from now on 
because you have to judge the creasing for yourself. 
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14. Now the following edges. 
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15. Now those.  

 

And we have a bonnet. 
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See it is pretty simple but just a bit repetitive.  

16. Now for the bumper. Convert to sub d and lets start creasing.  

 

17. Select the edges that need creasing. You should know what they are. If not 
just experiment a bit.  
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18. Not much to crease in the midguards for now so just leave them.  
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19. The top part. Convert to subs and crease away.  
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What we have so far. Dont worry about the gaps we'll fix them later.  
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20. Now for the doors. Once again convert to subs and crease the needed edges. 
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21. The back guard. You know what to do :) 

 

22. The back bit.  
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23. The back bumper. 
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Our car.... 
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Now to crease the vertices to make the edges full. Just do the same thing you did 
to the edges.  

24. The bonnet. 

 

25. The midguard. 
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Here is what we get by creasing the verices. There are obvious seams but that 
can be fixed. The main thing is that we are getting a good shape of the car going. 
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26. Now for the door. 
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27. The backguard. 
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28. The back bit. 

 

29. The back. 
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30. Now for the top....almost done. 
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Done 

 

 

That concludes this part. As I said above it it the last part of the actual body modelling. 
Of course there is still the interior and some detailing but the general shape is there. 
Mess around with it. Once again low poly the convert and then crease. 
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19. The car looked a bit square so I split the bonnet as you see below. 

 

And make it go all the way through the car. 
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Quck check... not bad 

 

20. Now for the headlights. Split the mesh in the front view as you see below. 
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Female Character using Comic 

 Start with good reference material and use as much as you can. 
 

 Using your reference as an image plane, block out the rough shape of the 
character using cylinders. 

 

 When adding finer details make sure to follow the muscle lines strictly. 
 

 You must end up with a nice clean model, symmetrical where possible. 
 

 Try and keep to a grid system, this will give you a neat model to work with, and 
result in better deformation. 

 

 Do not put polygons where they are not needed, even if this is a high-resolution 
model. 

 

 Check the edges on your character thoroughly. Make sure they are flipped the 
correct way, what you need to avoid is 

 

 faces collapsing in onto each other when the model is animated. 

 Adjust the character to its final binding pose. 
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       Example Model Sheet   Example Facial Expression 

Sheet  

 

 

 

 Rough Turn Around 

General Shape 
Now you can start to build the character but don't rush in and try to build it a bit at a 
time, try to fill out the whole shape first as this will help you to get the proportions 
correct. 
 
Limbs and Torso 
Start by creating three cylinders. Set the height to 8, subdivision axis to 8 and the 
subdivision height to 10, (this can differ depending on the poly count restrictions on the 
character, although it is easier to remove polygons later than to try and add 
them.)Rotate, translate and scale the cylinders to position them in the correct place 
corresponding to the left leg, left arm and torso buttry to keep a row of vertices lying on 
the elbow and knee. We only need to model one half of the body as it can be mirrored 
later to produce the right hand side. 
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Note – It will make scaling the vertices easier if you do not freeze the transforms on the 
cylinders! 
Using these cylinders, and keeping them as quads, view from the side and scale/move 
the vertices horizontally until the shape of the cylinder roughly fits the leg in the image 
plane. 

 

Next switch to the front view and do the same, adjusting them to fit the general shape. 

 

For the arm look from the front and scale the vertices to fit the shape of the reference 

image. 
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Next do the same from the side view. If your model sheet has its character drawn with 
the arms out to the side you will probably need to use some other reference material to 
adjust the vertices from the top view .The 
 
 

 
 
The torso cylinder needs to be split into two, the left side and the right side. Delete the 
right side, as we only need to work with the left for now. Also delete any cap faces on all 
the cylinders if you haven‘t done already. Doing as you have already done with the leg, 
using the front and side views scale/move the vertices horizontally to get the rough 
shape of the torso. 
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You should now have a clean, grid style mesh that fits the general shape of the left 
hand side of your character, but it‘s missing 
a head, foot and a hand. 

 
Before we add these we need to join the arm and leg to the torso. Start by raising the 
arm if need be, then move the vertices at the joining ends so that they lie where the 
joints would crease. Try to get vertices to line up with each other. 
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You should start to notice areas where you may need to add an extra vertex, or you 
could remove some faces to get the limbs to join properly. This is the next stage. Using 
the Split Polygon Tool to add the vertices, and deleting any unwanted faces make 
sure the vertices all line up perfectly, then combine the three pieces and weld the 
vertices. 
 
Before we add these we need to join the arm and leg to the torso. Start by raising the 
arm if need be, then move the vertices at the joining ends so that they lie where the 
joints would crease. Try to get vertices to line up with each other. 
You should start to notice areas where you may need to add an extra vertex, or you 
could remove some faces to get the limbs to join properly. This is the next stage. Using 
the Split Polygon Tool to add the vertices, and deleting any unwanted faces make sure 
the vertices all line up perfectly, then combine the three pieces and weld the vertices. 

 
You should now have a basic body although it may need tweaking slightly to get it back 
to a desired shape. Also at this stage add any extra bits, like breasts, and attach these 
to the basic model. 
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Hands 
 

 
Hands 
To be honest at this early stage I sometimes don't bother roughing in the hands. If I do 
need to, to get a better idea of proportions, a few cubes will suffice. 
Feet 
To create rough feet I simply extrude the edges at the base of the leg cylinder. Then I 
extrude the front of the newly created faces forward, usually having two divisions. It‘s 
just a case of editing the vertices then until you get a basic foot you are happy with. 

 
 
Head and Neck 
At this point the neck can simply be a low polygon cylinder, subdivision axis to 8 and the 
subdivision height to 3, adjusted, like the torso, to fit the neck in the image plane. 
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The head should begin as a cube with a few subdivisions, again adjusting the vertices 
to fit the general shape of the reference head. We don't add any detail to the head at 
this stage. Once done, weld the head to the neck and then the neck to the body, as 
we did previously with the torso and limbs. 

 
 
Adding Details 
By now you have your basic model filled out, it has all the limbs needed as well as a 
rough head, feet and maybe even hands. 
You can now do one of two things, optimise this model for in game use, removing strips 
of polygons and adjusting it to look like a low resolution version of your character, or you 
can go in and refine the model, add more detail and fill out the shape until it 
looks exactly like the reference material. Below are suggestions on the best way to 
achieve such details. 
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Note 

 
You can achieve allot of detail with the texture on your character, don‘t rely solely on 
polygons. 

 
Muscle Structure 
Keep an eye on where the muscles lie on your character, placing edges along the 
muscle lines will result in a much more natural deformation as well as making your 
model look better. 
 

 
Muscle Structure 
Note – It may be worth spending some time mapping the lines onto your model, (as 
pictured below). Simply go around it and use hard edges as I have done, in some cases 
you will need to use the Split Polygon Tool but don‘t be afraid to add a few polygons at 
this stage. 
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Shoulders 
An area most people struggle with is the shoulder. As you can see in the image below, 
when the arms are raised the shoulder muscle (deltoid) is more pronounced, bulging 
higher than the collar muscles (trapezius). Also notice that the big back muscle, 
(latissimus dorsi) acts like a fan, opening up when the arm is raised and closing again 
when the arm is relaxed. 

 
Armpit 

Remember that the armpit recesses into the body slightly. 
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Bicep Twist 
This is a trouble area if modelled incorrectly. When a twist is applied it can collapse and 
deform horribly but this can be avoided if you keep the polygons around this area in 
strips. 
Bending Areas 
An important part of any character is the areas where it needs to bend, i.e. elbows, 
knees etc. So go around your model and make sure to put in extra polygons in these 
areas. 

 

 
 
 Bending Areas 
 
An important part of any character is the areas where it needs to bend, i.e. elbows, 
knees etc. So go around your model and make sure to put in extra polygons in these 
areas. 
As with the elbow pin point the pivot area and create the polygons behind that point. 
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Face Detail 
 
Face topology is very important, depending on what you wish to achieve with your 
model that is. A good rule, as with the body,is to stick strictly to the muscle structure 
when placing your polygons and edges. Paying attention to how the face creases, and 
constructing it according will give you a natural looking face as well as making the 
creation of blend shapes and animation easier and more fluid. 
 
Face 

 
 

                                 Face Muscles      Face Wrinkles 
 
Once again, import some scanned in imagery to use as a guide. Scale the image plane 
to fit the rough head you have created 
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Subdivide the faces at the front and start to move the vertices until you get the general 
shape. You should also do this from the front view, using another image as a guide. 
Splitting 

 
 
Splitting the polygons, keep adding more detail until you are happy with the way the 
face looks, remembering to keep the edges running along muscle lines and also bearing 
in mind how the face will need to deform i.e. will it need eyes, eyelids, an inner 
mouth? 

 
Hands 
First off, if someone on your team, or even in the studio has already modelled a decent 
hand, use it. There is no point reinventing the wheel and making more work for you, 
even if it isn't the right style the structure should be sound enough for you to work with 
and adjust. 
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Before you build the hands you need to know what the character is to be used for. If its 
in game the chances are it won't need separate fingers, just maybe a separate thumb, if 
its a character for a cut scene then all fingers will need to be modelled. 
When starting the hand I always begin with a finger, spend time creating a good finger 
and you can then copy and adjust it for the other three and the thumb. Again, get some 
images of hands scanned in and use them as image planes. 
Start with a cube – Width 6, Subdivision Width 3, Subdivision Height 2. 
Using the Split Polygon Tool we now add some details to the finger. For the moment 
you just want to define the knuckle areas, 
these just need to be on the top half of the finger (add as much or as little detail as you 
require, the images represent a medium resolution finger.) 

 
Once done you can play around with the finger to get a general shape you are happy to 
start working with. Make sure you use the image you scanned in as a guide. 

 
 
 

When you are happy with the shape of the finger, duplicate it and adjust it to fit the other 
three fingers. 
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You should now have your basic fingers to work with, duplicate one of the other fingers 
and adjust it to fit the thumb. Then, using your modelling skills and the reference images 
add some more details and the rest of the hand. You should end up with 
something like this – 

 
This hand was modelled using a male hand as reference, no good for the female model 
I am doing but I can use this as a base and adjust it. 
A few things to consider – 
1. Its better to initially model the hand flat, this makes it easier to texture. Then you can 
adjust it later for the final pose. 
2. The base of the finger, where it meets the hand, is slanted not flat. If you look in 
between your own fingers you will notice a small webbing area. 
3. Your fingers are not straight so do not model them like that. They are most likely 
slightly crooked. 
4. In women, the ring finger and the index finger tend to be the same length. But with 
men, the index finger is shorter than the ring finger. 
The 

 
 
 

Arms - Out to the sides but slightly lowered, (about 35 degrees) 
Elbows - Should be bent inwards at an angle of about 40 degrees. 
Hands & Fingers - Should be in a relaxed position with the fingers slightly bent. The 
palms should be facing forwards. 
 Legs - These should be slightly bent, as if the character is in a slight crouching position. 
Face - The head should be in a rest pose, closed mouth and open eyes. 
 
 

Modeling a Giraffe 
 
The workflow can be described in following steps:  
1. Modeling a low-poly cage in Maya. 

http://en.9jcg.com/comm_pages/blog_content-art-55.htm
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2. Make UV in Maya. 
 
3. Export the low-poly cage to ZBrush for sculpting. 
 
4. Use photoshop to create general pattern for Giraffe's skin. 
 
5. Use Bodypaint to paint the texture so the patterns can be placed in the right place 
and avoiding texture stretching. 
 
This tutorial does not include all the details of using a particular tool or program like 
Bodypaint. Otherwise the tutorial will be too long. The purpose is to show you the 
workflow that I use to model a Giraffe. Like accomplishing anything else in 3D, there are 
multiple ways to get the same result. Therefore, it by no means the best process 
available. But, at least it is a way to do it :-)  
 
1. The first step is always: find good reference. There is no substitue to good reference 
materials. It could be a drawing or a photo. I googled a image with a side view of a 
giraffe, it gives me good proportion of the animal. I imported into Maya as an image 
plane. 

 

  
 
 

2. Create a poly cube, start extruding according to the reference. Of course, you will not 
follow exactly to the reference because it is not a perfect side view. You will need to 

judge by your heart on how much to extrude and scale. Do it in the perspective view so 
you have a good idea on how the proportion goes. 

 

 

This tutorial explains the process of making a giraffe in Maya. The same principle can 

also be used in any other 3d application. 

 

 

The workflow can be described in following steps:  

http://en.9jcg.com/comm_pages/blog_content-art-55.htm
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1. Modeling a low-poly cage in Maya. 

 

2. Make UV in Maya. 

 

3. Export the low-poly cage to ZBrush for sculpting. 

 

4. Use photoshop to create general pattern for Giraffe's skin. 

 

5. Use Bodypaint to paint the texture so the patterns can be placed in the right place 

and avoiding texture stretching. 

 

 

This tutorial does not include all the details of using a particular tool or program like 

Bodypaint. Otherwise the tutorial will be too long. The purpose is to show you the 

workflow that I use to model a Giraffe. Like accomplishing anything else in 3D, there are 

multiple ways to get the same result. Therefore, it by no means the best process 

available. But, at least it is a way to do it :-)  

 

 

1. The first step is always: find good reference. There is no substitue to good reference 

materials. It could be a drawing or a photo. I googled a image with a side view of a 

giraffe, it gives me good proportion of the animal. I imported into Maya as an image 

plane. 

 

 

  
 

 

2. Create a poly cube, start extruding according to the reference. Of course, you will not 

follow exactly to the reference because it is not a perfect side view. You will need to 

http://en.9jcg.com/comm_pages/blog_content-art-55.htm
http://en.9jcg.com/comm_pages/blog_content-art-55.htm
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judge by your heart on how much to extrude and scale. Do it in the perspective view so 

you have a good idea on how the proportion goes. 

 

 

  

  
 

 

Continue to extrude and scale. The next two pictures show the legs are extruded. Also 

you only need to model half of the body, you can always combine them later on. 
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The following pictures show the finished low-poly cage. It is quite boxy looking right 

now.  

 

 

  
  

 

 

3. To smooth the poly mesh out and add more details, convert the poly mesh to 

subdivision surface. By doing that, you have the ability to switch from Subd mode to 

Poly mode and use Polygon tools to continue sculpt the mesh and view the smoothed 

result at the same time.  
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4. Once I was satisfied with the main body, the head can be seperated from the mesh 

and I start working on the head. You can leave the head attached with the body and 

sculpt details on the head. But I prefer to edit the head alone. It gives more freedom 

when you add details to it.  

 

 

  
  

  

 

5. Once head is finished, I attach it back to the main body. And combine the mesh 

together. 

 

 

  
  

 6. Once the low-poly model is finished, layout UVs in maya. I start with a planar 
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mapping on the side view. Then go into to Edge mode, and select the edges to seperate 

the entire UVs into pieces. 

 

 

 
 

 

7. Once you have a clean UV with the low-poly mesh. Export as a .obj file. And open up 

ZBrush for sculpting. The following shows the high-rez (half million polygons) version of 

the giraffe model. 

 

 

  
  

  

  

 

8. Once you get the high-res model. You can use the technique I described in my other 

tutorial "Use Maya8.5 Transfer Maps Feature to Generate Normal Maps". You can 

create the normal map which can be applied to the low-poly mesh and at the render 

time all the details you get from sculpting in ZBrush will be displayed.  

 

 

9. Next I went for texturing the Giraffe. According to the reference, the Giraffe has a 

specific pattern for their skins. You can get the pattern showed below from applying a 

Liqufied filter in Photoshop on a simple pattern. Fill in the color and you are done. 

 

 

http://en.9jcg.com/comm_pages/blog_content-art-55.htm
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10. It is pretty hard to guess in 2D program like Photoshop on where to place the 

pattern and avoiding the texture stretching at the same time. So I used a 3d texturing 

program Bodypaint. It has all the tools you got in Photoshop, the difference is that you 

are painting directly on to the 3D Mesh. I will not touch on Bodypaint here because it will 

need another 10 pages to cover the basic. 

 

 

  
 

 

Here is the final texture map. 

 

 

 
 

 

Below is the screenshots I made: 
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UVs and texture map assigned: 

 

Male Character - Modeling – Continuity 

 
Part 1: Initial features 

Create a cage mesh in Maya and begin modelling the mouth… 

Material changes 

You can change the material to green so it's easier to see. Set the material properties 

and apply materials to objects using the Hypergraph in Maya. 

Writing scripts 
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You can also create two scripts to change the visibility of the layers on which the proxy 

and smooth meshes appear as well as the transparency of the surface of the proxy 

mesh. This enables you to switch between the low-res cage and smoothed versions of 

the model as you work with a single click. 

Using outlines 

The main reason for the outline is to provide some sort of guide. Without experience, it 

can be hard to model a head in 3D from scratch. Starting with an outline can help, but 

it's not essential. 

 Copy the directory called 3D_Head from the download to your hard drive. Set 

this as your current project (File>Project>Set...) then open the scene file 

FaceTemplates.mb. 

 

 

Switch to side view and enable textured display (key 6). Now trace the outline of the 

head using a single polygon. In Maya, use the Create Polygon tool 

(Modelling>Polygons>Create Polygon Tool). Click around the outline to make the 

polygon, and hit Return to finish. Don‘t place too many points yet – just make a 

rough outline. Remember that this will be a cage not the smoothed surface 
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The face that‘s created is selected and extruded slightly to make a band of quad 

polygons right around the face. In Maya, use the Edit Polygons>Extrude Face 

command and drag the z handle to the desired distance. 

 

 

With the face still selected, press Delete to clear it. Repeat for the face on the 

opposite side. Switch to object mode (right-click-hold or press F8 until the polygons 

turn green) and then use Polygons>Smooth Proxy. This generates a subdivided 

version of the cage – if you‘re using another app, apply its own subdivision surface 

option. The cage mesh is saved as Outline.obj. 
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Begin with the mouth. First, adjust the positions of the vertices so they match the 

template better, then select four edges that define the lips and extrude and adjust 

them to also follow the template. Repeat this to form two extra polygon segments for 

the lips. Since not all 3D apps handle edges in the same way, use whatever tools 

you see fit – it‘s the mesh topology that's important here. 

 

 

It‘s now time to create the first loop. You need an extra row of polygons above and 

below the lips, so add these by using Extrude Edge in Maya. Join any hanging 

points to the rest of the mesh using Weld or Merge Vertices. 

 

Part 2: Creating loops 

You‘ll need to use edge loops to mimic muscles under the skin. Without these, the 

head will be hard to animate… 

Workflow considerations 

In reality, you might be better off fixing the lone triangle in steps 1 and 2 later when 

you add more detail to the lips. The reason we‘ve suggested you do it here is to 

show you the workflow sooner rather than later. 
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Create the first loop at the corner of the mouth. Here, the outer row of polygons is 

connected to the lower row by a single quad polygon to create a ring. Another ring is 

formed for the lips themselves. Finally, you‘re left with a triangle, which you‘ll have to 

fill in. 

 

This isn‘t a problem. Use the Split Polygon tool in Maya to draw a cut through the 

polygons you‘ve just created up to the triangle, converting it into a quad. You simply 

need to move the point so you can see it better. 
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Next, work on the nose area. This is often a tricky part, especially in the area where 

the nose and cheek meet. Two of the nose edges are extruded twice here. 

 

 

 

Join the nose edges to the upper lip by creating three extra polygons in between,and 

then join them to the upper lip. Notice that refinement is also continuing on the mesh 

– an extra loop around the lips has been added to define the edge. As long as you 

have closed loops, it‘s easy to add extra detail like this without creating triangles or 

n-gons. 

 

Extrude the edges up again creating two more polygons. Join these to the nose 

junction using the Append to Polygon tool in Maya. This is an important joint in the 

topology because it marks a change. Note that the highlighted point has five quads 

connected to it. This enables a loop (highlighted in red) to continue up over the nose 

while accommodating the extra polygons for the nostril area. The cage object is 

called FaceNose.obj in the download. 
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Fill in the chin and cheek area economically with polygons. There are ways to stop a 

loop or redirect it to help keep the mesh optimised. The red dots indicate vertices 

that are connected to only three polygons. This is another kind of junction, one that 

enables you to reduce the mesh – its topology is like the corner of a cube and helps 

to fold the mesh around corners. 

 

To create a strong jawline you need to concentrate on the mesh and begin a nice 

one-shaped loop that runs beneath the chin and up the side of the jowls. This will 

eventually connect to the eyebrow region, closing the loop. Note the path of the 

polygons in the loop and also the five (white) and three (green) quad junctions in the 

mesh which have been created in the process. This is saved as ChinJaw.obj – you‘ll 

find the file in the download 
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Take a minute to examine the mesh. As you can see, there‘s a nice array of loops 

following the features and muscles of the face. However, there are one or two 

problem areas. The corner of the mouth will need looking at later, as will the radial 

edges perpendicular to the loops. These can be dealt with when we add more detail. 

 

Use the Create Polygon tool to trace the outline of the eye opening. We‘ve used ten 

points in total – notice that the corners both have two points not one. 

Tutorial Model the perfect 3D face 

You then need to extrude this polygon outwards to make a ring of polygons around 

the eye. In some apps, such as Maya, you can just extrude the edges instead – both 

methods work well. Repeat the extrusion process until you get three loops around 

the eye. If using the polygon extrude method, you can now delete the central n-gons, 

leaving just the loops. 

Add and position a sphere for the eye. This is just a stand-in to enable you to move 

the points of the eye polygon to the correct location – 



273 | P a g e  

 

a better eyeball can be modelled later if you wish. Select and move the vertices of 

the flat eye polygon so they just touch the sphere. 

Before you start to combine the eye with the rest of the face, first select and delete 

the smoothed surface, leaving just the cage. Select the face and the eye objects 

then use Polygons>Combine. Reapply Smooth Proxy to the resulting mesh. 

Part 3: Adding the eye 

Position an eye socket, create some loops and weld it to the mesh 

Strange shading Occasionally, you might have to align the normals of the mesh if its 

shading suddenly looks odd. Use Edit Polygons> Normals>Set To Face to fix most 

problems. You can also run the Polygons>Cleanup command to fix problem 

geometry 

 

 

 

Before you start to combine the eye with the rest of the face, first select and delete 

the smoothed surface, leaving just the cage. Select the face and the eye objects 

then use Polygons>Combine. Reapply Smooth Proxy to the resulting mesh. 

 

Add and position a sphere for the eye. This is just a stand-in to enable you to move 

the points of the eye polygon to the correct location –a better eyeball can be 
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modelled later if you wish. Select and move the vertices of the flat eye polygon so 

they just touch the sphere 

 

You then need to extrude this polygon outwards to make a ring of polygons around 

the eye. In some apps, such as Maya, you can just extrude the edges instead – both 

methods work well. Repeat the extrusion process until you get three loops around 

the eye. If using the polygon extrude method, you can now delete the central n-gons, 

leaving just the loops. 

 

The eye socket is connected to the rest of the mesh by selecting and welding the 

vertices (green dots). Notice that we‘re creating concentric loops around the eye, 

plus one loop that goes over the bridge of the nose and up over the brow. In order to 

join these smoothly with the rest of the face, a five-point vertex junction is used 

(yellow dot). This creates a branching loop, which continues down around the mouth 

and jowl area. 
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Hiding the sphere and activating all four views, move the vertices to match the 

template. There are no real rules for this – you just need to practise working with a 

mesh and try to build up the volume of the face in 3D. Using photo references or a 

mirror will help with this process. 

 

The nose-eye loop is finished by extruding the edges above the eye socket and 

welding the end points back into the rest of the face. The large thin forehead polygon 

has been split to supply a vertex for welding the brow polygons to. 

     Part 4: Building the skull 
You won‘t need many polygons for the skull, but creating the ear is an intricate 

process… 

 

Now you need to extend the brow to create the skull, where the polygon density is 

thinned out. You need few polygons here because the skull is not as detailed as the 

face. The vertices are edited and the smoothed mesh is previewed. Note we've cut 
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in an extra set of edges running from the inner edge of the eye around the temple to 

help sculpt this area. Maya‘s Split Polygon tool is ideal for this. The cage is called 

Brow.obj in the download. 

 

The rest of the skull should be completed using similar techniques. Again, pay 

attention to the bones, tendons and muscles under the skin, though if the character 

is going to have hair, you won‘t need to be too particular with the topology of the 

skull itself. As you can see here, it‘s by no means perfect, but should be fine for most 

situations 

 

Model the ears as a separate object. Begin by tracing the outline of the ear in the 

template using the Create Polygon tool (or similar) to make a single n-gon. This is 

moved to the side of the head and then the polygon is extruded outwards, inset 

twice and then extruded back in again to create a section of polygons for the edge of 

the ear. The centre n-gons can then be deleted. 
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Part 4: Building the skull continued... 

 

Delete a few of the polygons at the front of the ear, then extrude the free edge a 

number of times, moving and rotating it at each step. This creates the curled inner 

portion of the ear. 

 

Close the open section inside by creating polygons between the edges, making sure 

they‘re all quads. In Maya, use the Append Polygon tool and click on opposite edges 

to create each quad – hit [y] to reactivate the tool. Select the quads and extrude 

them inwards, then move them slightly to create the hump inside the ear. 
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Using the same technique with which you began the ear, create an n-gon where you 

want the ear-hole to be then extrude it inwards a few times moving and rotating as 

you go. Next, sculpt the ear some more and create the remaining border polygons. 

 

Around the back of the ear, select the outer edge and extrude inwards ready to 

connect it to the head. Some junctions will need to be created for this. A combination 

of Split Polygon tool, Append Polygon and Merge Vertices is good for constructing 

this part of the model.Around the back of the ear, select the outer edge and extrude 

inwards ready to connect it to the head. Some junctions will need to be created for 

this. A combination of Split Polygon tool, Append Polygon and Merge Vertices is 

good for constructing this part of the model. 

 

 

 

 

 

 

By connecting one edge on the ear perimeter to the next-but-one edge, you create a 

quad that has the effect of reducing the resolution around the perimeter of the ear. 

Two or three of these should do the trick. This enables you to connect the ear to the 

head with less of a chance of encountering triangles. You‘ll probably spend quite a 

while on this part, because it requires perseverance. If triangles are unavoidable, 

that‘s fine – this section of the head hardly moves if animated. 
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The final steps involve cutting in some details. Maya‘s Split Polygon tool can be 

used here to add geometry to the lips. A loop is created around the centre edge – 

triangles are created at the corners but we‘ll get rid of these soon. 

     Part 5: Final steps 
Refine the model and duplicate it to see the full effect of what you‘ve created… 

Reading meshes The ability to read a mesh is a skill that you‘ll acquire as you create 

more 3D models. You'll soon begin to recognize common topological patterns and 

gain an instinct of how to cut them or clean them up. As with most things, this skill 

comes only with practice. 

 

Delete the centre edge, leaving a single row of quads. These can then be extruded 

inwards twice to create the inside of the mouth. The corners of the mouth need a bit 

of work to remove the triangles and create a cleaner loop of quads. Edges can be 

cut in under the lower lip to facilitate this and make the result much cleaner. 
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Detail can be added to the nose so that you can create the tight folds around the 

nostrils and cheek. As you cut in extra edges, you‘ll find triangles unavoidable. One 

trick is, if you create a triangle by slicing a quad, create another triangle straight 

away after it. By removing the edge between the two triangles, you leave a quad. 

 

Refining the rest of the model is really just a matter of time, patience and 

experience. The more you do it, the better you‘ll become. As we‘ve modelled only 

half of the face, all we need to do is select the whole model and run 

Polygons>Mirror, to duplicate this side of the face. Increase the Poly Merge History 

attribute in the polyMergeVert node to weld the seam. 
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UNIT V 
 
Advanced Modeling in Maya 

Introduction 

Creating believable human face is one of ultimate goals of every 3D artist. The process 

of creating an average human face is nothing new, however to get the realistic and 

natural looking we have to make the best out of every step we do: from collecting 

references, planning before modeling, texturing, rendering...etc. In this essay i will only 

go into studying the modeling process, i will skip talking about fundamental basic things 

such as how to use tools in Maya or step by step instruction but pay more attention to 

upper level things such as : work flow, different method in modeling, topology, common 

mistakes ...etc all the things that you should put your mind on while modeling to create a 

realistic head model. 

Pre modeling 

Before going into modeling process, i researched at how should we set up references 

and concept arts as these process have a direct  influence  on our models later. The 

most important things in this part is the accuracy and quality of reference photographs 

or concept arts, if we under estimate or make mistake in this process, we might face 

problem in modeling when we realize that the model fit with the front view image plane 

but does not fit with the side view, or there is chance that our model look exactly fit in 

orthographic view but in perspective view it doesn't look alike the person in reference 

and this will consume a lot of time to make any changes once we have moved into 

modeling part.  

If we are going to take photograph of a real person for references, It is important to take 

photograph at right angle or else our model will look wrong and we will have to spend 

considerable amount of time to adjust it. we should also take into account of our camera 

's focal length. the longer our focal length is, the better reference photographs we have. 

Because the longer our focal length is, the closer our view angle to orthographic view ( 

like front view, side view  which we base our modeling on). However, in theory we never 

get a orthographic reference photograph due to distortion of view angle so the models in 

3D always look a little bit fatter than the real person, but this can be solved by additional 

editing in perspective view. The other thing is we should use even lighting because all 

the detail will be washed out or become hidden with too strong or too low lighting. 
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Maya  

We can‘t get the raw photograph straight from camera into Maya image plane for 

modeling yet, because of the deviation during photographing process we have to check 

whether these image are exactly fit with each other or not. we should correct our 

reference  images in Photoshop or any other images processing application.  

 
( references images from "ESSENCE: TheFace Modeling and Texturing" - Ballistic 

Publishing 2007 ) 

  Edge planning & Topology:  

 
( references images from "ESSENCE: TheFace Modeling and Texturing" - Ballistic 

Publishing 2007 ) 

we should always plan before modeling or else we will get lost in maze of edge loops or 

have too many unnecessary faces, triangle or pole ( vertex that shares more than 4 

edges ).initially we have to sketch out the main shape of the head then base from that 

we plan our edge structure. Having good topology for our face model is even more 

important than other object in 3D.  
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Modeling A Dragon Using Nurbs 

 
This presentation will walk you through the process that created 
a cartoon raptor. This is just another way to create the model 
with different goals and details in mind. We will look at the 
modeling, texturing, and lighting phases of the project. 
Creating the “Cartoon Raptor” 

  
Modeling Form in Silo 
If you have been following the tutorial, you will recognize the basic shape of the raptor. 
This image shows a point where I have started detailing the feet. As we move through 
this presentation, I will be adding more to the model than the tutorial called for. You may 
want to add some of these things, but 
remember to stick to the tutorial and finish the basic form first.  
Little add on s are icing on thecake. You need to turn in a basic 
working model first. 

 
Modeling the Mouth 
One of my big changes was the addition of a mouth. As you added edge loops to the 
head in the tutorial, you set the stage to build a nice open mouth. 
In the front of the head, I split apart the basic polygon structures. Even though I broke 
them apart, they all still stayed in quad format. This image shows the empty space 
inside the head after the first break. 
I used the ‗bridge‘ command to create polygons to bridge thefloor and roof of the mouth. 
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Modeling the Mouth 
 

 
The change in this image shows the use of the bridge command to cross the mouth and 
then splitting the polygons a few times to help build some features of the mouth. Since 
this was going to be very simple, I needed gums and a tongue (not seen here). Notice 
how the exterior of the head has not changed, I have only been adding edges inside of 
the mouth to existing edge loops. 
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Modeling the Mouth 
 

 
 
After I finished the mouth and the tongue, I did some more work on the rest of the body. 
There is now more form because of the additional edge loops. However, for simplicity, 
the interior of the mouth remained quite simple. In the last slide I mentioned gums. Now 
I am creating the teeth to fill in that mouth. The teeth are just little cylinders with a center 
point in the flat part. The center point was pulled up to ‗sharpen the tooth‘. 
All of the teeth were created individually and then merged to create one object in Silo. 
 
Modeling the Mouth 
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Here is the final mouth with 
subpatching on. You can work in whatever format is good for you. I work without 
subpatching for the basic work and then refine with it on. This is a cartoon raptor, so I 
pulled the corners of the mouth up and kept the teeth rounded. He‘s more like a panting 
dog than a vicious dinosaur. Think about the mood and attitude of your final character 
as you work. The face, more than any other part, reveals the character‘s personality. 
 
Modeling the Spines 
 

 
 
 
 
I wanted to add some spines along the head and back of my cartoon raptor. It should 
add a little variety of form to an otherwise solid red color for the dino. I started by adding 
two edge loops along the center line. 
These new loops would be the max width of the spines. Use the ‗slide‘ command to 
adjust them easily without affecting the geometry. 
Then it‘s a matter of a lot of extrusions. This image shows the first stage of the extrusion 
and then after I clean up the blockiness. 
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Modeling the Feet 
 

 
 

My feet/claws were also a bit different from the tutorial. You can see I broke up the toes 
for the model. I was trying to think about future animation, so I knew I would want those 
toes to move separately. Instead of just separating the model when you get to the 
claws, start earlier up the foot area. 
You can also see a fourth toe on the back of the heel. That was created by selecting a 
polygon and extruding until I got a shape I wanted. Variety and details make a character 
more interesting. 
 

 
 

Here‘s the subpatched version of the feet. Take a look at the claws. Even though they 
are small compared to the final model, they have detailed forms. Go out and do 
research about claws. Dino claws are more like birds than dogs, so it‘s in your best 
interest to look online for close-ups of bird claws for reference. Look at two last things. 
The indentation at the base of the claws was created by having three edge loops very 
close together to create a fold. Notice how I have applied different materials to different 
body parts. I applied them along the edge loops and geometry. 
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Final Model 
 

 
 

This is my basic model in it‘s final stages. Let‘s talk about the materials. I have created 
nine materials and applied them to polygons across the model. This raptor is different 
because I have no intention of creating any color maps for him. As he was being built, I 
created edge loops in the exact locations where I wanted different colors. I then applied 
materials to those polys. For example, I selected the polys for each spine and then 
applied the color of the ‗spine‘ material. Now, no matter how I rig or deform, those faces 
will always hold the correct color. 
 
Final Model 
 

 
 
Here‘s a closer look to see how the colors follow the edges of the model. Think of it as a 
skin for a moment. Even if you pinch your skin, the colors that cover that area of skin 
remain the same, even though stretched. By applying materials to polygons as block 
colors, I don‘t have to worry about matching or aligning textures. Another advantage for 
my animation is that I will only use procedurals or presets for my textures. I won‘t be 
loading any maps and render time should decrease. The drawback is that I can‘t have 
any detailed skin details. 
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UV Maps – Eye 
 

 
 
 

Here I go with the UV work. Do Ineed to? No. Do you need to do good UVs? Yes. It‘s 
required forthe class.I‘m skipping a lot of the UV headache because I have nointention 
of ever using them.Here‘s a look at the UV work for the eyeball in Silo 2.1. You can see 
the basic model, the 3D UV version of the model, and the 2D map. Notice that the eye 
only needs one UV seam. When you recreate the UVs using XYZ Coords, you can 
separate the circles for the final map. 
 
UV Maps – Body 
 

 
 
Since I was not focusing on cutting this model up like a traditional UV, I am using more 
seams than usual for the raptor body. More seams makes a more tedious effort when 
you clean up UVs, but you don‘t have to worry about fixing deformations of the maps. 
There‘s a tradeoff. Always do what your boss or teacher requests. ASK if you don‘t 
know what they want. I seamed all of the small parts separately so there was as little 
work as possible for things like the spines. 
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UV Maps – Body 
 

 
 
This was the layout after choosing XYZ Coords in the UV menu. Like I mentioned 
before, there are a lot of little pieces, but they don‘t require much effort for cleanup. 
Another drawback to the fast way of doing this is that you can‘t see any organization of 
pieces. At the least, reorganize the map pieces to show the basic form of your model. It 
will help if you need to return to the piece.Again, your work for 331 should look like the 
maps from my other document that talks about texturing in Photoshop. This is just 
another way to do it. 
 
UV Maps – Teeth 
I have been saying don‘t UV your body in the same way I am. However, when it comes 
to things like teeth you want to do it this way. Unless your model is the interior of the 
mouth, teeth are small enough to do quickly. There are too many and they are too 
tedious to play with for long periods of time. 
The time intensive part of UVing the teeth is setting up the UV Seams. Do each tooth 
individually and make sure they will unwrap without any overlapping. Think of the image 
of an unwrapped cube or cylinder. The teeth are very similar. 
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I have been saying don‘t UV your body in the same way I am. However, when it comes 
to things like teeth you want to do it this way. Unless your model is the interior of the 
mouth, teeth are small enough to do quickly. 
There are too many and they are too tedious to play with for long periods of time. The 
time intensive part of UVing the teeth is setting up the UV Seams. Do each tooth 
individually and make sure they will unwrap without any overlapping. Think of the image 
of an unwrapped cube or cylinder. The teeth are very similar. 
 
UV Maps – Teeth 
 

 
 
After I created the UV seams, I applied the XYZ Coords function and that‘s it. You can 
also try the‗Scale UVs Proportionally‘ command to see what you get, but I was happy 
with this first generation of the map. Notice how each of the teeth unwrapped along a 
seam of the cone and then around the edge of the base. Fast and useful for these 
simple models. 
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Last Look in Silo 
 

 
Now I‘m done with Silo. Here‘s one last look. I can‘t emphasize enough how important it 
is to label your parts and materials. It makes life so much easier. The whole model has 
four objects Right and Left Eyes Body Merged Teeth The UV‘s and textures will follow 
the model into Lightwave3D or Maya. I can adjust the shaders and materials in the next 
application I use. Be careful if you go to another program like ZBrush and then into 
Maya, you will lose that material information (but not the UVs). 
 

 

 
Modeling An Ear 
 
Step 1. 
 
It's always a good idea to have good reference material. I recommend Atlas of Human 
Anatomy for the Artist. It's a great resource for all your human modeling Anyhow, there 
are basically four major areas to the ear. The outer helix: the outer rim, the anti helix: 
the top curls of the inner area, the lobe and the ear hole area. (My simple explanation.. 
heh) If you look at it, there is basically a single line that follows the outline of the ear, 
then moves inside and branches into two areas. Keep those curves in mind when you 
model. 
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Step 2. 
 
Create a polygon profile of the general ear shape in a side window. Divide it up into it's 
four major areas using whatever Split tool your software uses. Once you have split up 
the upper ear ridge (helix) (Image #1), select those vertices and pull them out. (Image 
#2). While modeling, you will have to delete and add edges as you see fit. Keep your 
polygons four point polys if you can help it. In Image #1 I've highlighted the edges that 
will be pulled out to quickly (and roughly) shape the depth of the ear. By starting in 
those areas, you can get a quick sense of how the ear is progressing. 
 

 
 
Step 3. 
 
Split along the ear ridge again and move the second row of vertices out like the first 
row. 
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Step 4. 
 
Define the anithelix of the ear by grabbing its vertices and moving them out. Delete any 
edges that you don't like and add any (Split the Polygons) that you think will help. 
Remember to try and keep them four point polygons. In the end it will make for a 
cleaner model. 

 
 
Step 5. 
 
All I've done here is defined the outer ear ridges better, and deleted a few edges around 
the ear hole and then split them again to make that area more workable. The edges in a 
model are never set in stone, as I reach a new area to work on, I sometimes delete the 
edges that are there and make new ones that work better for the changes that are 
ahead and clean up any three point polygons I've made. 
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Step 6. 
 
I tweaked some more on the general shape simply by moving vertices and extruded in 
the general shape of the ear hole. 
 

 
 
Step 7. 
 
Still deleting and adding edges, I also got rid of the large open area in the inner helix 
that I should have noticed in the beginning. 8) I moved vertices around the ear hole to 
better define it. I then rotate the left half of the ear vertices a bit to give it a more ear 
appropriate angle 
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Step #8. 
 
I created a large polygon on the back of the ear, closing it. Simple. 8) 
 

 
 
Step #9. 
 
I then extruded the face out and scaled it a bit smaller. I deleted the polygons that 
weren't needed and merged some vertices that I had snapped to others near the front 
area where it will connect to the head. Moved the new vertices to better places to define 
the new ridge better. 
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Step #10. 
 
Extruded the large face once more to make the area where the ear will connect to the 
head. I then deleted any unnecessary polygons. Pretty much the same step as step 
nine. Merged any vertices that were snapped to others. Moved the new vertices to 
make a decent head connection shape. 
 

 
 
Step 11. 
 
I then added more definition around then ear hole area where it will connect to the 
cheek. I also moved the vertices in the outer helix inside curve outwards to create a 
sharper curve, I then did yet more tweaking on the general shape of the ear and its 
curves, always looking for areas that are three point polygons that I can delete edges 
on, or change slightly to make them four point. 
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Step 12. 
 
Did some more general adjusting on the vertices for a nicer outline, deleted the odd 
edges here and there and touched them up. Rotated the vertices outwards to make a 

more pleasing curve to the ear (Your ears not flat against your head� a common 

mistake). Defined around the ear hole tweaking the vertices there and around the inner 
ridges (antihelix), tweaked the vertices around the lobe to round it out some more. Went 
on one last prowl trying to get rid of three point vertices. You can pretty much tweak it 
until the cows come home at this stage. 8) 
 
Image 13 isn't needed 
 

 
 
Finished! 
 
All that is left is to Smooth (Sub-divide) it in whatever way your software package does. 
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Modeling a Foot 
 

 
 

I won't explain every detail in the beginning, you can get to the state in the next image 
several different ways. For example like this: polygonal box modeling. (This isn't meant 
to be a step-by-step cloning; it's more of a general workflow thing.)  
[Above] 
 
This is the model I started with for this session - a simple model several years old that 
I'd previously used as the 0-level of a hierarchical SubD surface. But I wanted to rebuild 
it without the hierarchy (mainly because I plan to render it in Renderman one day). 
[Below] 
 
Say we're going for realism. Well in that case this isn't working. It needs more detail, 
and for that we need reference. Also, the topology is bad. (I could make it better without 
reference, but I knew I'd need it before the end so I made it the first order of business.)  
 
The best reference is without a doubt the actual human body, and I did use my own foot 
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to some extent, but good photographs do have certain advantages over the living body 
(like for instance, my foot is really ugly). I used reference images from Peter Levius 
great site www.3d.sk - I found about 4 different women's feet there, from several angles, 
quite close up, flat on the floor, which was exactly what I needed. (I can't show all of 
them, for copyright reasons.)  
 

 
 
To those who doubt the usefulness of a traditional art education to a 3d modeler, I hope 
the following may help to sway your opinion a little. First I sketched the major shapes I 
could see, then I sketched a preliminary topology. There's also a cross-section showing 
the spacing of vertical edges around the back of the ankle.  
 

 
 

From here I started adding and deleting edges to the old model. On the left, the red 
lines indicate edges being added, and on the right, the highlighted edges (orange) are 
about to be deleted.  

http://refer.ccbill.com/cgi-bin/clicks.cgi?CA=923154-0000&PA=420968
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A view showing some points being pulled to the left, as seen on the right. 
 
More edge-insertions and deletion steps below 
  

 

 
At this stage I felt dissatisfied with the SubD version of the foot - it was still too smooth, 
and lacked detail.  
 
One of the most obvious characteristics of the foot is it has much more detail than many 
other parts of the body. The contrast is especially apparent on women. It's also true of 
course for hands, knees, elbows and central/lower front of throat etc, though usually 
less so.  
 
So I went back to the reference and did another round of sketches. On the left I've 
highlighted 'knobs' of bone and muscle that are visible most of the time, on most feet. 
On the right I've underlined the drooping shape of the ankle bone. Another thing I noted, 
which was unexpected, is that on some women the first knuckle of the index-toe - it's 
'base' - is lower than that of the little toe.  
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With those knobs added: 
 

 
And the final topology: 
 

 
Select these edges, then do a Subdiv Surface > Full Crease. 

 

 

 
 
A lot of people seem to think that polygons with 3 or 5 sides are bad when converted 
into SubD's, especially in other packages but also in Maya. I've never seen any other 
valid reason given (for Maya) than that it makes the file slower and heavier, and creates 
bumps where you might want smoothness. (Oh, and that MR can't render non-quads 
yet.) Perhaps there's also a sense that it takes a lot of effort and patience and some skill 
to keep it all quads, and the resulting mesh has a more pleasing 'clean' look to it.  
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But personally I've never noticed any slow-down. As you can see above I've integrated 
triangles and 5-sides into my modeling method. It's a very easy way to add bumps and 
discontinuities, and not having to worry about edgeloops is a relief and a timesaver, and 
keeps the polygonal model slightly lighter. It also works fine with deformations; here's a 
rigged foot bending: 
 

 
But if you have other experiences please feel free to share, I'm always eager to learn. 
 

 
The UV's (I know not very clean), and the texture maps: color, spec, bump.  
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Modeling a Head using Polygon 

Modeling the Head 

Before starting to model the face, it is recommended that you study the various muscles 

and their purpose. While reading about these muscles, you may want to use a hand-

held mirror to observe their effects on various expressions. 

The Skull 

Since the muscles of the head are thin and flat, it is the shape of the skull that dictates 

the overall form of the head. Figure 6-1 illustrates various views of the skull. Visualizing 

the skull beneath the head makes it easier to see their respective masses that shape 

the face. 

 
Fig. 6-1 Some of the more prominent features of the skull that affect the contours of the face are the 

forehead, eye sockets, nasal bone, cheekbones, the empty pockets between the jaw and 
cheekbones, and the chin. 
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The Muscles of the Head 

 

Fig. 6-2 The muscles of the head are divided into three groups: scalp, face, and mastication. 

 

It is important to note that no skeletal muscle acts on its own. When one muscle 
contracts or draws together its fibers, it activates other, opposing muscles, which in turn, 
modify the action of the original contracting muscle. Normally, the head is broken up 
into three sets of muscles. Most of these are small, thin, or deeply embedded in fatty 
tissue. A few of the muscles shown in Figure 6-2 warrant special attention. They play an 
important role in facial expressions and help define the contours of the face. 

Modeling the Head Steps 

 

 

Fig. 6-3 Head Steps 1-4. 1). Making a box. 2). Dividing it and bevel extruding the neck down. 3). 
Dividing the head down the middle and shaping only half of it. 4). Adding extra lines for more 

detailed modeling. 
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Step 1. (Figure 6-3). After loading your photo templates of the head, create a box that is 
similar in size to your background images. 
 
Step 2. (Figure 6-3). Divide the cube into smaller sections and bevel extrude the neck 
part down. 
 
Step 3. (Figure 6-3). At the 0 x axis split the head down the middle and delete one half 
of it. In subpatch or subdivision mode refine the shape of the half head.  
 
Step 4. (Figure 6-3). Split the half head into more sections and use the extra points to 
further refine the head.  

 
Fig. 6-4 Steps 5-10. 5). Preparing the mouth area (dark part). 6). The darker areas show where 

polygons are split and points moved. 7). Merging to upper and lower lips. 8). Beveling out the mouth. 
9). Beveling in the mouth. 10). Beveling in to start the inside of the mouth. 

 

Step 5. (Figure 6-4). The illustration indicates the region where the mouth will be 
modeled. This darker polygon is where the mouth will be split and beveled.  
 
Step 6. (Figure 6-4). Split the polygons and move points so that the configuration looks 
similar to the darker polygons in the illustration. 
 
Step 7. (Figure 6-4). Merge the two polygons of the upper and lower lip so that the one 
polygon can be beveled in the next step. 
 
Step 8. (Figure 6-4). Bevel out the mouth a little. 
 
Step 9. (Figure 6-4). Bevel in the mouth to about the same plane as the polygons of the 
front face. 
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Step 10. (Figure 6-4). Bevel in the first part of the inside of the mouth. 
 

 
 

Fig. 6-5 Steps 11-16. 11). Beveling the inside of the mouth once again. 12). A few more bevels 
complete the inside of the mouth. 13). Shaping the inside of the mouth and splitting the back 

polygons. 14). Refining the half lips. 15). Making the first bevel for the eyesocket. 10). Splitting the 
eye area in half. 

 
Step 11. (Figure 6-5). Bevel in the second part of the inside mouth area. 
 
Step 12. (Figure 6-5). Make several more bevels to complete the inside of the mouth. 
 
Step 13. (Figure 6-5). Shape the inside mouth part so that it is rounder. If the back 
polygon has more than 4 sides then split it up into 3 or 4-sided polygons. Delete any 
inside mouth polygons that were created along the 0 x axis from beveling. The half 
inside mouth should be an open form. 
 
Step 14. (Figure 6-5). Fine-tune the shape of the lips. The half mouth is now nearly 
complete. 
 
Step 15. (Figure 6-5). Begin the eyesocket by selecting the polygon in that area and 
beveling it in once. 
 
Step 16. (Figure 6-5). Divide the middle of the eyesocket and move points to give it a 
more almond-like shape. 
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Fig. 6-6 Steps 17-22. 17). Welding points at both corners of the eyesocket and merging the 2 half 
polygons (dark part). 18). Beveling in slightly to add a line around the opening. 19). Beveling in once 
more to begin the eyesocket. 20). Pushing and pulling points and splitting polygons to improve the 

eye opening. 21). Dividing and moving points at the cor- ner of the eye. 22). Beveling the eyesocket 
in several more times. 

 
Step 17. (Figure 6-6). Weld the two points at both corners of the eye opening. Merge 
the inside polygon (dark area in the illustration). 
 
Step 18. (Figure 6-6). Bevel the inside polygon inward a little so that you have an extra 
line around the eye opening (dark part). 
 
Step 19. (Figure 6-6). Bevel the eye opening polygon in once again. 
 
Step 20. (Figure 6-6). Split the polygons around the eye opening and refine its shape. 
 
Step 21. (Figure 6-6). The corner of the eye (dark part) should now be split and shaped. 
This is the area where the pink membrane will be seen. 
 
Step 22. (Figure 6-6). Continue work on the eyesocket by beveling it in a couple more 
times. 
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Fig. 6-7 Steps 23-28. 23). Completing the eyesocket. 24). Dividing polygons above the eye opening. 

25). Dragging points down to form the upper eyelid. 26). Splitting the polygons below the eye 
opening to make a crease 27). Refining the jaw by splitting polygons. 28). Splitting polygons around 

the lips. 

 
Step 23. (Figure 6-7). Bevel the eyesocket in once again. If necessary split the back 
polygon into 3 and 4-sided polygons. Shape the eyesocket to make it round enough to 
accommodate the eyeball which will be modeled in the next chapter.  
 
Step 24. (Figure 6-7). Divide the polygons above the eye opening (dark area of the 
illustration). The resulting line will form the eyelid.  
 
Step 25. (Figure 6-7). Drag the points above the dark part down and forward a little. 
Move the vertices of the top of the dark area back and up somewhat. This should form 
the upper eyelid. 
 
Step 26. (Figure 6-7). Make the crease below the eye opening by splitting polygons. 
Move the points underneath the eye opening to create a line there. If your model has 
bags under the eyes you can easily shape one with the two parallel lines.  
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Step 27. (Figure 6-7). The polygons below the chin should be split. Move the resulting 
points to improve the chin area. 
 
Step 28. (Figure 6-7). Now it is time to begin polishing the shape of the head. This 
means that polygons in certain areas will have to be split into smaller ones and some 
will have to be merged. Points will also be moved. If your software has the ability to spin 
quads, then use this option to find the best configuration for the different polygons. The 
dark parts in the illustrations indicate where you will have to split and merge polygons. 
Notice the change in polygons between steps 28a and steps 28b.   
 

 
Fig. 6-8 Steps 29-34. 29). Dividing and shaping the forehead polygons. 30). Splitting the polygons in 
the center. 31). Dividing polygons by the ear. 32). Splitting polygons down from the top of the head 
to the chin 33). Merging polygons into one for the ear location and arranging the 9 points around it. 

34). Beginning the nose by unifying polygons into one. 

 
Step 29. (Figure 6-8). The polygons in the forehead region are too large so they should 
now be divided into smaller ones. 
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Step 30. (Figure 6-8). The middle section on the side of the head running through the 
ear part is divided all the way down to the bottom of the neck. 
 
Step 31. (Figure 6-8). The polygons where the ear will be modeled are too large so they 
should now be split into sections like those shown as darker values.  
 
Step 32. (Figure 6-8). The illustration indicates the location where more polygons are 
split down and across the base of the chin. 
 
Step 33. (Figure 6-8). Move points around the location for the ear so that you have a 
rough shape of its outline. You should have 9 points outlining the ear. Merge the 
polygons where the ear will go. Continue moving points around this polygon until you 
have a shape similar to the white area of the illustration. 
 
Step 34. (Figure 6-8). Split and move points on the polygons so they look similar to the 
dark area in the illustration where the nose will be modeled. Merge the 3 polygons into 
one. 

 
Fig. 6-9 Steps 35-42. 35). Beveling out the nose polygon. 36). Dividing the nose polygon so each 
section has 4 sides. 37). Splitting polygons and moving points below the nose (darker areas). 38). 

Dividing polygons next to the nose 39). Refining the polygons next to the nose by splitting them 
some more. 40). Dividing some more polygons. 41) Making an extra line close to the nose wing. 42) 

Splitting polygons and moving points on the side of the face. 
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Step 35. (Figure 6-9). Select the merged nose polygon and bevel it outward to make the 
general shape of the nose. 
 
Step 36. (Figure 6-9). Divide the nose polygon into 4-sided ones. Move points to shape 
the nose. A more detailed nose will be  
modeled after the next few steps which involve refining parts of the face. 
 
Step 37. (Figure 6-9). Use the dark areas of the illustration as a guide for splitting 
polygons underneath the nose.  
 
Step 38. (Figure 6-9). Divide polygons on the cheek area. 
 
Step 39. (Figure 6-9). Split more polygons next to the nose.  
 
Step 40. (Figure 6-9). Divide polygons along the lower half of the nose and the cheek. 
 
Step 41. (Figure 6-9). Make a line along the side of the nose next to the nose wing by 
dividing poly- gons. Pull and push points to make the indentation that follows the edge 
of the nose wing. 
 

 
Fig. 6-10 Steps 43-49. 43). Starting the nostril by selecting the polygon to bevel up. 44). The first 
bevel of the nostril. 45). The second bevel for the nostril. 46). The final bevel of the nostril. 47). 

Creating the line for the upper portion of the nose wing. 48). Dividing polygons at the top of the nose. 
49) Dividing polygons at the corners of the lips and refining their shape. Adjusting the width of the 

nose after mirror duplicating the half face. 
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Step 43. (Figure 6-10). Divide the polygons at the bottom of the nose so that you have 
one that can be beveled up to make the nostril (dark polygon in the illustration). 
 
Step 44. (Figure 6-10). Bevel the nostril polygon inward a little to form the outer edge of 
the nostril. 
 
Step 45. (Figure 6-10). Bevel the polygon up into the nose to make the first inside 
section of the nostril. 
 
Step 46. (Figure 6-10). Bevel the nostril polygon up once more to complete the nostril. 
Move points to refine the nostril's shape. Notice the other inside views of the eyesocket 
and inner mouth forms.  
 
Step 47. (Figure 6-10). Follow the illustration to make a line at the lower half of the 
nose. Pull and push points closer to each other to make the upper line of the nose wing 
more distinct.  
 
Step 48. (Figure 6-10). Refine the shape of the nose at the top by splitting polygons and 
moving points. Notice the nose wing now has a distinct shape. 
 
Step 49. (Figure 6-10). Use a set value to move all the points at the center seam to the 
0 x axis. This is important if you don't want to have holes and creases along the center 
of the face after mirror duplicating it. Check to make sure that there are no middle 
polygons for the inside mouth and eyesocket. When the face is mirrored there should be 
a hollow for these without polygons dividing them in half. These kind of polygons are an 
annoyance since they pull on the outer ones creating unsightly creases. Check the 
nostril to make sure that you did not move any of its points to the 0 x axis. 
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Fig. 6-12 Steps 57-61. 57). Dividing and moving points for the upper part of the ear bowl. 58). 
Splitting polygons and moving points to make the ear flap. Smoothing the section between the ear 
and the head. 59). Dividing and moving points to refine the shape of the ear flap. 60). Splitting and 

pushing/pulling points to complete the ear. 61). Mirror duplicating the half head. If necessary, refining 
parts of the head with Symmetry on. 

 

Step 57. (Figure 6-12). Model the small dimple at the top of the inside ear after splitting 
some of the polygons. 
 
Step 58. (Figure 6-12). Sculpt the ear flap after dividing polygons. Make the transition 
between the ear and the side of the head smooth. It should appear seamless. 
 
Step 59. (Figure 6-12). Continue modeling the axis. Mirror duplicate the half head and 
make sure the points are merged at the center seam. If needed, with Symmetry on 
finish the head by moving points.  

 

Modeling a Head using Subdivision 

Odeling A Head in Maya With Subdivision Emulation 

Perhaps I should preface this tutorial by acknowledging that many different methods 
exist for creating 3D characters for broadcast. To date, probably the most popular 
method has, in my estimation, also been the most complex one - that is, modeling with 
the use of NURBS surfaces. In the past, NURBS modeling was generally credited with 
many distinct advantages over polygonal modeling. Specifically, its advocates 
appreciate the excellent performance of NURBS geometry in wireframe mode, the 
ability to easily modify organic shapes with a minimal number of CVs while retaining a 
smooth surface continuity, a virtually infinite degree of control over the tessellation of 
the model at rendering time, the ability to easily add detail to a NURBS surface without 
changing the topology of the piece (through the insertion of isoparms at specified 
locations), and in some cases an added level of control over texture application 
because of the inherent UV directionality that is associated with NURBS and patch 
surfaces.  
 
However, although I have enjoyed the benefits of NURBS modeling and have had a fair 
amount of success with NURBS-based character design, I would argue that modeling 
with subdivision emulation (or even better, actual subdivision surfaces) can offer all of 
the benefits of NURBS modeling along with a dramatically simpler production process. 
In this tutorial, I will explore the process of modeling a 3D character head through the 
use of subdivision emulation in Maya 3.0 Complete. In subsequent tutorials (to be 
posted soon), I will address the issues associated with texturing the resulting smooth 
surface, animating the facial expressions through the use of blend shapes, and adding 
eyebrows and hair using Maya's Paint Effects tools.  
 
Of course, the first step to modeling any character is generally to create a series of 
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character sketches so that one has a clear vision of exactly what the character model 
should look like. Although it is always nice to have a reference on hand when creating 
3D models, I believe that the use of character sheets is particularly important when one 
is creating original 3D characters; too often 3D models tend to be constrained by the 
toolset, and end up looking surprisingly inorganic or (perhaps even worse) 
inappropriately hyper-realistic. Before I began modeling the character featured in this 
tutorial, I spent several hours sketching and revising the character's proportions on 
paper.  
 
Once these character sketches are complete, the next step is to start creating the 3D 
model. For the purpose of simplicity, I always start by creating a polygonal cube 
(Create>Polygon Primitives>Cube) which I will then sculpt into the desired form.  

 

Using the Polygons>Smooth tool, I could immediately convert this cube into a very 
rounded, organic shape. However, once the smooth tool had been invoked, the mesh 
would become too dense to modify in any controllable way (unless I were to de-activate 
the smoothing node in the object's history, modify the cube shape, and then apply a 
new smooth effect). Fortunately, on page 217 of the Maya Polygonal Modeling manual, 
Alias/Wavefront provides Maya users with a very handy mel script which allows artists 
to modify a low-poly mesh while a duplicate, smoothed version interactively updates. 
Dirk Bialluch has elaborated on this concept, with a very complete and elegant mel 
script named Connect Poly Shape, which can be downloaded from his website. 
Typically, mel scripts are placed in the following directory:  
 
[root]:\\WINNT\Profiles\[user]\maya\scripts 
 
Once installed, the user can generally run a mel script by entering the name of the script 
in the command line (in the lower-left corner of the screen) followed by a semi-colon. 
Because Dirk Bialluch's Connect Poly Shape script has multiple components (including 
shelf icons and help files), installation of his script is a bit different and is detailed on his 
website and in the readme.txt file included in the zipped download. Smoothed, high-poly 
3D characters can be created without this sort of mel script, however the artist will 
continually need to deactivate then reapply smoothing as the model is constructed.  

http://dirk-bialluch.mayaring.com/mel/html/connectPolyShape.shtml#_blank
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Once the Connect Poly Shape mel script has been invoked, an options window will 
appear that allows the artist to specify smoothing parameters, designate whether the 
smoothed duplicate will inherit the transforms of the original low-poly mesh, disable the 
shading of the low-poly mesh, assign the low poly cage and smoothed geometry to 
different display layers, and even mirror and merge the geometry. Typically, I toggle the 
Keep Border option off. I also prefer to make the layer containing the smoothed 
geometry a "reference" layer, so that I can more easily select points on the low-poly 
cage without inadvertently selecting the smoothed mesh. Simply toggle the Disable 
Selection option on and the resulting smoothed geometry will be assigned to a non-
editable display layer. I may also choose to modify the divisions attribute to either 
increase or decrease smoothness. Generally, however, it is a good idea to keep the 
number of divisions to an absolute minimum until it comes time to apply textures or 
render the scene.  

 

Pressing the Connect Poly Shape button in the options window creates a smoothed 
duplicate which will update as the low-poly model is manipulated, allowing the artist to 
create a very smooth, highly tessellated model by modifying only the simple, low-poly 
"cage."  
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Since heads are generally symmetrical, I like to create a mirrored instance of the shape 
(scaled to -1 in the X axis) so that I can work on just one half of the face, while the other 
half is simultaneously created. Since my original cube was 1 unit large, I translate both 
the smoothed and low-poly models to the right (positive X) .5 units, so that one side of 
the models sit along the Z axis at "X=0."  

 

Next, using the insert key, I move the pivot point of the smoothed cube back to the 
origin (X=0)  

 

Then, I select and delete the interior face of the low-poly cube.  

 

I am now ready to create the mirrored instance copy of the smoothed half, using a 
negative X scaling. Since the smoothed version of my model was automatically 
assigned to a reference layer, I will need to click on the layer containing the smoothed 
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geometry (named cpsResult) and select Standard from the drop down menu so that the 
object can be selected from a camera view. I then duplicate the smoothed model with 
Edit>Duplicate>Options set as follows:  

 

The result will be a full, shaded, smoothed shape which will update as I manipulate the 
low-poly cage. 
 
Note: I could have automated much of this mirroring process early on using the mirror 
and stitch settings in the Connect Poly Shape options window. However, in this exercise 
I have opted to mirror the smoothed geometry manually for clarity. 

 

Now, the actual character modeling process begins. Maya offers a wide range of 
polygonal modeling tools, but with this setup, I generally use only three tools: namely, 
the Split Polygon Tool, the Extrude Face tool, and occasionally the Append to Polygon 
Tool. Although the low-poly mesh will always be quite manageable in wireframe mode, I 
want to add detail only where it is absolutely necessary to define the shape of the 
character (which is why I always start building my characters with a cube). It is 
important to remember that this low-poly mesh will eventually be used to create a wide 
range of different facial expressions for this character, so keeping the number of points 
to a minimum will simplify the process of creating these facial variations. Additionally, 
each new polygon on this low-poly cage results in a significant number of polygons on 
the smoothed duplicate, so for the sake of performance during the modeling phase, and 
also later when it comes time to render, it is important to add detail sparingly. 
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Beginning with the Edit Polygons>Split Polygon Tool tool, I begin adding detail and 
moving vertices into position.  

 

Using the Edit Polygons>Extrude Face tool, I add detail to protruding and recessed 
areas (like the nose, eyes, and mouth). You will notice that faces extruded along the 
interior border edge result in the creation of new interior faces.  

 

I delete these new interior faces so that I may modify the profile of the face as desired.  

 

I continue adding detail using the Extrude Face and Split Polygon tools until I have 
enough detail to begin refining areas of the model, pushing and pulling the vertices into 
the right position.  
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As the modeling process continues, I may notice that my wireframe performance is 
becoming very sluggish. In part, this is simply due to the large number of polygons 
being drawn on the smoothed model. However, the more substantial performance hit is 
actually the result of the extensive INPUT history which accumulates as the low-poly 
model is being created. To improve performance, select the low-poly cage, then select 
Edit>Delete by Type>History. The history of the low-poly object will be deleted, but its 
connection to the smoothed duplicate will remain intact. 

From this point forward, the modeling process should be fairly intuitive. A couple tips to 
keep in mind: 1) try to avoid creating polygons on the low-poly cage that have more 
than four sides (otherwise, the smoothed results will be less predictable), and 2) be sure 
to keep all interior edge vertices of the character head at X=0 so that an open seam 
does not appear between the two halves of the head. 
 
A couple hours into the modeling process, I generally add eyes to the character (in this 
case, they are simply NURBS spheres), so that I can get the shape of the eyebrows and 
eyelids correct.  

 

Most of the process is really just a matter of refinement. This stage can be very time 
consuming (it took me about six hours to get to a point where I felt this model was true 
to my original sketches), but in many ways it is the most gratifying step. 
 
Once the refinement process is finished, I generally delete the smoothed duplicate 
geometry in order to simplify my scene for the skinning and animating stage. I am left 
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with a finished, low-poly half face which I mirror and merge using the Polygons>Mirror 
Geometry>Options tool, as shown:  

 

This final, low-poly head can now bound to a skeleton and animated, then smoothed 
using Edit Polygons>Smooth.  

 

In my next tutorial, I will discuss how to texture a model created using subdivision 
emulation 

Modeling an Island 

NURBS Island 

Using what we have learned from the previous lessons on NURBS modeling and tools, 
lets model a tropical get-away!  

Mountain Range 

1. Let‘s use the Birail 3+ tool to create our mountains. Create two curves in a semi circle 
shape. These will be our rail curves. 
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2. Create a series of curves with varying heights to be the high and lows of the 
mountain. 

 

3. Hit the Birail 3+ tool and select all the riders in a clockwise motion, hit enter and 
select both the rails. 

 

4. Delete history on the NURBS surface. 

5. Create two more curves at the ends of the rail curves. These will be our mountain 
base curves. 

 

6. Select the curves that form the ends of the mountain and break them into two curves 
(Edit Curves > Detach Curve). 
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7. Select the base curves and the two broken curves and hit Surface > Boundary. 
Repeat this step for the other end of the mountain.  

8. Create a layer and put the mountain in it. Name the layer Mountain and turn it to 
reference mode. Now our mountain is complete. 

9. Save your file. 

 

Beach 

1. Select the original rail curves and duplicate them. 

 

2. Create another layer and name it Beach. Put the duplicated curves in there. 

3. Create two more curves that will close off the rail curves. 
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4. Attach these new curves and round out the edges so they aren‘t so sharp. 

5. Move the CVs around so that they reach out beyond the mountain‘s base. 

6. Delete the curve‘s history. 

7. Create two more curves (riders for the beach surface) and use the Birail 2 tool. 

 

8. Delete history on the beach surface. 

9. Break the two beach rider curves in half. 

10. Select both parts of one beach rider and the end curve to the beach and use the 
Boundary tool to create geometry that would close off the open part of the beach. 
Repeat this step for the other side. 

 

11. Save your file. 

Beach Hut 

1. Lets create our beach house of out bamboo stalks. Create a series of NURBS Cirlces 
as illustrated below. 

2. Scale a few circles in and move them closer to another circle (so that they almost sit 
within a larger circle). 
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3. Create three separate lofts. 

 

4. Select each loft and Attach Surface. 

5. Duplicate the end circles and scale them in. 

6. Select the end circles and create a loft out of them. We‘ll use these as the thickness 
of the bamboo shoots. 

 

7. Select the end lofts and Attach Surface.  

8. Delete the history of the shoot and center the pivot. Now we have our template 
bamboo shoot. From here, we‘ll duplicate them several times to make walls, a floor and 
a ceiling. 

9. Select all the bamboo shoots and group them (ctrl-g). Also center the pivot on this 
group. 
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10. Copy one of the bamboo shoots and place it at the four corners of the floor. Rotate 
them so that they stand upright as illustrated below.  

 

11. Duplicate the floor group and rename it to roof. Rotate slightly and move the roof 
group up to the approximate location illustrated in the following image: 

 

12. Duplicate the floor group again and sit it upright as the rear wall. 
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13. Duplicate the back wall three more times and make adjustments for windows and a 
door. 

 

14. Create a layer and name it Beach_house. Put all beach house in that layer. 
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15. Turn the beach and mountain layers back on and scale the beach house group so 
that it fits nicely on the beach. 

Palm Trees With Leaves 

1. Turn off all the other layers and create a new layer named Tree. 

2. Create a series of circles that goes up like a palm tree. Scale each circle smaller and 
smaller as you make your way up to the top. 

 

3. Select the bottom circle and select each one up till you reach the top one and create 
a loft out them. This will be the basis for the trunk of the tree.  

4. Now lets create a leaf. Go to the top view and create a series of curves that will 
outline half of the shape of the leave. 

 

5. Cut the curve and then get rid of the unwanted pieces. Attach the curves. 
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6. Use Duplicate negative X on Scale to mirror the curves. 

 

7. Reverse curve direction of the new curve. 

8. Delete the history of both the curves. 

9. Select both of the curves and create a loft out of them. 

10. Insert three isoparms running the long length dividing the leave. 

 

11. With the loft still selected, create a lattice with 5x2x5 divisions. 

12. Select the lattice points and push and pull them around until you have a nicely 
sculpted leave. 
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13. Delete the history. 

14. Move the pivot point by hitting the insert key and move it to the beginning of the 
leave. Hit the insert key again to turn of move pivot option. 

15. Move the leave to the top of the tree and duplicate it many times translating, rotating 
and scaling each one. 

 

16. Select all the leaves and the tree and group them. Center the pivot and put them all 
in the Tree layer. That completes Nurbs Island. 
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Other items you could add to this model: 

 Canoe 
 Volcano top 
 Cave in the side of the mountain  
 Fruit hanging from the trees  

Molecular Data In Maya. Paint Effects 

Paint Effects is a component of Maya used to quickly and easily paint brush strokes and 
particle effects on a 2D canvas or on or between 3D geometry.  

You can use Paint Effects as a traditional paint program to paint images on a canvas, or 
to paint repeatable textures that you can apply to geometry in your scenes.  

 

Paint Effects goes beyond traditional painting—you can paint entire particle effects on 
your canvas or scene with a single brush stroke. On a 2D canvas a single brush stroke 
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can produce complex images, for example trees or flowers. In your scene, that same 
brush stroke produces these entities three-dimensionally. Imagine being able to paint an 
orchard in your scene where the painted trees exist as objects that your characters can 
move around. You can also apply dynamic forces to the effects you paint in your scenes 
and animate the display and movement of the effects. For example, you can make 
plants grow, make long hair blow in the wind, or make a river flow.  

How the Paint Effects Tool works 

The Paint Effects Tool works like a paintbrush. When you drag with the Paint Effects 
Tool, you create a stroke. A stroke is a collection of curves with attributes that define 
how the paint is applied along the stroke path. You can paint strokes on a 2D canvas to 
create 2D images or textures, or you can paint strokes in a scene to create paint effects 
in true 3D space.  

Brushes  

The attribute settings that define the appearance and behavior of a stroke are 
collectively called a brush. When you paint a stroke, Paint Effects creates a new brush, 
copies the template brush settings to the new brush, then attaches the new brush to the 
stroke, giving the brush a unique name.  

The template brush is simply the collection of attribute settings that define the brush to 
be attached to your next stroke. Think of it as your paint can—the place you mix your 
paint before applying it. Any changes you make to the paint in the can (the attribute 
settings in the template brush) affect what your next stroke looks like, but they do not 
affect any previous strokes made with paint from that can (the template brush).  

You can save brushes so that specific combinations of attribute settings are available 
when you need them. Saved brushes are called preset brushes. When you select a 
preset brush, its settings are copied to the template brush, where you can tweak them 
before painting your stroke. Any tweaks or changes you make to the settings in the 
template brush are not made to the selected preset brush, unless you explicitly save 
them. You can create your own preset brushes or use the preset brushes that ship with 
Paint Effects.  

Strokes  

A Paint Effects stroke is a curve attached to a hidden underlying NURBS curve (or 
curves). The underlying NURBS curve defines the shape of the stroke path.  

When you paint a stroke on a 2D canvas, Paint Effects applies paint along the stroke 
path according to the template brush attribute settings, then discards the stroke 
geometry. Because there is no geometry on the 2D canvas, you cannot modify the 
strokes or the attached brushes after you have painted them.  
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When you paint a stroke in a 3D scene, Paint Effects saves the stroke with the scene. 
Because strokes are geometry, they have construction history and they are editable. 
You can modify a stroke‘s attributes, transform a stroke, change its shape, modify the 
number of CVs on the stroke path curve, and reset the attributes of the brush attached 
to the stroke. You can even attach brushes to existing NURBS curves to create strokes.  

Although by default each stroke has a unique brush attached to it, you can force strokes 
to share a single brush. When stokes share a brush, any changes you make to the 
brush affect all the strokes that brush is attached to.  

Types of strokes  

There are two basic kinds of strokes: simple strokes and strokes that simulate growth.  

Simple strokes  

On simple strokes, paint is applied directly along the stroke path.  

 

Strokes simulating growth  

Strokes with tubes simulate organic growth. As you paint, tubes sprout from the stroke 
path, like plants growing from a path of seeds. The tubes grow, split, and expand in 
discrete steps along the stroke path, growing a segment longer at each step.  

Here‘s how it works. As you paint the stroke, Paint Effects samples points on the stroke 
path based on input from your mouse or stylus. When you paint the stroke quickly, the 
sample points are farther apart, when you paint the stroke slowly, the sample points are 
closer together. When it samples a point, Paint Effects plants new tubes along the path 
between the last sampled point and the current one, then grows the previously planted 
tubes one more segment. When you finish painting the stroke, the tubes will either 
continue growing until they reach the end of their life span (defined by the number of 
tube segments), or they will stop growing, so that tubes near the end of the stroke are 
less complete than the ones at the beginning.  

Tubes can grow into an almost infinite variety of shapes and forms (for example, plants, 
hair, fire, and water) depending on the attributes you set for the stroke.  

On the 2D canvas, strokes with tubes can quickly produce complex images. In a 3D 
scene, the tubes can grow into 3D space.  
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How paint is applied to strokes  

Paint is applied to strokes in overlapping stamps when the stroke is rendered.  

If the stroke is simple (it has no tubes), the stamps are applied along the stroke path.  

 

If the stroke simulates growth (it has tubes), the stamps are not applied along the stroke 
path, but are applied along the tube paths.  

 

When you work on the 2D canvas, you immediately see the paint applied to the stroke. 
However, when you work in 3D in your scene, strokes are represented as wireframes. 
While a wireframe representation of a stroke provides quick, immediate feedback 
without diminishing performance, at times you will want to see what the stroke really 
looks like without having to do a post-process render. You can do this using an 
interactive stroke rendering mode in the Paint Effects panel called the scene painting 
view.  

The Paint Effects scene painting view is a snapshot of the scene view of your scene 
where you can view your strokes as wireframes, or you can apply paint to your strokes 
as you paint, in effect, rendering your strokes interactively.  
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Hair- Hair Dynamics 

Use hair caches 

You simulate hair by playing through the time slider (see Play a hair simulation). You 

can create a cache file to store all the positions of the hair curves during the simulation. 

This cache lets you quickly preview the results of the hair simulation without having to 

render. This offers many benefits, including scrubbing back and forth in the time slider 

and re-using a cache so you don't have to solve at render time.  

The main purpose of the cache is for batch render so:  

 you can do distributed rendering and have the simulation match exactly.  
 you can do batch rendering without Maya Unlimited licenses (Hair simulation 

requires Maya Unlimited). .  

Specifically you can:  

 Create a hair cache 
 Append to a hair cache 
 Truncate a hair cache 
 Delete a hair cache 

Create a hair cache  

To create a hair cache  

1. Select the hair system.  
2. Do one of the following:  

o Select Hair > Create Cache.  
o Select Hair > Create Cache > , set the time range and sampling settings 

and then click Create.  

 

 

 

http://download.autodesk.com/us/maya/2009help/files/Simulating_hair_Play_a_hair_simulation.htm
http://download.autodesk.com/us/maya/2009help/files/Simulating_hair_Use_hair_caches.htm#WS17956d7adbc6e736102de1b5117ae3225e2-7ffd
http://download.autodesk.com/us/maya/2009help/files/Simulating_hair_Use_hair_caches.htm#WS17956d7adbc6e736102de1b5117ae3225e2-7ffc
http://download.autodesk.com/us/maya/2009help/files/Simulating_hair_Use_hair_caches.htm#WS17956d7adbc6e736102de1b5117ae3225e2-7ffb
http://download.autodesk.com/us/maya/2009help/files/Simulating_hair_Use_hair_caches.htm#WS17956d7adbc6e736102de1b5117ae3225e2-7ff9
http://download.autodesk.com/us/maya/2009help/files/Hair__Create_Cache.htm
http://download.autodesk.com/us/maya/2009help/files/Hair__Create_Cache.htm
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You can select from the following options:  

Cache Time Range 

Select a time range for the cache. Use the time range as specified in the Render 
Settings or the Time Slider, or set a new time range with the Start/End option.  

Sampling 

Specify either Over or Under for sampling and then set a Rate value for sampling. The 
default value for Rate is 1.  

Append to a hair cache  

You can use Append to Cache to add the specified frames to the existing cache. If the 
range of frames you specify occurs earlier than the last frame in the cache, the 
overlapping frames are overwritten. You may want to append to a hair cache if you 
decide to render more frames than you originally had cache for.  

You might use the ―append and truncate a cache‖ workflow if you're hand-tweaking the 
behavior of your hair. For example, cache a simulation for a while, truncate it at or 
before the frame where some hairs do something you don't want, modify some 
attributes, cache for a while again until you notice some behavior that you want to 
change. See To truncate a hair cache.  

To append to a hair cache  

1. Select the hair system.  
2. Select Hair > Append to Cache > . The Append to Hair Cache Options window 

appears.  

You can select from the following options:  

Append Time Range 

Select a time range to append to the cache. Use the Current Time (applies a 
single frame), Current Time to Time Slider End, or set a new time range with the 
Start/End option.  

Sampling 

Specify either Over or Under for sampling and then set a Rate value for 
sampling. The default value for Rate is 1.  

1. Set the append options and then click the Append button.  

http://download.autodesk.com/us/maya/2009help/files/Simulating_hair_Use_hair_caches.htm#WS73099cc142f48755-3d114b751181c40f14b3368
http://download.autodesk.com/us/maya/2009help/files/Hair__Append_to_Cache.htm
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Maya appends the new cache information to the existing cache file for the hair 
system according to the options you set.  

Truncate a hair cache  

You may want to truncate a cache for one of the following reasons:  

 If your modifications only start affecting the behavior of your hair dynamics 
partway through the cache, and you only want to re-cache form the point where it 
changes.  

 If you don't want or need the tail end of your simulation.  

To truncate a hair cache  

1. Select the hair system with the cache you want to truncate.  
2. In the Time Slider move to the frame where you want to truncate the cache.  
3. Select Hair > Truncate Cache. Maya deletes the cache from the current frame 

forward.  

Delete a hair cache  

You may want to delete your hair cache for one of the following reasons:  

 If you modify a dynamic hair simulation after caching, you must disable or delete 
the cache so that the modifications appear when you play the hair simulation.  

 You must re-create the cache before you (distributed) render your hair.  
 You can delete the cache to free up disk space.  

Dynamics and Effects 

 Topics in this section 

    Dynamics 

    Hair 

    Fluid Effects 

    Fur 

    Live 

    Dynamics 

 

http://download.autodesk.com/us/maya/2009help/files/Hair__Truncate_Cache.htm
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Introduction To Dynamics 

 Dynamics is a branch of physics that describes how objects move. Dynamic animation 

uses rules of physics to simulate natural forces. You specify the actions you want the 

object to take, then let the software figure out how to animate the object.  

Dynamic animation lets you create realistic motion that‘s hard to achieve with traditional 
keyframe animation. For instance, you can make effects such as tumbling dice, waving 
flags, and exploding fireworks.  

To get started quickly using Maya® Dynamics™, see the Dynamics lessons in the 
Getting Started with Maya tutorials.  

Click the image below to play an animation showing a software-rendered particle cloud.  

Reactor.mov 

 

Software-rendered cloud particles make realistic steam.  

Hair overview 

Maya Hair is a component of Maya Unlimited that you use to create a dynamic hair 
system so you can model realistic hairstyles and hair behavior. Since Hair is a generic 
dynamic curve simulation, you can also use these curves to create non-hair effects.  

With Hair you can simulate:  

 natural movement and collisions of long hair  
 hair blowing in the wind or being blow dried  
 hair when swimming underwater  
 various hairstyles, including ponytails, braids, and updos  
 other dynamic curve effects such as ropes, chains, cables, wires, a suspension 

bridge, sea creatures, or even a lofted surface from a curve. For more 
information, see Creating other models and effects with hair.  

http://download.autodesk.com/us/maya/2009help/Movies/Reactor.mov
http://download.autodesk.com/us/maya/2009help/files/Creating_hair_Creating_other_models_and_effects_with_hair.htm
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To get started quickly using Maya Hair, a Hair tutorial is included with Maya. The Hair 
tutorial is one of the many comprehensive tutorials in the Getting Started with Maya 
Unlimited guide. To access the Hair tutorial, select Help > Tutorials.  

To play the animation, click the link below.  

longHair.mov 

 

Hair connections  

A hair system is a collection of hair follicles. A NURBS or polygonal surface can have 
multiple hair systems on the same surface and one hair system can span multiple 
surfaces.  

A hair follicle in human hair typically hosts one hair, whereas in Maya each hair follicle 
hosts a hair curve. The hair follicle controls the attributes and curves associated with a 
particular hair clump, and how the hairs attach to a NURBS or polygonal surface. The 
input to each follicle is a Start Position NURBS curve, a surface and a UV position to 
attach to.  

When creating hair, the hair system output can be in the form of NURBS curves, Maya 
®Paint Effects™ strokes, or both. If the specified output when creating hair is NURBS 
Curves, each follicle will contain one NURBS curve that represents the position of the 
hair in that follicle. If the specified output is Paint Effects, each follicle has a hair clump, 
made up of Paint Effects strokes.  

There are various attributes on a hair system for modifying the look and behavior of the 
hair as a whole. There are also follicle level attributes that will override the hair system 
attributes; the visible result will be affected by both the follicle and hair system 
attributes.  

Paint Hair Tool 

With the Paint Hair Tool you can create hair, add and remove follicles, as well as paint 
follicle attributes, including Hair Scale, Stiffness, and Braid.  

Rendering Hair  

http://download.autodesk.com/us/maya/2009help/files/WS73099cc142f48755-3d114b7511841aefa9f-563e.htm
http://download.autodesk.com/us/maya/2009help/Movies/longHair.mov
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Paint Effects hair can be rendered using the Maya Software renderer. You can also 
convert Paint Effects hair to polygons and render in another renderer, such as mental 
images® mental ray®. Or you can output just the dynamic NURBS curves to an external 
renderer, such as Pixar® RenderMan®.  

Hair Output  

Consider outputting Hair to Paint Effects if you want to:  

 render with the Maya Software renderer  
 convert the Paint Effects hair to polygons and render in any renderer  

Consider outputting Hair to NURBS curves if you want to:  

 use the curves for output to another renderer that directly supports curve 
rendering.  

 select a few Current Position curves and loft a surface through them with 
construction history.  

 extrude a circle down the curve to create a tube.  
 use the curves as path or control curves for any standard Paint Effects brush, 

such as feathers or vines. These brushes behave differently than the default 
built-in Paint Effects as the curves are not the hairs, but controls that interpolate 
and affect Paint Effects. This scenario is slower to update and takes a bit of time 
to set up. Alternatively, you could just assign a Paint Effects brush to a hair 
system (you don‘t need NURBS Curves output for this).  

Consider outputting Hair to both NURBS curves and Paint Effects if you want to:  

 use both the curves (for example, as particle emitters to simulate spray flying off 
wet hair) and render using the integrated Paint Effects either directly or by 
converting to polygons. 
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Particle Emission 

Realistic atmospheric effects, such as 
clouds, mist, fog, steam, and smoke.  

cloudFlythrough3.mov 

 

Pyrotechnics, such as fire, explosions, and 
nuclear blasts.  

nuclearBlob.mov 

 
Viscous fluids, such as molten lava and 
mud. 

Open water, such as calm or rough oceans 
with white caps and foam.  

http://download.autodesk.com/us/maya/2009help/movies/cloudFlythrough3.mov
http://download.autodesk.com/us/maya/2009help/movies/nuclearBlob.mov
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lavaflow.mov 

 

oceanSwells.mov 

 

SPEffects.com 

The official Blog of Surrealistic Producing Effects, LLC. 

 Website Home 
 Blog Home 
 About us 

Create a dynamic collision between two objects, leaving a dent on one of the 

objects. 

March 31st, 2008 | by Todd Palamar |  

Soft Body Collisions 

 

Elements: 

1. NURBS Sphere 
2. Polygon mesh 
3. Duplicate polygon mesh 
4. Gravity Field 

http://download.autodesk.com/us/maya/2009help/movies/lavaflow.mov
http://download.autodesk.com/us/maya/2009help/movies/oceanSwells.mov
http://speffects.com/blog/
http://www.speffects.com/
http://speffects.com/blog
http://speffects.com/blog/about/
http://speffects.com/blog/2008/03/create-a-dynamic-collision-between-two-objects-leaving-a-dent-on-one-of-the-objects/
http://speffects.com/blog/2008/03/create-a-dynamic-collision-between-two-objects-leaving-a-dent-on-one-of-the-objects/
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Overview: In our first example we have a ball crashing into a moving cube. Upon impact 

the ball will bounce off the cube leaving a dented surface on the cube. To create this 

effect, we use a soft body particle system attached to a subdivided polygon mesh. 

The ball is made into an active rigid body with which you can establish interaction with 

the particles of the soft body. Particles themselves do not act upon rigid bodies, 

meaning they do not affect rigid body transforms. 

It only works the other way around. Rigid bodies can move particles! Because of this, 

we need another element, a second passive rigid body cube for the ball to bounce 

against. By adding some gravity and two key frames our simulation is complete. 

Getting Started… 

1. First, lets run through a real simple scene to get acclimated with the tools. (If you are 
already familiar with soft/rigid body operations jump to the More Advanced section.) 
Create a primitive NURBS sphere using the defaults. Rename it to ball. 
Transform the sphere. (Figure 1) 

 

 Translate X = -4 
 Translate Y = 5 
 Scale X = .5 
 Scale Y = .5 
 Scale Z = .5 

2. Create a primitive polygon cube using the defaults. We will keep its name, 
pCube1. 
Transform the cube. (Figure 2) 
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 Translate Y = .5 
 Scale X = 3.5 
 Scale Z = 1.6 

Change pCube1‘s subdivision inputs. Select the cube and in the channel box select the 
words polyCube1. Change the following inputs: 

 Subdivisions Width = 35 
 Subdivisions Height = 10 
 Subdivisions Depth = 16 

This adds more geometry to the entire cube. The purpose is to provide some detail for 
our dent. Next, 

 choose Modify > Freeze Transformations and Edit > Delete By Type > History. 

When dealing with simulation it is important to always make sure your geometry is clean 
of history and transforms. 

3. Duplicate pCube1 and use its duplicate name, pCube2. 

Transform the cube. (Figure 3) 

 

 Translate Y = -1 
 Scale X = .8 
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 Scale Y = .8 
 Scale Z = .8 
 Next, choose Modify > Freeze Transformations and Edit > Delete By Type > 

History. 

4. Now, let’s make pCube1 a soft body. This is the important part. 

 Choose Soft/Rigid Bodies > Create Soft Body and open the tool options box. Set 
Create Options to Make Soft. 

By doing this all of the other options are grayed out. This creates a soft body object 
without a goal. Basically, it creates a particle for each vertex, making each one dynamic. 
At this point, they are at the mercy of Newton‘s laws of physics and no longer under 
your control. To gain some control back, you must set the Conserve on the newly 
created particles to zero. 

***Note*** Open the outliner (Window > Outliner). Click on the plus sign next to pCube1. 
This reveals the connected particle shape. Select it. In the channel box, under 
pCube1ParticleShape, find Conserve; the eighth attribute down. Set it to zero. (Figure 
4) 

 

You can think of the conserve as Newton‘s law, an object in motion tends to stay in 
motion. By reducing this value you reduce the effects of this law. Setting it to zero, turns 
it off. 

5. Select pCube2 and make it a Passive Rigid Body. (Choose Soft/Rigid Bodies > 
Create Passive Rigid Body) Use the defaults for all of the settings. Passive rigid bodies 
are full fledged rigid bodies, but allow you to key frame their transforms. 

6. Make pCube2 a child of pCube1. 

7. Next, let‘s animate pCube1. Set a key in its current position for the translate X. To 
key just the translate X attribute, click on the words TranslateX in the channel box. 
Press and hold the right mouse button down, scroll down to the second option in the list, 
Key Selected, then release the mouse button. For the next key, move forward in the 
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timeline to frame 60. Type a value of -7 for the TranslateX attribute and Key Selected 
again. (Figure 5) 

 

***Note*** 
You may have an update issue with your passive rigid body that is a child of pCube1. If 
pCube2 becomes separated from its parent pCube1, simply type in its correct value. 
You can get the value from pCube1‘s location. 

8. Our next step is to get the sphere to interact with our animated cubes. 

 Select the ball. Choose Fields > Gravity, keep the defaults. (By selecting the ball 
first and then choosing a field, Maya automatically makes the necessary 
connections to the ball.) Press play to view the simulation. At this point, the ball 
just bounces off pCube2. It is ignoring pCube1 all together. Rigid body collision is 
automatic in Maya 7, but particle collision is not. Select pCube1 and ball. Choose 
Particles > Make Collide tool options box. Change the options as follows. 

 Resilience = .5 
 Friction = .5 

9. Play through the animation again. This time the outer box, pCube1 gets dented 
where the ball makes contact. 

 Select pCube2 and hide it. To complete the effect hide pCube2 and the particles. 
(Figure 6 & QUICKTIME 1) 
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More Advanced… 

1. In this section, we follow the same basic setup as above. We have created a sphere, 
translated it appropriately, and added gravity to it. In place of the cube, we are using a 
more detailed piece of geometry, a polygon car. You can substitute the car for anything. 
(Figure 7) 

 

The first step, is to define the area of the model to be smashed, in this case, the hood. 
Select faces on the model and choose Edit Polygons > Duplicate Face. Make sure the 
Separate Duplicated Faces option is checked. Delete the history. Select the new object 
and add it to a layer for easier selection. This new geometry is what the ball will collide 
against. Translate it beneath its original faces, scale it if necessary, but position as deep 
as you want the dent. (Figure  

 

2. The hood itself has very few polygons in it. In order to make the dent look good we 
need to have a certain amount of faces. This can be done using any method or tool like, 
smooth or subdivide. For total control however, it is best to hand model the effect with 
the split polygon tool. To keep the geometry in quads and triangles always start and end 
at a vertex. Split the geometry up until you have a decent configuration. (Figure 9) 
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***Note*** It doesn’t matter if the geometry is attached or a separate model. You can 
parent it back the original. This also gives you the extra ability to alter the geometry 
freely without taking the entire object into consideration. 

3. Next turn the car into a soft body by choosing Make Soft from the Soft Body Creation 
Options. Remember t o set the Conserve to zero. 

4. Animate the object traveling into the path of the falling ball. After you perfect the 
timing, select the particles or the object they are attached to, and the rigid body ball. 
Choose Particles Make Collide. 

***Note*** 
If the particle collision or dent effect is not working, it could be due to the passive rigid 
body collision object too close to the particles. Try moving it a little further away from the 
them. 

5. To change how the ball reacts when it collides you can modify the bounciness and 
mass of both rigid body objects. Change the ball‘s mass to 600 and its bounciness to .1. 
Play through the simulation. The ball now hits with more of thud. To increase its impact 
even more change the passive rigid body bounciness to .1 as well. 

6. You can also modify the resilience and friction between the particles and active rigid 
body ball through the geoconnector node. This was created when you chose Make 
Collide from the Particle pull down menu. 

***Note*** This controls how the particles move. Change the settings to a Resilience of 
1 and a Friction of 0. The changes are subtly but can affect the way the dent looks. 

A quick way to access this node is to type geo* in the quick select box at the end of the 
status menu bar. By adding the wildcard * (asterisk) you select everything with the geo 
prefix. 

7. For a final touch, add a polygon plane for the floor. Scale it to fit all the elements. 
Freeze the transforms and Delete history. Make it a passive rigid body. 



349 | P a g e  

 

 

Particle Shading Script 

A MEL script that hooks your particle system up with a camera automatically, resulting 
in a z-depth/focus depth/height/age/etc shader, that can be used to render images 
meant to serve as an aid during compositing. This way you can e.g. render out 
hardware particles‘ depth channel with motion blur. 

Please note 

The script was written by Björn Henriksson and myself and has been tested on Maya 
version 5.0 and 6.5. 

Except being able to render the particles in the hardware batch renderer or hardware 
buffer you can also use other renderers such as Pixar Renderman. Note that if you want 
to render using Pixar Renderman, you will need to light your particles. One way to do 
this could be to just orient constrain a directional light to your camera. 

For those of you who need custom tailored shading, I‘ll try and explain how you can set 
up your own particle shading in the tutorial below. A couple of example scenes are 
available for download below: 

Tutorial, part 1: Depth shader 

 

http://www.bhenriksson.se/
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Okay, so you want to do some particle shading. First, create some particles and maybe 
add some fields to them to spice it up. Also create a regular camera. In my script below 
I assume that the name of the particles is ―particle1‖ and the name of the camera is 
―camera1‖. 

 

Let‘s start by making our own particle depth shader. 

Open up the particleShape1 in the attribute editor and scroll down to the per particle 
(array) attributes. Under the ―add dynamic attributes‖ section, hit the ―general‖ button. 
Here type distanceToCamPP into the attribute name field. Then tick the ―per particle 
(array)‖ option under attribute type. Hit ―OK‖. Now, under the ―add dynamic attributes‖ 
section, hit the ―color‖ button and choose ―add per particle attribute‖. You should now 
have two new attributes under the particleShape‘s per particle (array) attributes list in 
the attribute editor: distanceToCamPP and rgbPP. 

 

Right-click in the textfield next to rgbPP in the attribute editor and choose ―runtime after 
dynamics expression‖ (or in Maya 13, choose ―runtime expression‖). Type the following 
into the textbox: 

1. // DISTANCE BETWEEN PARTICLE AND CAMERA 
2. vector $camPosition = <>; 
3. vector $particlePosition = particleShape1.worldPosition; 
4. particleShape1.distanceToCamPP = mag($particlePosition-$camPosition); 
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5.   
6. // DEPTH DISTANCE 
7. float $depthDistance = cameraShape1.farClipPlane-cameraShape1.nearClipPlane; 
8.   
9.   
10. // DEPTH DISTANCE CONVERSION (RANGE NODE FORMULA) 
11. float $oldMin = 0; 
12. float $oldMax = $depthDistance; 
13. float $min = 0; 
14. float $max = 1; 
15. float $outValueDepth = $min + (((particleShape1.distanceToCamPP-$oldMin)/($oldMax-

$oldMin)) * ($max-$min)); 
16.   
17. // SET COLOR 
18. particleShape1.rgbPP = <>; 

…and hit the ―create‖ button! 

 

Now let‘s make the camera‘s clipping plane visible. Select camera1 and enable clipping 
planes (found in the ―camera/ligth manipulator‖ menu under the ―display‖ dropdown). 
Still having the camera1 selected, fire up the attribute editor and set the far clipping 
plane to a fairly low value, so that it ends just beyond the furthest particle (depth-wise). 
If you hit play and let your particles emit, you should be able to see their color ranging 
from black to white. It is completely black at the camera‘s near clipping plane and 
completely white at the camera‘s far clipping plane. 

Cool, you just made your own particle depth shader! 
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Tutorial, part 2: Combined particle depth & height shader 

 

The script that Björn and I have written asks you about what you want rendered in each 
of the RGB channels and then hooks your particle system up accordingly with a camera 
of choice. This is what we are going to take a look at next! 

Oh and by the way, if you were wondering, the expressions in our MEL script is much 
more optimized for performance and could be harder to grasp if you are learning to write 
your own expressions. 

 

Let‘s put the depth information and height information into the rg channels (we‘ll leave 
the b channel empty). This way we can access both the depth image and the height 
image from within the same file in our favourite compositing application. 

First, create two locators and name them roofLoc1 and floorLoc1. Place roofLoc1 below 
floorLoc1 and replace the old expression with this: 

1. // DISTANCE BETWEEN PARTICLE AND CAMERA 
2. vector $camPosition = <>; 
3. vector $particlePosition = particleShape1.worldPosition; 
4. particleShape1.distanceToCamPP = mag($particlePosition-$camPosition); 
5.   
6. // DEPTH DISTANCE (GREEN) 
7. float $depthDistance = cameraShape1.farClipPlane-cameraShape1.nearClipPlane; 
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8.   
9. // DEPTH DISTANCE CONVERSION (RANGE NODE FORMULA) 
10. float $oldMin = 0; 
11. float $oldMax = $depthDistance; 
12. float $min = 0; 
13. float $max = 1; 
14. float $outValueDepth = $min + (((particleShape1.distanceToCamPP-$oldMin)/($oldMax-

$oldMin)) * ($max-$min)); 
15.   
16. // HEIGHT DISTANCE (RED) 
17. vector $floorLocation = <>; 
18. vector $heightColor = (particleShape1.worldPosition - $floorLocation) / (roofLoc1.translateY-

$floorLocation); 
19. $outValueHeight = $heightColor.y; 
20.   
21. // SET COLOR 
22. particleShape1.rgbPP = <>; 

Don‘t forget to hit the ―edit‖ button to actually make the changes to the expression go 
through! 

You can now adjust the height range using the two locators …and voila, you‘ve got your 
own combined particle depth & height shader! 

Particle Speed 

 

There are situations where a phenomenon's velocity or speed is related to it's behavior 

or appearance. Perhaps the incandecence increases as a particle moves faster... or the 

color changes from blue to red. Perhaps some dust is resting on an object, but once it 

gets blown away it also begins to dissipate and fade. These effects can be achieved by 

understanding how to reference particle speed, which is not a default particle attribute. 
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Attributes related to speed which particles do have by default are velocity and 

acceleration. It is important to understand these for they can cause confusion for those 

new to this terminology. Everyone knows what speed is... we are reminded to be aware 

of it whenever we get in a car. Speed is a 'float' number which tells us how fast we are 

moving. Velocity and acceleration, however, are 'vectors', which not only tell us 

magnitude but also direction. A velocity of <<0,10,0>> tells us that a particle is moving 

in the positive Y direction with a speed of 10 units per second. An acceleration of 

<<0,10,0>> tells us that a particle is speeding up in the positive Y direction. Thus when 

trying to determine a particle's speed, our focus is on the velocity, not the acceleration.  

With this in mind, there are a couple ways we could query a particle's speed: custom 

variables or custom attributes. For example, assuming we have a particle object, 

particleShape1, which has the rgbPP attribute, we could write the following runtime 

expression: 

float $speed = mag(particleShape1.velocity); 

if ($speed > 5) 

particleShape1.rgbPP = sphrand(1); 

else 

particleShape1.rgbPP = rand(<<.2,.4,.6>>,<<.2,.5,1>>); 

The above expression will give us bluish particles unless they start moving faster than 5 

units/second at which point they would become rainbow colored. We defined a new 

variable called $speed which was assigned the magnitude of the velocity vector. The 

mag() function returns the magnitude of any vector by taking the square root of 

x2+y2+z2. So the magnitude of velocity is speed, which is useful when the directionality 

is not needed. An example where directionality is used would be: 

vector $velo = particleShape1.velocity; 

if ($velo.y > 5) 

particleShape1.acceleration += <<5,0,0>>; 

else 

particleShape1.acceleration += 0; 

The above will cause particles to speed up in X if their speed in Y is greater than 5. 

So custom variables have their place, as do expressions, but what if you want to color 

particles based on speed by using a color ramp. This is a case where we will need to 

define speed as a custom attribute. 

With general knowledge of the particle engine in Maya, one should be aware that there 

are many attributes which a particle shape node can have, but does not by default: 

radiusPP, goalU, spriteNumPP, etc. These attributes serve specific purposes when 
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added, yet we are also able to add 'custom' attributes to particle objects which do not 

serve any purpose when created. Their functionality is determined by the user by 

assigning them values to store, which other attributes may reference. 

So we want to create an attribute called 'speed'. With the particleShape node selected 

and the attribute editor open, in the Add Dynamic Attributes folder, click the general 

button. This opens the Add Attribute window which has three tabs. Select the left tab. In 

the name field enter 'speed', for attribute type choose 'float', Per Particle Array. With the 

attribute created, you will now see it listed in the Per Particle Array Attributes folder of 

the particleShape node. 

We chose PP Array because we want each particle to have its own speed attribute... as 

any particle's speed will likely be different from any other. Now that each particle has 

'speed', we need to assign it a value. We want to write a runtime expression as this is 

an attribute whose value changes over time: 

particleShape1.speed = mag(particleShape1.velocity); 

At this point any other attribute of the particleShape node can query this 'speed' 

attribute value. 

For example: 

particleShape1.opacityPP = particleShape1.speed; 

Would have the effect of getting particles to fade out when they stop moving. Although 

this relationship works well, it is not very complex. If you need particles to fade on when 

they begin moving but fade out when they reach a certain speed, a ramp may be the 

most efficient technique to design the relationship between opacity and speed. 

Likewise, if we want color to change based on speed, ramps are going to be our friend. 

Something you should know is that ramps are commonly connected to attributes such 

as rgbPP, opacityPP and radiusPP based on a particle's lifespan. This means that a 

particle's 'Age' determines where in the ramp the particle's attribute gets its value from. 

Well, what we want to do is not base the query on 'Age' but on 'Speed'. 

With 'rgbPP' and 'speed' already added to the particle object, right click on rgbPP in the 

Per Particle folder and go to the creation dialog window for Create Ramp. By default 

Input U is mapped 'none', and Input V is mapped to 'Age'. Change Input V to 'Speed'. 

As you can see, any per particle attributes which you have added will appear in this list.  
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At this point we have accomplished our goal to relate speed to a color ramp, but there 

are still a couple things left to do to get the right results. The obvious first thing to do is 

to edit the ramp with the required colors; perhaps blue at the bottom and red at the top. 

If you playback your scene, the particles will no doubt be using a color from the ramp, 

but the relationship of speed to the ramp will not necessarily be evident. This is because 

the ramp V positions go from 0 at the bottom to 1 at the top... but our particle speed 

attribute does not necessarily go from 0 to 1. But this is not to say that it can't. We 

simply need to edit the runtime expression for 'speed': 

particleShape1.speed = mag(particleShape1.velocity)/$topspeed; 

where $topspeed is a guesstimate of the top speed that any particle in the particle 

object will hit. It is not necessary to be completely accurate, as it makes little difference 

if only 50% of the color ramp is being used. Once $topspeed has been deduced, the 

effect should be clear, assuming that the particle's speed -is- changing. 

At this point there is an optional step which can be taking to increase the variety within 

the particle color (or whatever attribute you are relating to speed). Based on our current 

ramp set-up, all particles travelling the same speed will be the same color. This is 

because all particles are using the left most edge of our ramp (U = 0). What can be 

done is to add some variation to the ramp, using any technique available with Maya 

Textures (noise, color gain, etc), then have each particle use a different U coordinate 

along the ramp. 

Add a new attribute to the particleShape node called 'rand_u'. Then write the following 

creation expression to assign a random number to this new attribute: 

particleShape1.rand_u = rand(0,1); 

Where we previously had assigned 'Input U' to 'none' when we created the ramp, we 

now want 'Input U' to be mapped to the 'rand_u' attribute, while 'Input V' is still mapped 

to 'speed'. To change the mappings after a ramp has already been created, it is easiest 

disconnect/reconnect the ramp by right clicking on the attribute in the Per Particle Array 

Attributes folder. 
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So that about wraps it up... while there are many ways to incorporate this topic into an 

effect, below is a simple case where a turbulence field creates sudden speed changes 

which in turn are causing color shifts. 
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